User avatar
ebiian
Posts: 9
Joined: Thu Jul 19, 2012 7:25 am

USB and LAN is dead (solved)

Thu Jul 19, 2012 7:29 am

i think my USB and LAN is dead !
usb and lan worked until last week well. and now no led and nothing. i tried almost every image but nothing. :(

kadamski
Posts: 187
Joined: Fri Jun 08, 2012 10:56 pm

Re: USB and LAN is dead

Thu Jul 19, 2012 8:07 am

LAN and USB are connected the same way to the SoC, they are both connected to internal USB. So unfortunately it is possible that they both broke for the same reason. What is the output of your lsusb command? Do you have eth0 interface in your system or it is gone?

User avatar
ebiian
Posts: 9
Joined: Thu Jul 19, 2012 7:25 am

Re: USB and LAN is dead

Thu Jul 19, 2012 8:37 am

How should i do the lsusb-command? The keyboard is a usb device which does not work!

zardoz99
Posts: 175
Joined: Fri Jan 13, 2012 2:25 pm
Location: Somewhere in Canada.

Re: USB and LAN is dead

Thu Jul 19, 2012 9:07 am

What you could do is put the command into /etc/rc.local or the equivalent for your distro using a PC running Linux and have it run at boot time with the output going to the console..

Z.

alexchamberlain
Posts: 121
Joined: Thu Jun 14, 2012 11:20 am
Location: Leamington Spa, UK
Contact: Website

Re: USB and LAN is dead

Thu Jul 19, 2012 9:14 am

You could try flashing a new SD card, and test it to see if it is a hardware problem?
Developer of piimg, a utility for working with RPi images.

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12327
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: USB and LAN is dead

Thu Jul 19, 2012 9:26 am

Maybe a bad solder job on crystal X1, if when plugging in a network cable (connected to a netwerk device obviously) none of the ethernet LED's on board light up, its most probably a hardware problem, not a software problem.

User avatar
ebiian
Posts: 9
Joined: Thu Jul 19, 2012 7:25 am

Re: USB and LAN is dead

Thu Jul 19, 2012 11:14 am

i will try another sd-card in the afternoon, put the lsusb command into /etc/rc.local
and check the soldering of x1.
is it possible, that the whole ic (lan9512 responsilbe for lan and usb) is soldered bad ?

User avatar
AndrewS
Posts: 3625
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
Contact: Website

Re: USB and LAN is dead

Thu Jul 19, 2012 11:20 am

Might be worth trying a different PSU, in case your PSU (for some reason) is no longer able to supply enough power to the USB chip?
If it is a hardware problem with your RPi, you should be able to send it back under warranty (as long as you haven't over-volted).

User avatar
ebiian
Posts: 9
Joined: Thu Jul 19, 2012 7:25 am

Re: USB and LAN is dead

Thu Jul 19, 2012 12:17 pm

an other psu i tried already - nothing changed.
i haven't overvolted until jet but i don't know how much it costs to send my rp back (austria to uk - i ordered it directly form rs-uk)

User avatar
ebiian
Posts: 9
Joined: Thu Jul 19, 2012 7:25 am

Re: USB and LAN is dead

Thu Jul 19, 2012 7:29 pm

:D SOLVED !
it was x1 !
thank you for your help !

User avatar
AndrewS
Posts: 3625
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
Contact: Website

Re: USB and LAN is dead

Thu Jul 19, 2012 10:19 pm

Great news :)
How did you fix it BTW? (in case anyone else has the same problem)

User avatar
ebiian
Posts: 9
Joined: Thu Jul 19, 2012 7:25 am

Re: USB and LAN is dead (solved)

Fri Jul 20, 2012 7:10 am

i used my hot air solder station: http://www.aoyue.de/index.php/cat/c251_ ... ation.html
about 270 °C and heated up mainly the crystal x1 and also all solder points in this area (but not the chip ic3 - lan9512) ;)

User avatar
AndrewS
Posts: 3625
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
Contact: Website

Re: USB and LAN is dead (solved)

Fri Jul 20, 2012 10:01 am

Bye-bye warranty ;)

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12327
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: USB and LAN is dead (solved)

Sat Jul 21, 2012 7:39 pm

Good work!, and in practical terms the warranty will only be (seen to be) expired when its clear (by molten plastic parts etc) that you did something to the board. Not that I advocate the unwary reader to put his :mrgreen: hairdryer to the test on the R-PI LOL.

Return to “General discussion”