woocaash
Posts: 5
Joined: Mon Apr 19, 2021 9:03 pm

Pi 400 bluetooth disaster

Mon Apr 19, 2021 9:17 pm

Is there support for Raspberry Pi 400? I purchased this unit and it should have bluetooth. Maybe it has but unfortunately it does not work.
Is there a warranty ? What kind of company does not support their product ? You are buying something and you are stuck with it ???
I have spent hours reading forums and playing with it. Honestly I would return it as soon as possible. You pay money for something and this thing is not working. I did dozens of new clean installations, updates, upgrades, file editing, adding comments etc etc and bluetooth is not working. To be honest I should not be doing all that. Product should come working. And I am not alone. There are plenty of posts from different people all over the internet. The complaints started in November. My bluetooth units are working on another machines with no problem...

fruitoftheloom
Posts: 26505
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Pi 400 bluetooth disaster

Tue Apr 20, 2021 11:41 am

woocaash wrote:
Mon Apr 19, 2021 9:17 pm
Is there support for Raspberry Pi 400? I purchased this unit and it should have bluetooth. Maybe it has but unfortunately it does not work.
Is there a warranty ? What kind of company does not support their product ? You are buying something and you are stuck with it ???
I have spent hours reading forums and playing with it. Honestly I would return it as soon as possible. You pay money for something and this thing is not working. I did dozens of new clean installations, updates, upgrades, file editing, adding comments etc etc and bluetooth is not working. To be honest I should not be doing all that. Product should come working. And I am not alone. There are plenty of posts from different people all over the internet. The complaints started in November. My bluetooth units are working on another machines with no problem...

The Warranty is undertaken from whoever you purchased it from ;)
The information is out there....you just have to let it in.

My other Linux machines: ChromeBox
https://www.aliexpress.com/item/32966393971.html
& Stone Desktop Intel CoreDuo circa 2010

Undertow
Posts: 29
Joined: Thu Feb 18, 2021 2:00 pm

Re: Pi 400 bluetooth disaster

Tue Apr 20, 2021 1:19 pm

I'm typing this on a Pi 400 and it is paired to bluetooth mouse and bluetooth headphones and works perfectly well (under Raspberry Pi OS and Ubuntu).

However when I first booted it up with factory supplied SD and upgraded a component needed for bluetooth audio needed to be installed manually. From previous posts in the forum it is obvious some people hit the same problem and tried to fix the broken audio with stuff from the web which could break bluetooth completely. Some do seem to have other strange issues though.

That said if you have tried completely fresh downloads then maybe you do have a hardware fault. Why not as a test try a download of Ubuntu Desktop 20.10 https://ubuntu.com/download/raspberry-pi and see if bluetooth works there? If it doesn't then hardware fault seems likely. If it does work then we can figure out what your problem is knowing that it is software not hardware.

gordon77
Posts: 5597
Joined: Sun Aug 05, 2012 3:12 pm

Re: Pi 400 bluetooth disaster

Tue Apr 20, 2021 2:11 pm

woocaash wrote:
Mon Apr 19, 2021 9:17 pm
Is there support for Raspberry Pi 400? I purchased this unit and it should have bluetooth. Maybe it has but unfortunately it does not work.
Is there a warranty ? What kind of company does not support their product ? You are buying something and you are stuck with it ???
I have spent hours reading forums and playing with it. Honestly I would return it as soon as possible. You pay money for something and this thing is not working. I did dozens of new clean installations, updates, upgrades, file editing, adding comments etc etc and bluetooth is not working. To be honest I should not be doing all that. Product should come working. And I am not alone. There are plenty of posts from different people all over the internet. The complaints started in November. My bluetooth units are working on another machines with no problem...
It might be useful to detail what you have tried. Are you uisng PiOS ?. Does the Bluetooth device show when you do Add Device ? Does it pair? Etc

Undertow
Posts: 29
Joined: Thu Feb 18, 2021 2:00 pm

Re: Pi 400 bluetooth disaster

Tue Apr 20, 2021 2:16 pm

One thing further is that I do have some tricky devices (a mini keyboard/touchpad combo in particular) which is difficult to pair through the gui and I usually end up doing it via bluetoothctl and it usually pairs on the 2nd attempt. Once paired though it stays that way.

So you could try from the command line
bluetoothctl
then type the command "scan on" (without quotes) at the bluetooth prompt. Does it find anything?

woocaash
Posts: 5
Joined: Mon Apr 19, 2021 9:03 pm

Re: Pi 400 bluetooth disaster

Wed Apr 21, 2021 12:27 am

Hi

Mostly it is:
"Pairing failed - GDBus.Error:org.bluez.Error.AuthenticationFailed"

sometimes this:
"Pairing failed - GDBus.Error:org.bluez.Error.Already Exists"


unfortunately raspberry pi screen shot is to big to attach
I wil also try another OS. Good idea.

SO far I tried Raspberry OS. I don't have official card but downloaded official imager.
Tried all 3 versions of Raspberry Lite, recommended, and full. Couple times each.

I had it working in the past. I had to restart Bluetooth every time. It was a single line command. I think it was "sudo systemctl restart bluetooth but I should not be restarting Bluetooth all the time. I saw many comments from November and treated it as a bug. I thought it should be fixed soon. We have April. Same all on my side...

Also. When the speaker was connected the volume was very very low. It was set at 100% everywhere but sounded like 20%

thank you
Last edited by woocaash on Wed Apr 21, 2021 12:39 am, edited 1 time in total.

woocaash
Posts: 5
Joined: Mon Apr 19, 2021 9:03 pm

Re: Pi 400 bluetooth disaster

Wed Apr 21, 2021 12:30 am

pi@raspberrypi:~ $ bluetoothctl
Agent registered
[bluetooth]# scan on
Discovery started
[CHG] Controller E4:5F:01:19:6A:0B Discovering: yes
[NEW] Device 4D:40:26:93:36:40 LE-Bose Micro SoundLink
[NEW] Device E3:60:58:E1:6C:9A Govee_H5074_6C9A
[NEW] Device E0:7C:62:21:0D:95 E0-7C-62-21-0D-95
[CHG] Device E3:60:58:E1:6C:9A RSSI: -62

bose speaker

Undertow
Posts: 29
Joined: Thu Feb 18, 2021 2:00 pm

Re: Pi 400 bluetooth disaster

Thu Apr 22, 2021 12:36 am

woocaash wrote:
Wed Apr 21, 2021 12:30 am
pi@raspberrypi:~ $ bluetoothctl
Agent registered
[bluetooth]# scan on
Discovery started
[CHG] Controller E4:5F:01:19:6A:0B Discovering: yes
[NEW] Device 4D:40:26:93:36:40 LE-Bose Micro SoundLink
[NEW] Device E3:60:58:E1:6C:9A Govee_H5074_6C9A
[NEW] Device E0:7C:62:21:0D:95 E0-7C-62-21-0D-95
[CHG] Device E3:60:58:E1:6C:9A RSSI: -62

bose speaker
What happens if you enter "pair 4D:40:26:93:36:40" at bluetooth prompt (use latest ID if different)?

woocaash
Posts: 5
Joined: Mon Apr 19, 2021 9:03 pm

Re: Pi 400 bluetooth disaster

Thu Apr 22, 2021 1:46 pm

pi@raspberrypi:~ $ bluetoothctl
Agent registered
[bluetooth]# scan on
Discovery started
[CHG] Controller E4:5F:01:19:6A:0B Discovering: yes
[NEW] Device 5B:8C:07:B9:82:33 LE-Bose Micro SoundLink
[NEW] Device E3:60:58:E1:6C:9A Govee_H5074_6C9A
[NEW] Device E0:7C:62:21:0D:95 E0-7C-62-21-0D-95
[DEL] Device 5B:8C:07:B9:82:33 LE-Bose Micro SoundLink
[DEL] Device E3:60:58:E1:6C:9A Govee_H5074_6C9A
[DEL] Device E0:7C:62:21:0D:95 E0-7C-62-21-0D-95
[NEW] Device E0:7C:62:21:0D:95 E0-7C-62-21-0D-95
[NEW] Device 5B:8C:07:B9:82:33 LE-Bose Micro SoundLink
[NEW] Device E3:60:58:E1:6C:9A Govee_H5074_6C9A
[bluetooth]# pair 5B:8C:07:B9:82:33
Attempting to pair with 5B:8C:07:B9:82:33
[CHG] Device 5B:8C:07:B9:82:33 Connected: yes
Failed to pair: org.bluez.Error.AuthenticationFailed
[CHG] Device 5B:8C:07:B9:82:33 Connected: no
[DEL] Device 5B:8C:07:B9:82:33 LE-Bose Micro SoundLink
[CHG] Device E3:60:58:E1:6C:9A ManufacturerData Key: 0xec88
[CHG] Device E3:60:58:E1:6C:9A ManufacturerData Value:
00 39 07 1a 19 64 02 .9...d.
[CHG] Device E3:60:58:E1:6C:9A ManufacturerData Key: 0x004c
[CHG] Device E3:60:58:E1:6C:9A ManufacturerData Value:
02 15 49 4e 54 45 4c 4c 49 5f 52 4f 43 4b 53 5f ..INTELLI_ROCKS_
48 57 50 74 9a 6c c2 HWPt.l.
[NEW] Device 5B:8C:07:B9:82:33 LE-Bose Micro SoundLink


Last night I did over 10 fresh installations. The same problem exist with Ubuntu. I installed Ubuntu couple times and played extensively. Both Raspberry and Ubuntu can not pair to my speaker. They both see my speaker but are unable to connect. The only command that works
is "sudo systemctl restart bluetooth". After typing this command I was able to pair my speaker on both Raspberry & Ubuntu. When you restart PC Bluetooth is not working anymore and you have to restart bluetoothctl with above command every single time.

Second issue is audio itself. After restarting bluetooth I am able to pair normally. Both systems recognize, pair, and list connected devices. (ONLY AFTER TYPING THE COMMAND)

Second issue is audio itself.

On Raspberry Pi quality is good but it is super low volume and everything is set to max.
This is not acceptable. My cellphone is louder than bose speaker ;(

On Ubuntu speaker was connected but audio was choppy/stuttering.
Unable to listen so I drop the Ubuntu and came back to Raspberry.

Now I can have nice audio if I keep my speaker next to my ear and restart bluetooth every single time... ;)


Please advise if that sounds like a software issue or hardware issue.


Thank you

thradtke
Posts: 684
Joined: Wed May 16, 2012 5:16 am
Location: Germany / EL

Re: Pi 400 bluetooth disaster

Fri Apr 23, 2021 7:23 am

woocaash wrote:
Thu Apr 22, 2021 1:46 pm
Second issue is audio itself.

On Raspberry Pi quality is good but it is super low volume and everything is set to max.
This is not acceptable. My cellphone is louder than bose speaker ;(
Might be the device, don't know. I have a similar problem however: I connect to a Google Nest Mini via BT, and the Google voice is 10 times louder than the bluetooth signal. So, when the nest is set to a comfortable level, the Pi needs to be at 100% to barely have any output.

If this is actually a software problem, I'd be happy if someone could solve it or point me in the right direction. I plan to buy a speakerphone for the 400, and since those are very expensive, I want to make sure there are no problems with them. I know from YT videos that Pi bluetooth audio lags a fraction of a second, but that's something I can handle. But it needs to be quite loud to compensate for ambient noise.

Can't help with your BT problem, woocaash. Just wanted to let you know BT/Audio on the Pi is actually far from being perfect. Guess either your 400 is defect, or you have a problem with the firmware or something. I'd RMA it.
Rocket Scientist.

woocaash
Posts: 5
Joined: Mon Apr 19, 2021 9:03 pm

Re: Pi 400 bluetooth disaster

Sat Apr 24, 2021 11:54 am

Thank you thradtke. I will return and see if the new one has the same problem. I read your posts in the past from November. You tried to help already other people having the same issue. I will post an update when I receive replacement. Thank you all

thradtke
Posts: 684
Joined: Wed May 16, 2012 5:16 am
Location: Germany / EL

Re: Pi 400 bluetooth disaster

Tue Apr 27, 2021 7:07 am

woocaash wrote:
Sat Apr 24, 2021 11:54 am
Thank you thradtke. I will return and see if the new one has the same problem. I read your posts in the past from November. You tried to help already other people having the same issue. I will post an update when I receive replacement. Thank you all
Good luck!

Meanwhile I've read a little about the output level problem and there seems to be a solution: I installed blueman, and since I didn't want to have two bluetooth managers (but it works), I purged blueman soon after trying and noticing nothing had changed. But on the next reboot (and since then), the sound output level was significantly higher.

So, there's a solution but I don't know really what it is.
Rocket Scientist.

Return to “Raspberry Pi 400”