mob-i-l
Posts: 361
Joined: Sat Dec 29, 2012 2:45 am
Location: Lund, Skåne/Scania, Sweden
Contact: Website Facebook Twitter YouTube

How use dual screens in Lubuntu 19.10?

Fri Apr 10, 2020 4:11 pm

I run Lubuntu 19.10 on a Raspberry Pi 4B with 4 GB RAM. I installed Ubuntu 19.10 64-bit using Raspberry Pi Imager, and then installed Lubuntu desktop using:
sudo apt install lubuntu-desktop

This works, but it only uses one screen (HDMI 0). In "Preferences/LXQt settings/Monitor settings" there is only one screen, and also in KDE System Settings.

How can I use both screens similar to as in Raspbian Buster? Both screens are active in the beginning during boot.

Only one display seems to be detected after X started:

Code: Select all

$ xrandr -q
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1280 x 1024, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024      0.00*
Have Pi0&1A&1B&1B+&2B&3B&4B w/ rasPiOS. Started w/ BASIC on ABC80&ZX81 then Forth, Z80… https://scratch.mit.edu/users/mobluse/ https://github.com/mobluse/ https://twitter.com/mobluse/ https://YouTube.com/MOBiL4u/

User avatar
waveform80
Posts: 366
Joined: Mon Sep 23, 2013 1:28 pm
Location: Manchester, UK
Contact: Website Twitter

Re: How use dual screens in Lubuntu 19.10?

Fri Apr 10, 2020 6:55 pm

You probably need the FKMS overlay loaded. On the boot partition (normally mounted under /boot/firmware in Ubuntu), add the following line to syscfg.txt or usercfg.txt (doesn't matter which):

Code: Select all

dtoverlay=vc4-fkms-v3d
Then reboot. With this overlay in place you *should* find that both displays appear (at least they do for me when attempting this on lubuntu on a Pi4).

You may find that you want to add the following line as well as for some reason our default framebuffer seems to ignore the overscan setting (not something I've dug into yet as we actually want to work towards simply enabling FKMS as the default, but it's currently causing issues on the smaller-memory platforms like the 3A+):

Code: Select all

disable_overscan=1
Hope that works for you!

Dave.
Author of / contributor to a few pi related things (picamera, Sense HAT emulator, gpiozero, piwheels, etc.), and currently a software engineer at Canonical responsible for Ubuntu on the Raspberry Pi.

Return to “Ubuntu”