rwcooper
Posts: 22
Joined: Wed Dec 30, 2015 9:04 pm

64-bit ubuntu 19.10 wifi not working

Mon Nov 04, 2019 2:26 pm

Hi, I'm trying to get wifi working under 64-bit ubuntu 19.10 on a RPi 4 - 4GB. Wired ethernet works fine, but the wifi only seems to work if it is also has a wired ethernet connection, that is I can successfully ping the ip address for the wifi connection. If I run raspbain wifi works fine. After installing the server version of ubuntu I installed kunbutu-desktop and wifi worked. I want to run this RPi headless most of the time and occasionally run it with a monitor/keyboard/mouse and kde. I purged network-manager and modified /etc/netplan/50-cloud-init.yaml as shown below.

Code: Select all

# This file is generated from information provided by
# the datasource.  Changes to it will not persist across an instance.
# To disable cloud-init's network configuration capabilities, write a file
# /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the following:
# network: {config: disabled}
network:
  version: 2
  renderer: networkd
  wifis:
    wlan0:
      dhcp4: no
      dhcp6: no
      addresses: [192.168.32.15/24]
      gateway4: 192.168.32.12
      nameservers:
        addresses: [142.161.130.155,142.161.2.155]
      access-points:
        "mylan":
          password: "secretpasswd"
  ethernets:
    eth0:
      dhcp4: no
      dhcp6: no
      optional: true
      addresses: [192.168.32.16/24]
      gateway4: 192.168.32.12
      nameservers:
        addresses: [142.161.130.155,142.161.2.155]   
I also changed /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg to contain the following.

Code: Select all

network: {config: disabled}
I ran several commands in hope that someone can help me based on the output from these commands.

Code: Select all

# service [email protected] status
● [email protected] - WPA supplicant for netplan wlan0
   Loaded: loaded (/lib/systemd/system/[email protected]; enabled-runtime; vendor preset: enabled)
   Active: active (running) since Thu 2019-04-11 11:28:41 CDT; 6 months 24 days ago
 Main PID: 1165 (wpa_supplicant)
    Tasks: 1 (limit: 4199)
   CGroup: /system.slice/system-netplan\x2dwpa.slice/[email protected]
           └─1165 /sbin/wpa_supplicant -c /run/netplan/wpa-wlan0.conf -iwlan0

Apr 11 11:28:41 raspberry10 systemd[1]: Started WPA supplicant for netplan wlan0.
Apr 11 11:28:41 raspberry10 wpa_supplicant[1165]: Successfully initialized wpa_supplicant
Nov 04 07:37:21 raspberry10 wpa_supplicant[1165]: wlan0: Trying to associate with SSID 'Northumberlan'
Nov 04 07:37:24 raspberry10 wpa_supplicant[1165]: wlan0: Associated with d8:30:62:2f:9e:9d
Nov 04 07:37:24 raspberry10 wpa_supplicant[1165]: wlan0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Nov 04 07:37:24 raspberry10 wpa_supplicant[1165]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=CA
Nov 04 07:37:24 raspberry10 wpa_supplicant[1165]: wlan0: WPA: Key negotiation completed with d8:30:62:2f:9e:9d [PTK=CCMP GTK=CCMP]
Nov 04 07:37:24 raspberry10 wpa_supplicant[1165]: wlan0: CTRL-EVENT-CONNECTED - Connection to d8:30:62:2f:9e:9d completed [id=0 id_str=]

# service wpa_supplicant status
● wpa_supplicant.service - WPA supplicant
   Loaded: loaded (/lib/systemd/system/wpa_supplicant.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-11-04 07:38:01 CST; 35s ago
 Main PID: 1298 (wpa_supplicant)
    Tasks: 1 (limit: 4199)
   CGroup: /system.slice/wpa_supplicant.service
           └─1298 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant

Nov 04 07:38:00 raspberry10 systemd[1]: Starting WPA supplicant...
Nov 04 07:38:01 raspberry10 wpa_supplicant[1298]: Successfully initialized wpa_supplicant
Nov 04 07:38:01 raspberry10 systemd[1]: Started WPA supplicant.

# netstat -nr
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         192.168.32.12   0.0.0.0         UG        0 0          0 wlan0
192.168.32.0    0.0.0.0         255.255.255.0   U         0 0          0 wlan0

# ip route | grep default
default via 192.168.32.12 dev wlan0 proto static 

# more /run/netplan/wpa-wlan0.conf
ctrl_interface=/run/wpa_supplicant

network={
  ssid="mylan"
  key_mgmt=WPA-PSK
  psk="secretpassword"
}

# ifconfig wlan0
wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.32.15  netmask 255.255.255.0  broadcast 192.168.32.255
        inet6 fe80::dea6:32ff:fe20:6688  prefixlen 64  scopeid 0x20<link>
        ether dc:a6:32:20:66:88  txqueuelen 1000  (Ethernet)
        RX packets 12  bytes 1676 (1.6 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 99  bytes 11039 (11.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

I don't know what to try next. Any suggestions are greatly appreciated. Hopefully I won't have to start over with a clean install of ubuntu.

Thanks...Randy

fruitoftheloom
Posts: 22062
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: 64-bit ubuntu 19.10 wifi not working

Mon Nov 04, 2019 4:25 pm

Retired disgracefully.....
......to an uncomplicated life !

Rather than negativity think outside the box !

rwcooper
Posts: 22
Joined: Wed Dec 30, 2015 9:04 pm

Re: 64-bit ubuntu 19.10 wifi not working

Mon Nov 04, 2019 5:26 pm

Ok I'll go there.

feelslikeautumn
Posts: 315
Joined: Wed Aug 09, 2017 9:51 pm

Re: 64-bit ubuntu 19.10 wifi not working

Mon Nov 04, 2019 6:05 pm

No don't do that.

Somebody on here may very well know the answer. I can tell you how to do it if you are willing to re-install.

If you do want to ask on another site, then Askubuntu.com is the place. Note it is not a forum - strict questions and answers only.

feelslikeautumn
Posts: 315
Joined: Wed Aug 09, 2017 9:51 pm

Re: 64-bit ubuntu 19.10 wifi not working

Mon Nov 04, 2019 6:56 pm

Trying to refamiliarise myself with how networking works, there are plenty of useful links out there:

https://askubuntu.com/questions/1033826 ... i-wireless
https://askubuntu.com/questions/1143287 ... rver-18-04
https://askubuntu.com/questions/1122757 ... -and-above

Have a search around if you haven't already done so, you may very well find your answer.

rwcooper
Posts: 22
Joined: Wed Dec 30, 2015 9:04 pm

Re: 64-bit ubuntu 19.10 wifi not working

Thu Nov 07, 2019 8:33 pm

feelslikeautumn wrote:
Mon Nov 04, 2019 6:05 pm
No don't do that.

Somebody on here may very well know the answer. I can tell you how to do it if you are willing to re-install.

If you do want to ask on another site, then Askubuntu.com is the place. Note it is not a forum - strict questions and answers only.
If you could tell me how to do that I would really appreciate it. I'm willing to reinstall...Randy

feelslikeautumn
Posts: 315
Joined: Wed Aug 09, 2017 9:51 pm

Re: 64-bit ubuntu 19.10 wifi not working

Sun Nov 10, 2019 10:39 pm

I can only tell you how I install, which is to use the mini iso. Because you have a pi4 and there is no generic kernel for this yet, then it is a bit of an ordeal. I wrote instructions for using the raspi2 kernels with the mini iso here https://ubuntu-mate.community/t/aarch64 ... b/16853/37 . Actually these could be improved since grub2 is now usable with the raspi2 kernels.

The advantage of this is it gives you an install like a normal computer. You can then follow all standard documentation. I normally install via ethernet (but wifi is possible too), install a graphical environment and network manager is there to manage wifi connections. If I drop to a shell or start in a shell then the network connection has always been still managed as far as I can remember. It is certainly something I have never had to think about.

I hope that helps a bit, but I'm sure the actual answer to your problem is in the links I previously provided or a bit more googling about netplan. Good luck!

(p.s. Sorry about the slow reply)

rwcooper
Posts: 22
Joined: Wed Dec 30, 2015 9:04 pm

Re: 64-bit ubuntu 19.10 wifi not working

Mon Nov 11, 2019 7:29 pm

Thanks for the replay. I'll play around with it a bit more.

phase
Posts: 54
Joined: Thu Jun 30, 2016 3:05 am

Re: 64-bit ubuntu 19.10 wifi not working

Fri Nov 15, 2019 1:25 am

tis is prolly a bit late but have you solved it yet..

if not are you trying to get it working via the desktop
or the command line with not desktop installed
have a look here for the command line..

https://www.linuxbabe.com/ubuntu/connec ... supplicant

jonah1
Posts: 1
Joined: Thu Jan 09, 2020 9:28 am

Re: 64-bit ubuntu 19.10 wifi not working

Thu Jan 09, 2020 9:30 am

Hey, I got the same problem.

Does anyone have any idea how to solve this problem?

Sincerely yours.
jonah

phase
Posts: 54
Joined: Thu Jun 30, 2016 3:05 am

Re: 64-bit ubuntu 19.10 wifi not working

Thu Jan 09, 2020 11:39 am

i thought it was enabled by default seems you guy`s are having issues try adding this to the "usercfg.txt" file

Code: Select all

dtoverlay=pi3-enable-wifi

thatchunkylad198966
Posts: 134
Joined: Thu Jul 04, 2019 10:21 am
Location: UK, Birmingham

Re: 64-bit ubuntu 19.10 wifi not working

Thu Jan 09, 2020 11:49 am

fruitoftheloom wrote:
Mon Nov 04, 2019 4:25 pm
https://ubuntuforums.org/
Way to help, bro. :lol: :?
OP: do what as been said above my reply - hopefully it'll work for you.
One man's trash is another man's treasure! :) Pi's I have; Pi Zero, Pi Zero W, Pi 2 x2, Pi 3 x2, Pi 4 4GB x2.

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 25451
Joined: Sat Jul 30, 2011 7:41 pm

Re: 64-bit ubuntu 19.10 wifi not working

Thu Jan 09, 2020 11:53 am

thatchunkylad198966 wrote:
Thu Jan 09, 2020 11:49 am
fruitoftheloom wrote:
Mon Nov 04, 2019 4:25 pm
https://ubuntuforums.org/
Way to help, bro. :lol: :?
OP: do what as been said above my reply - hopefully it'll work for you.
Fruits post was from last November, any ranting about content should probably have been done then.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I own the world’s worst thesaurus. Not only is it awful, it’s awful."

trejan
Posts: 1217
Joined: Tue Jul 02, 2019 2:28 pm

Re: 64-bit ubuntu 19.10 wifi not working

Thu Jan 09, 2020 12:16 pm

phase wrote:
Thu Jan 09, 2020 11:39 am
i thought it was enabled by default seems you guy`s are having issues try adding this to the "usercfg.txt" file

Code: Select all

dtoverlay=pi3-enable-wifi
Eh? pi3-enable-wifi? That overlay doesn't exist.

andrum99
Posts: 1067
Joined: Fri Jul 20, 2012 2:41 pm

Re: 64-bit ubuntu 19.10 wifi not working

Thu Jan 09, 2020 12:52 pm

trejan wrote:
Thu Jan 09, 2020 12:16 pm
phase wrote:
Thu Jan 09, 2020 11:39 am
i thought it was enabled by default seems you guy`s are having issues try adding this to the "usercfg.txt" file

Code: Select all

dtoverlay=pi3-enable-wifi
Eh? pi3-enable-wifi? That overlay doesn't exist.
Ignore that suggestion - wifi is enabled by default.


sciurulus
Posts: 1
Joined: Sun Feb 16, 2020 1:17 pm

Re: 64-bit ubuntu 19.10 wifi not working

Sun Feb 16, 2020 1:42 pm

Hi, I got this issue, too. Wifi works fine with Raspian out of the box.
With Ubuntu 19.10, Wifi is not starting out of the box, neither the dhclient -v (or -r -v) hack helps. So it's certainly not a ISP issue. I do not see any errors in the dmesg log or elsewhere. I do not know the new netplug system, so I have no clue how to debug it.

Was the system upgrade that made it work? I'm just asking because I have no cable network and it would require some effort to build one for upgrading.
Thanks for any help!

murraybd
Posts: 13
Joined: Thu Nov 14, 2019 10:56 pm

Re: 64-bit ubuntu 19.10 wifi not working

Mon Feb 17, 2020 3:49 pm

Here is an example of how to use netplan to connect to a wireless network.

https://netplan.io/examples#connecting- ... ss-network
Software Engineer at Canonical
Ubuntu Core Developer

Return to “Ubuntu”