ADAchim
Posts: 2
Joined: Tue Aug 03, 2021 5:16 am

Sim7600G HAT on pi 4 Model B with Ubuntu 21.04 as OS

Tue Aug 03, 2021 5:27 am

Hey, I want to connect a waveshare sim7600 HAT to my Pi. While I tested on windows, the module started the cellular connection automatically with the provided windows drivers. Since there are no such drivers for Linux, I wanted to ask if someone managed to get it work automatically or I have to use a NDISwrapper or it works only with AT commands?
BTW., the device works, if someone should mistake the drivers imentioned with the serial drivers from waveshare.
Thanks a lot

rberger
Posts: 2
Joined: Sun Jul 06, 2014 10:52 pm

Re: Sim7600G HAT on pi 4 Model B with Ubuntu 21.04 as OS

Wed Aug 04, 2021 7:06 am

retically it should work with the ModemManager and NetworkManager. I have yet to make it work though. mmcli and the Ubuntu Desktop Network Settings GUI does recognize the modem, but haven't figured out how to actually make it work yet.

I did get it to work following the directions in viewtopic.php?p=1450784#p1450784

The one thing with recent Ubuntu at least the Desktops is it starts ModemManager automatically which will conflict with the qmcli commands that those directions use. So you need to stop the ModemManager with:

Code: Select all

  sudo systemctl unmask ModemManager.service # may need this
    sudo systemctl disable ModemManager.service
Also the most recent versions of the SIM7600 HAT that is different than many of these instructions that are out there is the newer ones are already setup for powering on when the Pi is powered on, already set for raw-ip (don't need to do the steps around

Code: Select all

echo 'Y' | sudo tee /sys/class/net/wwan0/qmi/raw_ip
And is already online so you don't really need to do

Code: Select all

sudo qmicli -d /dev/cdc-wdm0 --dms-set-operating-mode='online'
Though it won't hurt to do them

ADAchim
Posts: 2
Joined: Tue Aug 03, 2021 5:16 am

Re: Sim7600G HAT on pi 4 Model B with Ubuntu 21.04 as OS

Wed Aug 04, 2021 9:00 am

Thank for the advice.
These steps I found too, but it wasn't working. Eventually, I found a less convenient workaround by changing the the Kconfig file in the drivers/usb/serial folder of the Kernel.

Basic instructions are here: https://techship.com/faq/how-to-integra ... ng-kernel/

CONFIG_USB_SERIAL=y
CONFIG_USB_SERIAL_WWAN=y
CONFIG_USB_SERIAL_OPTION=y

changing those configurations gave me the ability to connect to the cellular modem after a reboot.
I hope it can help you too.

Return to “Ubuntu”