theblackrouge
Posts: 1
Joined: Sun Apr 11, 2021 4:18 am

XRDP Remote Control on Ubuntu 20.10 Rasberry Pi 4

Sun Apr 11, 2021 4:47 am

Hi everyone. So I've set up Ubuntu 20.10 on my Pi 4 and configured XRDP for remote controlling the Pi. Setting everything up was a pain in the a*s, but eventually I got it working. I have used my Desktop PC (Windows 10) and the native Remote Desktop Connection (RDP) tool to connect to the Pi and it worked perfectly for the past two months. I never turned off the Pi, I always just logged off and logged in when I needed to use it again.

Fast forward to yesterday, where the electricity was cut off from the Pi for a few moments. This happened one time in the past already, and the connection was completely lost then. When I went to the Pi with keyboard, mouse, monitor and 2 different HDMI cables, I have tried every possible way to get image on the monitor, but despite any effort, it would always say "No Signal", even though I tested the monitor and the cables, and they work for sure. Restarting the Pi, trying the different HDMI ports on the Pi and Monitor didnt work. So I was out of ideas and ended up re-installing the whole Ubuntu OS (loosing all my data and XRDP set up) and at the first boot, I instantly got an image on the monitor. So I had to go through the whole process of installing the OS and re-configuring everything for the XRDP remote control set up.

So after the electricity cut off yesterday once again, I went to the Pi, again with monitor, HDMI cables, mouse and keyboard and tried to get an image on the monitor, but once again, despite trying everything out, im not getting an image on the monitor. Weird thing is, that if I try to connect to the Pi with XRDP, the log-in screen of XRDP still appears:

Image

And after I log in, I do actually get an image but its broken:

Image

The weird thing is that it is still reactive and the connection still seems to work for whatever reason. So even though the display is broken, if I start typing on the keyboard, the pixels on the broken image are moving and stuff is happening on the Pi, so it seems the connection is still working. So I would probably be able to do some commands by opening the terminal with shortcuts and typing commands, but I wouldn't have any idea what the problem here is and what I would have to do to fix this.

As mentioned earlier, the last time this happened I didnt find a way of fixing the "No Signal" Problem and had to re-install the OS and reconfiguring everything, which took me quite a lot of time. I really don't want to go through the whole process of re-installing the OS and setting everything up for XRDP again.

I'm also very scared to turn off the Pi, and try to get an image on the Monitor by starting it up again, because the last time, once the Pi was turned off, there was no possible way to get an image on the display without reinstalling OS.

I can't believe that Ubuntu 20.10 on the Pi4 just completely breaks once the Pi is turned off by accident. There must be something im missing here and I'm hoping that someone can help me with this. All I need is to get a working XRDP connection from my Windows 10 PC to the Ubuntu 20.10 Pi 4. And as it seems, the XRDP connection is still working, however the display is broken and I can't use it like that. Anyone have any tips on what I could do? Thanks in advance!

lynnejohn
Posts: 10
Joined: Fri Mar 23, 2018 6:29 pm

Re: XRDP Remote Control on Ubuntu 20.10 Rasberry Pi 4

Mon Apr 12, 2021 7:38 pm

I saw this behavior on our Raspberry Pi4 running Ubuntu 20.10 except we are not running xrdp. The Pi had been running for a while and I went to the monitor to do some work and kept getting the "no signal" from the attached ViewSonic monitor. I tried power cycling the monitor, plugging and unplugging the HDMI cable and even swapped HDMI cables, but nothing worked. The Pi was running as it responded to pings and the web server was up as well. I finally cycled power on the Pi and the HDMI connection to the ViewSonic monitor came back to life.
I know this does not help you but it makes me think there is something about Ubuntu 20.10 that occasionally causes the HDMI output to stop operating.

Return to “Ubuntu”