curtvaughan
Posts: 2
Joined: Tue Nov 19, 2019 10:14 pm

Re: Can’t install Ubuntu on RPI 4

Tue Nov 19, 2019 10:31 pm

Great post! Very useful and apropos to the current issues with installing Ubuntu 19.10 to an RPI 4 with top memory spec. I know you took a lot of time to go into the detail you provided, but I found it very helpful. Without the edits you specify the installation process of "server" hangs prior to one's being able to ssh into the system.

andrum99
Posts: 922
Joined: Fri Jul 20, 2012 2:41 pm

Re: Can’t install Ubuntu on RPI 4

Wed Nov 20, 2019 10:55 pm

Matha wrote:
Sun Nov 10, 2019 3:34 pm
Perhaps, Ben and Mark could exchange some notes on agreeing with the nomenclature standards established by the Foundation for public image downloads.
Canonical have made a few minor mistakes so far with this release. I don't think these are huge issues. Some of them do seem a bit sloppy to me though.

macromorgan
Posts: 9
Joined: Mon Aug 26, 2019 2:35 pm

Re: Can’t install Ubuntu on RPI 4

Thu Nov 21, 2019 3:30 am

dustnbone wrote:
Tue Nov 19, 2019 8:56 pm
gordonfreemanjr wrote:
Wed Nov 06, 2019 3:16 pm

Anyway, the sole reason of my attempts to install Ubuntu on RPI4 are to run Steam and GOG Galaxy clients. Can you recommend any other available OS capable of doing that?
Steam will not run on Raspberry Pi, the Linux client is for x86/x64 not ARM. I would assume the GOG client is the same but I can't confirm as I don't use it personally.

The games hosted on Steam are also only for the x86/64 platform, so even if the client ran none of the games could.

Can also confirm Ubuntu works fine on 2GB Pi4 but not the 4GB.
The GoG client seems to be WINE based so I wouldn’t bet it would work, but you could try it at least.

For Steam I’ve tried every combination I could think of and I always get a segfault from QEMU. It looks like it’s trying to use an address larger than 4GB for something then screaming because numbers that big don’t usually exist in 32 bit land; I haven’t filed a bug report yet but it looks like no matter the version or how I run it QEMU dies at the function “helper_cmpxchg8b”, specifically on line 71 of the mem_helper.c file in QEMU master.

aarch64:
qemu-user-i386 + chroot + steam = segfault
qemu-user-i386 + multilib + steam = segfault
qemu-user-i386 + chroot + wine + windows steam = segfault
qemu-user-i386 + multilib + wine + windows steam = segfault

For aarch32 I only tried the linux client, I didn’t get WINE involved but had the same issues.

I was able to get Stardew Valley to start to load, but then it got mad that steam wasn’t running and quit. Also note I tried both steam and steamcmd.

Suffice to say I’m curious if I can get Steam to run, but so far no dice.

edit: Just did some for fun comparisons. Using QEMU user mode and multi arch Debian buster chroot I was able to determine that even if we were successful in getting Steam, GoG or any games to run the performance may be so low it’s useless.

Running on an AARCH64 host observed the following with 2 extremely not scientific benchmarks of running RSA hashes with OpenSSL and using stress-ng to “benchmark” a CPU on a single thread:
i386 - 50x slower at RSA and 6x slower at stress-ng
amd64 - 3x slower at both
ppc64el - 2x slow at RSA and 10x slower at stress-ng
mips - 10x slower at RSA and 4x slower at stress-ng.

Not sure why i386 is so much slower, especially relative to amd64...

Return to “Ubuntu”