_Mark_
Posts: 99
Joined: Sun Jun 02, 2013 8:04 am

Re: Qt5WebKit + Gstreamer

Sun Jan 26, 2014 12:23 pm

I see someone solved rebuilding buildroot.

I followed the procedure from the beginning but this time I get these errors:

Code: Select all

/home/mark/dev/buildroot-rpi/output/host/usr/bin/ccache /usr/bin/gcc -std=gnu99   -O2 -I/home/mark/dev/buildroot-rpi/output/host/usr/include -L/home/mark/dev/buildroot-rpi/output/host/lib -L/home/mark/dev/buildroot-rpi/output/host/usr/lib -Wl,-rpath,/home/mark/dev/buildroot-rpi/output/host/usr/lib -o m4 m4.o builtin.o debug.o eval.o format.o freeze.o input.o macro.o output.o path.o symtab.o ../lib/libm4.a
m4.o: In function `main':
m4.c:(.text.startup+0x260): undefined reference to `version_etc'
m4.c:(.text.startup+0x3ef): undefined reference to `emit_bug_reporting_address'
collect2: error: ld returned 1 exit status
make[3]: *** [m4] Error 1
make[3]: Leaving directory `/home/mark/dev/buildroot-rpi/output/build/host-m4-1.4.16/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/mark/dev/buildroot-rpi/output/build/host-m4-1.4.16'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/mark/dev/buildroot-rpi/output/build/host-m4-1.4.16'
make: *** [/home/mark/dev/buildroot-rpi/output/build/host-m4-1.4.16/.stamp_built] Error 2 

Any one else ran into them?

_Mark_
Posts: 99
Joined: Sun Jun 02, 2013 8:04 am

Re: Qt5WebKit + Gstreamer

Thu Jan 30, 2014 7:29 am

Solved cleaning the buildroot cache.

Now the last problem is when I use OpenGL the widget is actually rendered "behind" the console.... I'm pretty sure I'm missing something!

PolyD
Posts: 2
Joined: Tue Feb 11, 2014 12:25 pm

Re: Qt5WebKit + Gstreamer

Tue Feb 11, 2014 12:34 pm

Hi - I've been playing with this for a week or so. I've been unable to get any audio to play with my video. What audio codes are supported?

Thanks

albertd
Posts: 51
Joined: Thu Aug 30, 2012 8:10 pm

Re: Qt5WebKit + Gstreamer

Sat Feb 22, 2014 12:16 am

We're moving to a new repo:
https://github.com/metrological/buildroot

Please use:
make rpi_qt5webkit_defconfig

and then:
make menuconfig

You can select your audio codecs, we've enabled MP3 + AAC for now by default

Kind regards,
Albert
Last edited by albertd on Mon Feb 24, 2014 6:46 pm, edited 1 time in total.

darkladen
Posts: 22
Joined: Mon Oct 01, 2012 7:54 pm

Re: Qt5WebKit + Gstreamer

Mon Feb 24, 2014 6:20 pm

albertd wrote:We're moving to a new repo:
https://github.com/metrological/buildroot

Please use:
make raspberrypi_defconfig

and then:
make menuconfig

You can select your audio codecs, we've enabled MP3 + AAC for now by default

Kind regards,
Albert
Hi Albert, I try to test the new repo and I can compile this, but, i cant find the files to copy into "SDX1". Reviewing the previous version, I can prepare de first partition (boot) with this files:

output/images/rpi-firmware/*
output/images/zImage

Where i found this files ?? I try mixing two repo.
"https://github.com/albertd/buildroot-rpi.git" = BOOT
"https://github.com/Metrological/buildroot.git" = ROOT

This method dont work.

How I can get files to boot partition ???

Thanks.

albertd
Posts: 51
Joined: Thu Aug 30, 2012 8:10 pm

Re: Qt5WebKit + Gstreamer

Mon Feb 24, 2014 6:45 pm

darkladen wrote:
albertd wrote:We're moving to a new repo:
https://github.com/metrological/buildroot

Please use:
make raspberrypi_defconfig

and then:
make menuconfig

You can select your audio codecs, we've enabled MP3 + AAC for now by default

Kind regards,
Albert
Hi Albert, I try to test the new repo and I can compile this, but, i cant find the files to copy into "SDX1". Reviewing the previous version, I can prepare de first partition (boot) with this files:

output/images/rpi-firmware/*
output/images/zImage

Where i found this files ?? I try mixing two repo.
"https://github.com/albertd/buildroot-rpi.git" = BOOT
"https://github.com/Metrological/buildroot.git" = ROOT

This method dont work.

How I can get files to boot partition ???

Thanks.
Please use
make rpi_qt5webkit_defconfig
make

Then you can copy both:
output/images/rpi-firmware/*
output/images/zImage

To the boot partition.

Then extract the rootfs.tar in the second partition.

Cheers,
Albert

darkladen
Posts: 22
Joined: Mon Oct 01, 2012 7:54 pm

Re: Qt5WebKit + Gstreamer

Mon Feb 24, 2014 6:53 pm

albertd wrote:
darkladen wrote:
Please use
make rpi_qt5webkit_defconfig
make

Then you can copy both:
output/images/rpi-firmware/*
output/images/zImage

To the boot partition.

Then extract the rootfs.tar in the second partition.

Cheers,
Albert
:o Ultra Fast Reply !!!
I am very grateful.

Thank you very much.

albertd
Posts: 51
Joined: Thu Aug 30, 2012 8:10 pm

Re: Qt5WebKit + Gstreamer

Mon Feb 24, 2014 6:55 pm

darkladen wrote: :o Ultra Fast Reply !!!
I am very grateful.

Thank you very much.
You're welcome, please do git pull, some html5 video tag fixes have been done today.

Cheers,
Albert

albertd
Posts: 51
Joined: Thu Aug 30, 2012 8:10 pm

Re: Qt5WebKit + Gstreamer

Mon Feb 24, 2014 10:41 pm

Also Canvas 2D + WebGL is now hardware accelerated.

deales
Posts: 5
Joined: Fri Feb 28, 2014 9:16 pm

Re: Qt5WebKit + Gstreamer + WebGL + Canvas

Fri Feb 28, 2014 9:22 pm

Hi All,

Hope someone can help me with this, when I try to compile the webkit using...

Code: Select all

make rpi_qt5webkit_defconfig
make
I get the following error in the config.log

Code: Select all

## ----------- ##
## Core tests. ##
## ----------- ##

configure:2344: checking build system type
configure:2358: result: x86_64-unknown-linux-gnu
configure:2378: checking host system type
configure:2391: result: arm-buildroot-linux-gnueabihf
configure:2420: checking for arm-buildroot-linux-gnueabihf-gcc
configure:2447: result: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc
configure:2716: checking for C compiler version
configure:2725: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc --version >&5
/root/buildroot/output/build/glibc-2.18-svnr23787/libc/configure: line 2727: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc: No such file or directory
configure:2736: $? = 127
configure:2725: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc -v >&5
/root/buildroot/output/build/glibc-2.18-svnr23787/libc/configure: line 2727: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc: No such file or directory
configure:2736: $? = 127
configure:2725: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc -V >&5
/root/buildroot/output/build/glibc-2.18-svnr23787/libc/configure: line 2727: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc: No such file or directory
configure:2736: $? = 127
configure:2725: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc -qversion >&5
/root/buildroot/output/build/glibc-2.18-svnr23787/libc/configure: line 2727: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc: No such file or directory
configure:2736: $? = 127
configure:2741: checking for suffix of object files
configure:2763: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc -c -O2   conftest.c >&5
/root/buildroot/output/build/glibc-2.18-svnr23787/libc/configure: line 2765: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc: No such file or directory
configure:2767: $? = 127
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "GNU C Library"
| #define PACKAGE_TARNAME "glibc"
| #define PACKAGE_VERSION "(see version.h)"
| #define PACKAGE_STRING "GNU C Library (see version.h)"
| #define PACKAGE_BUGREPORT "http://sourceware.org/bugzilla/"
| #define PACKAGE_URL "http://www.gnu.org/software/glibc/"
| #define PKGVERSION "(Buildroot) "
| #define REPORT_BUGS_TO "<http://www.eglibc.org/issues/>"
| /* end confdefs.h.  */
I am using Ubuntu 13.10 x64, do I need to install glibc 2.8? If so how do I go about doing that, ubuntu doesnt seem to have 2.8 listed as a package.

deales
Posts: 5
Joined: Fri Feb 28, 2014 9:16 pm

Re: Qt5WebKit + Gstreamer + WebGL + Canvas

Thu Mar 06, 2014 12:29 am

I managed to solve the issue, by starting again but running "rpi_qt5webkit_defconfig" only whare as before I was running both "rpi_qt5webkit_defconfig" and "rpi_defconfig"
deales wrote:Hi All,

Hope someone can help me with this, when I try to compile the webkit using...

Code: Select all

make rpi_qt5webkit_defconfig
make
I get the following error in the config.log

Code: Select all

## ----------- ##
## Core tests. ##
## ----------- ##

configure:2344: checking build system type
configure:2358: result: x86_64-unknown-linux-gnu
configure:2378: checking host system type
configure:2391: result: arm-buildroot-linux-gnueabihf
configure:2420: checking for arm-buildroot-linux-gnueabihf-gcc
configure:2447: result: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc
configure:2716: checking for C compiler version
configure:2725: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc --version >&5
/root/buildroot/output/build/glibc-2.18-svnr23787/libc/configure: line 2727: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc: No such file or directory
configure:2736: $? = 127
configure:2725: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc -v >&5
/root/buildroot/output/build/glibc-2.18-svnr23787/libc/configure: line 2727: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc: No such file or directory
configure:2736: $? = 127
configure:2725: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc -V >&5
/root/buildroot/output/build/glibc-2.18-svnr23787/libc/configure: line 2727: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc: No such file or directory
configure:2736: $? = 127
configure:2725: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc -qversion >&5
/root/buildroot/output/build/glibc-2.18-svnr23787/libc/configure: line 2727: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc: No such file or directory
configure:2736: $? = 127
configure:2741: checking for suffix of object files
configure:2763: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc -c -O2   conftest.c >&5
/root/buildroot/output/build/glibc-2.18-svnr23787/libc/configure: line 2765: /root/buildroot/output/host/usr/bin/arm-buildroot-linux-gnueabihf-gcc: No such file or directory
configure:2767: $? = 127
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "GNU C Library"
| #define PACKAGE_TARNAME "glibc"
| #define PACKAGE_VERSION "(see version.h)"
| #define PACKAGE_STRING "GNU C Library (see version.h)"
| #define PACKAGE_BUGREPORT "http://sourceware.org/bugzilla/"
| #define PACKAGE_URL "http://www.gnu.org/software/glibc/"
| #define PKGVERSION "(Buildroot) "
| #define REPORT_BUGS_TO "<http://www.eglibc.org/issues/>"
| /* end confdefs.h.  */
I am using Ubuntu 13.10 x64, do I need to install glibc 2.8? If so how do I go about doing that, ubuntu doesnt seem to have 2.8 listed as a package.

deales
Posts: 5
Joined: Fri Feb 28, 2014 9:16 pm

Re: Qt5WebKit + Gstreamer

Thu Mar 06, 2014 12:31 am

albertd wrote:Also Canvas 2D + WebGL is now hardware accelerated.
Albert,

This is the bit I am really interested in! but unsure how to get it working? I launched mlbrowser pointing it to a few WebGL demo pages, most failed to load, the ones that did load had poor performance. Am I doing this completely wrong in using mlbrowser?

Any assistance is much appreciated.

albertd
Posts: 51
Joined: Thu Aug 30, 2012 8:10 pm

Re: Qt5WebKit + Gstreamer

Thu Mar 06, 2014 8:39 am

deales wrote:
albertd wrote:Also Canvas 2D + WebGL is now hardware accelerated.
Albert,

This is the bit I am really interested in! but unsure how to get it working? I launched mlbrowser pointing it to a few WebGL demo pages, most failed to load, the ones that did load had poor performance. Am I doing this completely wrong in using mlbrowser?

Any assistance is much appreciated.
Hi,

Could you validate this link:
http://helloracer.com/webgl/

Furthermore try to set the hdmi_mode=4 in the config.txt so you are running on 720p, because of memory constrained.

WebGL is very depended on what is support by the chip + driver.

Cheers,
Albert

deales
Posts: 5
Joined: Fri Feb 28, 2014 9:16 pm

Re: Qt5WebKit + Gstreamer

Thu Mar 06, 2014 6:05 pm

albertd wrote:
deales wrote:
albertd wrote:Also Canvas 2D + WebGL is now hardware accelerated.
Albert,

This is the bit I am really interested in! but unsure how to get it working? I launched mlbrowser pointing it to a few WebGL demo pages, most failed to load, the ones that did load had poor performance. Am I doing this completely wrong in using mlbrowser?

Any assistance is much appreciated.
Hi,

Could you validate this link:
http://helloracer.com/webgl/

Furthermore try to set the hdmi_mode=4 in the config.txt so you are running on 720p, because of memory constrained.

WebGL is very depended on what is support by the chip + driver.

Cheers,
Albert
Hi Albert,

I have tried the link you gave me (which is mighty impressive on my desktop pc) it attempts to load the page but then crashes after 30 sec or so with...

Kill process 248 (mlbrowser) score 867 or sacrifice child.
Process 248 (mlbrowser) total-vm:685164kB, anon-rss:109204kB, file-rss:60kB

I presume this is an out of memory issue??

If I try http://get.web.org the spinning box displays on the PI as it is supposed to, was just hoping for something a bit fancier! Out of interest have you tried http://helloracer.com/webgl/ on your PI? If so how did it run?

Many thanks for your help.

albertd
Posts: 51
Joined: Thu Aug 30, 2012 8:10 pm

Re: Qt5WebKit + Gstreamer

Thu Mar 06, 2014 7:44 pm

deales wrote: Hi Albert,

I have tried the link you gave me (which is mighty impressive on my desktop pc) it attempts to load the page but then crashes after 30 sec or so with...

Kill process 248 (mlbrowser) score 867 or sacrifice child.
Process 248 (mlbrowser) total-vm:685164kB, anon-rss:109204kB, file-rss:60kB

I presume this is an out of memory issue??

If I try http://get.web.org the spinning box displays on the PI as it is supposed to, was just hoping for something a bit fancier! Out of interest have you tried http://helloracer.com/webgl/ on your PI? If so how did it run?

Many thanks for your help.
Are you using a RPI Model B? You really need the 512MB memory to run the WebGL stuff.

Cheers,
Albert

deales
Posts: 5
Joined: Fri Feb 28, 2014 9:16 pm

Re: Qt5WebKit + Gstreamer

Thu Mar 06, 2014 7:53 pm

albertd wrote:
deales wrote: Hi Albert,

I have tried the link you gave me (which is mighty impressive on my desktop pc) it attempts to load the page but then crashes after 30 sec or so with...

Kill process 248 (mlbrowser) score 867 or sacrifice child.
Process 248 (mlbrowser) total-vm:685164kB, anon-rss:109204kB, file-rss:60kB

I presume this is an out of memory issue??

If I try http://get.web.org the spinning box displays on the PI as it is supposed to, was just hoping for something a bit fancier! Out of interest have you tried http://helloracer.com/webgl/ on your PI? If so how did it run?

Many thanks for your help.
Are you using a RPI Model B? You really need the 512MB memory to run the WebGL stuff.

Cheers,
Albert
I am using a Model B, but it is one of the early ones with 256mb. Will try and obtain a 512mb model and give that a whirl.

sonnym
Posts: 3
Joined: Thu Feb 27, 2014 5:16 pm

Re: Qt5WebKit + Gstreamer + WebGL + Canvas

Tue Mar 11, 2014 9:18 pm

First off, this project is wonderful and has really helped me out tremendously.

I have, however, encountered a number of small issues with mlbrowser.

1) I see a lot of rendering glitches with fonts greater than 62px. In some cases, when a container also has overflow hidden, the text will not render at all.
2) The loop attribute for the <video> tag does not appear to work.
3) Setting font-family to Helvetica (which is in /usr/share/fonts) does not work.

I think these are all issues I can work around, but just wanted to bring them to your attention. Thanks again for a wonderful project.

albertd
Posts: 51
Joined: Thu Aug 30, 2012 8:10 pm

Re: Qt5WebKit + Gstreamer + WebGL + Canvas

Wed Mar 12, 2014 12:21 am

sonnym wrote:First off, this project is wonderful and has really helped me out tremendously.

I have, however, encountered a number of small issues with mlbrowser.

1) I see a lot of rendering glitches with fonts greater than 62px. In some cases, when a container also has overflow hidden, the text will not render at all.
2) The loop attribute for the <video> tag does not appear to work.
3) Setting font-family to Helvetica (which is in /usr/share/fonts) does not work.

I think these are all issues I can work around, but just wanted to bring them to your attention. Thanks again for a wonderful project.
Thanks for your feedback sonnym!

We will investigate the issues you have found and try to patch them in the near future.

Cheers,
Albert

albertd
Posts: 51
Joined: Thu Aug 30, 2012 8:10 pm

Re: Qt5WebKit + Gstreamer + WebGL + Canvas

Thu Mar 20, 2014 8:51 am

sonnym wrote: 1) I see a lot of rendering glitches with fonts greater than 62px. In some cases, when a container also has overflow hidden, the text will not render at all.
Fonts glitches have been fixed.

vitorcarvalhoml
Posts: 13
Joined: Thu Apr 11, 2013 3:03 am

Re: Qt5WebKit + Gstreamer + WebGL + Canvas

Thu Apr 03, 2014 12:16 pm

Hello, great project! Really! :D

I tried to open hellotrace.com/webgl, but raspi couldn't run it. Here is the output:

Code: Select all

# mlbrowser http://helloracer.com/webgl
EGLFS: Unable to query physical screen size, defaulting to 100 dpi.
EGLFS: To override, set QT_QPA_EGLFS_PHYSICAL_WIDTH and QT_QPA_EGLFS_PHYSICAL_HEIGHT (in millimeters).
EGLFS: Unable to query screen depth, defaulting to 32.
EGLFS: To override, set QT_QPA_EGLFS_DEPTH.
browser release ( Apr  2 2014 18:16:17 ) 
hide mouse pointer 
geometry :  QSize(1280, 720) 
This plugin does not support setParent!
This plugin does not support setParent!
add browser 
attach object to bridge 
add webkit bridge for object  MLWebKit(0x2c9fb0, name = "browser") 
load and show page 
load ( url ) :   QUrl( "http://helloracer.com/webgl" )  
show () 
attach object to bridge 
add webkit bridge for object  MLWebKit(0x2c9fb0, name = "browser") 
"http://helloracer.com/webgl/js/Three.js [242]:Error creating WebGL context." 
"http://helloracer.com/webgl/js/Three.js [242]:TypeError: null is not an object (evaluating 'f.clearColor')" 
Maybe I forgot something in "make menuconfig". I didn't perform the command "make rpi_qt5webkit_defconfig" I used the "make rpi_defconfig".

I have to do a new "make"?
About the EGLFS warnings..what can I do?!
Another question! Someone already tried to open reveal.js presentation on raspi? The link is http://lab.hakim.se/reveal-js/#/

Thanks!

albertd
Posts: 51
Joined: Thu Aug 30, 2012 8:10 pm

Re: Qt5WebKit + Gstreamer + WebGL + Canvas

Thu Apr 03, 2014 7:24 pm

vitorcarvalhoml wrote:Hello, great project! Really! :D

I tried to open hellotrace.com/webgl, but raspi couldn't run it. Here is the output:

Code: Select all

# mlbrowser http://helloracer.com/webgl
EGLFS: Unable to query physical screen size, defaulting to 100 dpi.
EGLFS: To override, set QT_QPA_EGLFS_PHYSICAL_WIDTH and QT_QPA_EGLFS_PHYSICAL_HEIGHT (in millimeters).
EGLFS: Unable to query screen depth, defaulting to 32.
EGLFS: To override, set QT_QPA_EGLFS_DEPTH.
browser release ( Apr  2 2014 18:16:17 ) 
hide mouse pointer 
geometry :  QSize(1280, 720) 
This plugin does not support setParent!
This plugin does not support setParent!
add browser 
attach object to bridge 
add webkit bridge for object  MLWebKit(0x2c9fb0, name = "browser") 
load and show page 
load ( url ) :   QUrl( "http://helloracer.com/webgl" )  
show () 
attach object to bridge 
add webkit bridge for object  MLWebKit(0x2c9fb0, name = "browser") 
"http://helloracer.com/webgl/js/Three.js [242]:Error creating WebGL context." 
"http://helloracer.com/webgl/js/Three.js [242]:TypeError: null is not an object (evaluating 'f.clearColor')" 
Maybe I forgot something in "make menuconfig". I didn't perform the command "make rpi_qt5webkit_defconfig" I used the "make rpi_defconfig".

I have to do a new "make"?
About the EGLFS warnings..what can I do?!
Another question! Someone already tried to open reveal.js presentation on raspi? The link is http://lab.hakim.se/reveal-js/#/

Thanks!
Hi please use the latest build at https://github.com/metrological/buildroot and run: make rpi_qt5webkit_defconfig

After that use qtbrowser --url=http://helloracer.com/webgl

Cheers,
Albert


vitorcarvalhoml
Posts: 13
Joined: Thu Apr 11, 2013 3:03 am

Re: Qt5WebKit + Gstreamer + WebGL + Canvas

Sat Apr 05, 2014 1:02 pm

Hi! Thank you for your answer!
Did you do some further configuration? My /boot/config.txt is the default. How smoothly reveal.js runs? Here it wasn't very smooth. I tried out other html5 presentation system, like impress.js (http://bartaz.github.io/impress.js/#/bored) and looks very good.

I wonder if I start to put more JS (ajax call for example) in the impress.js it will be presented more slowly.

Code: Select all

disable_overscan=1
force_turbo=0
arm_freq=1000
gpu_freq=500
core_freq=500
sdram_freq=500
over_voltage=6
gpu_mem_256=128
gpu_mem_512=256
kernel=zImage
framebuffer_depth=32
Have you lost connection (no more ping or ssh access) with pi while running qtbrowser with reveal.js or hellorace?

Thanks! ;)

-- EDIT --
I'm still having the EGLFS issue..Did you installed some other package in menuconfig?

albertd
Posts: 51
Joined: Thu Aug 30, 2012 8:10 pm

Re: Qt5WebKit + Gstreamer + WebGL + Canvas

Sun Apr 06, 2014 9:58 am

vitorcarvalhoml wrote:I tried out other html5 presentation system, like impress.js (http://bartaz.github.io/impress.js/#/bored) and looks very good.
I agree impress.js looks a lot better, could be that the rendering is more optimised for the GPU please monitor the CPU on the RPI and use:

Code: Select all

export WEBKIT_SHOW_COMPOSITING_DEBUG_VISUALS=1
before launching the qtbrowser to debug the rendering, furthermore you can enable the web inspector by adding --inspector=9998 and goto http://<rpi ip address>:9998 to get a sense on what it's doing.
vitorcarvalhoml wrote:Have you lost connection (no more ping or ssh access) with pi while running qtbrowser with reveal.js or hellorace?
No I didn't have this problem, but could be the level of over clocking.
vitorcarvalhoml wrote:I'm still having the EGLFS issue..Did you installed some other package in menuconfig?
No I didn't add anything, what EGLFS issue are you getting?

Cheers,
Albert

albertd
Posts: 51
Joined: Thu Aug 30, 2012 8:10 pm

Re: Qt5WebKit + Gstreamer + WebGL + Canvas

Sun Apr 06, 2014 10:05 am

BTW which version are you using for the RPI, the 512MB model?

Return to “Official Foundation Display”