User avatar
DaedalusOS
Posts: 13
Joined: Mon Aug 26, 2019 8:08 pm

Display Resolution Issue

Fri Nov 01, 2019 9:06 pm

Greetings!

I've spent the past hour attempting to figure this out, to no avail...

I've hooked up my Raspberry Pi 4 to the 7" Touchscreen Display, and unfortunately I'm running into an issue with the resolution being larger than the display itself.

Output of tvservice -s:
state 0x400000 [LCD], 800x480 @ 60.00Hz, progressive

I have overscan disabled, and I made sure that /boot/config.txt doesn't have anything with overscan enabled in there.

The right side of my screen is cut off, I can't see the clock, and I can move the mouse off the physical screen. The touch is also offset, so if I touch anywhere on the screen, the mouse is about a centimeter to the right...

Any ideas?

Thanks!

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 27404
Joined: Sat Jul 30, 2011 7:41 pm

Re: Display Resolution Issue

Fri Nov 01, 2019 9:17 pm

Weird.

What version of Pi, what version of OS and are you using FKMS or legacy graphics?
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed.
I've been saying "Mucho" to my Spanish friend a lot more lately. It means a lot to him.

User avatar
DaedalusOS
Posts: 13
Joined: Mon Aug 26, 2019 8:08 pm

Re: Display Resolution Issue

Fri Nov 01, 2019 9:28 pm

jamesh wrote:
Fri Nov 01, 2019 9:17 pm
Weird.

What version of Pi, what version of OS and are you using FKMS or legacy graphics?

Code: Select all

cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
I did just run raspi-update earlier as well, to no avail.

As for graphics, how would I tell that? (I'm still somewhat new to this, sorry!)

Side note, when I run xwininfo -root, I get "-geometry 848x480+0+0"

User avatar
DaedalusOS
Posts: 13
Joined: Mon Aug 26, 2019 8:08 pm

Re: Display Resolution Issue

Sat Nov 02, 2019 3:29 pm

jamesh wrote:
Fri Nov 01, 2019 9:17 pm
Weird.

What version of Pi, what version of OS and are you using FKMS or legacy graphics?
Thanks for the hint above with this post, I went through /boot/config.txt and I found the following line:

Code: Select all

dtoverlay=vc4-fkms-v3d
Once I put a "#" before that and rebooted, everything is now literally fine. The touch is accurate and the screen resolution issue is now resolved.

Thanks!

Return to “Official Foundation Display”