pumpkinpi
Posts: 141
Joined: Fri Apr 18, 2014 7:11 pm

Solved but don't know why: RPi Display Goes Black at Boot

Fri Jul 19, 2019 3:19 am

I have an RPi 3B and have had it powering an RPi display for a few years. I recently reimaged my card using dd from another Pi+display combo that was working perfectly and tried to boot the system with both the source and the reimaged card. The display turns on when I boot the pi, shows the for red raspberries and then promptly goes black before showing me any text during boot. The pi boots perfectly fine because I can SSH into it and it seems to be fully functional, but the display stays off.

I know for sure it is not a power issue. I have used this power supply for a long time successfully and tried swapping to a new higher current one and also tried powering the display and pi separately. All with the same result.

I tried the reimage with a couple different cards. Same behaviour.

System is running Raspbian Stretch and is up to date.

Any tips on what I can investigate?

Thanks!
PPi
Last edited by pumpkinpi on Sat Jul 20, 2019 12:01 pm, edited 1 time in total.

pumpkinpi
Posts: 141
Joined: Fri Apr 18, 2014 7:11 pm

Re: RPi Display Goes Black at Boot

Sat Jul 20, 2019 12:00 pm

So, last night I hit on the rather obvious idea of just writing a new card and seeing if the screen comes on and works. It does. So, it is not a hardware issue. I will mark this on as "solved but don't know why".

dwmreg
Posts: 5
Joined: Wed Jul 17, 2019 2:51 am

Re: Solved but don't know why: RPi Display Goes Black at Boot

Sun Jul 21, 2019 3:25 am

I"m seeing this on my pi3b+ and 4b. Did you use a fresh recent version of the Raspberry PI OS downloadable from this site?

I think it has a major video bug of some kind. Some quirk.

User avatar
HawaiianPi
Posts: 4741
Joined: Mon Apr 08, 2013 4:53 am
Location: Aloha, Oregon USA

Re: Solved but don't know why: RPi Display Goes Black at Boot

Sun Jul 21, 2019 3:29 am

pumpkinpi wrote:
Fri Jul 19, 2019 3:19 am
I recently reimaged my card using dd from another Pi+display combo that was working ...
Next time try the SD Card Copier utility that's included with Desktop version of Raspbian.
My mind is like a browser. 27 tabs are open, 9 aren't responding,
lots of pop-ups...and where is that annoying music coming from?

pumpkinpi
Posts: 141
Joined: Fri Apr 18, 2014 7:11 pm

Re: Solved but don't know why: RPi Display Goes Black at Boot

Sun Jul 21, 2019 10:27 am

Oh, that is a really good idea. Thanks!

Return to “Official Foundation Display”