Nebulosis
Posts: 1
Joined: Wed Oct 03, 2018 6:26 pm

7” touchscreen not working

Wed Oct 03, 2018 6:34 pm

I got a new Raspberry Pi 7” official touchscreen today. I have assembled everything as instructed and when I hooked everything up to power, the Raspberry Pi lighting is on but there is no output to the screen. I’ve double checked all the FPC connections, all the pins are placed properly. And yes, I have checked, it works on my computer monitor. (I’m running the latest version of Raspbian.)
I’m a complete novice to the Raspberry Pi, so if anyone sheds some light on this issue that’d be great. Thanks in advance!

User avatar
DougieLawson
Posts: 34114
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: 7” touchscreen not working

Thu Oct 04, 2018 11:39 am

Can you get a photo of your Raspberry? There's been some reports of the DSI connector being mounted incorrectly on the board.

Also pull off the green and yellow wires you don't need those unless you've got an original RPi 1B.
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

2012-18: 1B*5, 2B*2, B+, A+, Z, ZW, 3Bs*3, 3B+

Any DMs sent on Twitter will be answered next month.

erik677
Posts: 2
Joined: Fri Oct 05, 2018 5:54 am

Re: 7” touchscreen not working

Fri Oct 05, 2018 10:25 am

Also check the white ribbon cable that connects the screen to your Raspberry Pi. I only bought this screen a couple of weeks ago and the initial trouble I had was because I had inserted it the wrong way around.

hth
Erik.

Return to “Official Foundation Display”