gxs
Posts: 2
Joined: Sun Jul 22, 2018 5:01 pm

Touch problem using the official 7" screen

Sun Jul 22, 2018 5:12 pm

I have exhausted all of my ideas so I'm turning to you the community for help.
I'm experiencing some odd issues with my screen that I don't know how to solve.

First thing first. My setup:
- Hifiberry AMP2
- Raspberry 3
- Official 7" screen
- SmartiPi case
- 18v 3A brick going to AMP2

Basically I want to make a sound system.

Now for the problem:
The thing is that the screen works fine when I use a USB cable and power it from anywhere (brick, battery,...).
But I want to power the thing with the least wires possible so I have used the pins and connected the 5v and gnd pins to AMP2. When I do that the screen doesn't respond to touch at all or rarely. Ok no problem. I have ordered a converter and split the power cable into two pieces. One goes to the AMP2 and powers it and the raspberry. And the other goes into the converter and converts to 5v and goes into the screen. The converter has both the USB and wire options so I can connect to either the pins or to the usb directly. It should work but yet it doesn't.

I have used both USB and pin cables. The USB cable works fine if I plug it into a battery bank. The converter itself does supply enough power. So I'm at a loss as to what is wrong here. Even connecting it to the raspberry 5v and gnd and powering it via GPIO should work in theory but doesn't. So what am I doing wrong?

Thanks for the help

gxs
Posts: 2
Joined: Sun Jul 22, 2018 5:01 pm

Re: Touch problem using the official 7" screen

Tue Jul 24, 2018 11:00 am

I forgot to add that the converter is able to output up to 5A so it should supply enough power for the screen itself.

Return to “Official Foundation Display”

Who is online

Users browsing this forum: No registered users and 1 guest