MattPackwood123
Posts: 18
Joined: Fri Apr 11, 2014 1:48 pm

Power Supply Issue?

Tue Feb 11, 2020 9:01 pm

I seem to be having issues with a RaPi3 and the Official display, I have a Y-Cable that splits a USB power supply, one part to feed the RaPi, the other to feed the display, but I seem to get hardware crashes. These "never" happen if only the RaPi is powered, do I need a higher current power supply (and where would I find one)?

Matt

fruitoftheloom
Posts: 21650
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Power Supply Issue?

Wed Feb 12, 2020 10:11 am

MattPackwood123 wrote:
Tue Feb 11, 2020 9:01 pm
I seem to be having issues with a RaPi3 and the Official display, I have a Y-Cable that splits a USB power supply, one part to feed the RaPi, the other to feed the display, but I seem to get hardware crashes. These "never" happen if only the RaPi is powered, do I need a higher current power supply (and where would I find one)?

Matt

You should not need a separate Power Supply for each device, the Official Power Supply should be sufficient:

https://www.raspberrypi.org/products/ra ... er-supply/

https://docs.rs-online.com/516e/0900766b81446707.pdf
Retired disgracefully.....
......to a more gentile life !

alphanumeric
Posts: 2310
Joined: Tue Jan 19, 2016 2:17 pm
Location: Sydney, Nova Scotia, Canada

Re: Power Supply Issue?

Sat Feb 15, 2020 9:11 pm

I've run my 7 inch touch with a Pi 3B+, 2.5A power supply, and Y power cable with no issues.
And my Pi 4B, 3A USB C power supply, and Y splitter cable with no issues.
My SmartiPi case comes with two different Y cables, One for use with a Pi 3B and one for use with a Pi 4B.

Return to “Official Foundation Display”