agavepi
Posts: 3
Joined: Thu Jul 11, 2019 1:49 am

No output coming from Raspberry Pi

Thu Jul 11, 2019 2:18 am

Pi newbie here and my first post!

I have a Raspberry Pi 3 B+ with the official foundation attached to it. I had it working correctly for 1 day and now I can't get any output from the device. For context, I did "slightly" bump the GPIO pins with the jumper cables attached and all of the sudden the screen stopped working. I believe the power GPIOs are working since I can see the pi's power led turn on when I connect the display to power.

Here are the scenarios that I've tried:
1. Reconnecting the GPIO cables and testing the touchscreen output -- nada
2. Reconnecting the ribbon and testing the touchscreen output -- nada
3. Disconnecting the GPIO and ribbon and testing the HDMI output -- nada

I am not sure what to do next to reconnect to it. Any ideas?

See attached for pics of the setup and cables:
https://ibb.co/wyLjpqy
https://ibb.co/pdzbj36
https://ibb.co/gR9294F
https://ibb.co/Z1BhRDP
https://ibb.co/vD7c7Kx

6by9
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 7407
Joined: Wed Dec 04, 2013 11:27 am
Location: ZZ9 Plural Z Alpha, aka just outside Cambridge.

Re: No output coming from Raspberry Pi

Thu Jul 11, 2019 9:46 am

You're on a Pi 3B+, therefore why are you connecting up the I2C pins when the instructions state this is only for the Model A and B (ie the very original models).
3. Disconnecting the GPIO and ribbon and testing the HDMI output -- nada
That would imply you've killed your Pi. Most likely you've shorted the 3.3V rail to something it shouldn't have been connected to and blown the PMIC.
Software Engineer at Raspberry Pi Trading. Views expressed are still personal views.
I'm not interested in doing contracts for bespoke functionality - please don't ask.

aBUGSworstnightmare
Posts: 1498
Joined: Tue Jun 30, 2015 1:35 pm

Re: No output coming from Raspberry Pi

Thu Jul 11, 2019 2:34 pm

what happens if you disconnect the jumper wires and power your Pi and your Screen via USB?

No need to connect I2C interface as this isconnected by the FPC cable!

What power supply do you use? Make sure you don't have strange settings in your config.txt which will cause the pi to fail during booting. Also let us know which OS you're using.

agavepi
Posts: 3
Joined: Thu Jul 11, 2019 1:49 am

Re: No output coming from Raspberry Pi

Fri Jul 12, 2019 2:42 am

what happens if you disconnect the jumper wires and power your Pi and your Screen via USB?
- nothing shows up.

No need to connect I2C interface as this isconnected by the FPC cable!
-got it!

What power supply do you use? Make sure you don't have strange settings in your config.txt which will cause the pi to fail during booting. Also let us know which OS you're using.
-i was using the official power supply but i was sending it directly to the pi and not to the screen. another noob question but how can i check the settings in the config.txt without being able to get something displayed on a screen? i also check i'm not able to remote connect as i normally do using VNC

thanks for the help!

User avatar
rpdom
Posts: 15361
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: No output coming from Raspberry Pi

Fri Jul 12, 2019 6:07 am

agavepi wrote:
Fri Jul 12, 2019 2:42 am
what happens if you disconnect the jumper wires and power your Pi and your Screen via USB?
- nothing shows up.
What LEDs are showing on the Pi when you power it up and what do they do?

Specifically the red PWR LED and the green ACT LED.

agavepi
Posts: 3
Joined: Thu Jul 11, 2019 1:49 am

Re: No output coming from Raspberry Pi

Mon Jul 15, 2019 11:35 pm

I tested with another pi and now I’m back in business. Can someone please confirm if my setup won’t fry it a second time?

https://imgshare.io/image/axUHS
https://imgshare.io/image/axYfK

Return to “Official Foundation Display”