cleroux
Posts: 1
Joined: Sun Dec 27, 2020 7:52 pm

RPi 4 case fan always on, fan control not working (fixed)

Sun Dec 27, 2020 9:49 pm

Hello all,
I'm posting this information here in the hopes it will be useful to others having the same problem.

I have a Raspberry Pi 4 with the official case fan. I've connected it as suggested in the official documentation. I enabled fan control using `raspi-config` with the default suggestions of pin 14 and 80°.

My problem was that the fan was always running full speed and quite noisy.

After some investigation I found that my `/boot/config.txt` file contained the following:

Code: Select all

dtoverlay=gpio-fan,gpio_pin=14,temp=80000
However, the configuration should be:

Code: Select all

dtoverlay=gpio-fan,gpiopin=14,temp=80000
The underscore character in `gpio_pin` was the problem. I changed it to `gpiopin` and the fan speed control is working properly now.

After some investigation, I found that this problem was already fixed in this commit:
https://github.com/RPi-Distro/raspi-con ... df64d53fe0

Upon further investigation, I found that my distribution image (RetroPie 4.7.1) included the buggy script.

I think the proper fix is to make sure your distribution is up-to-date with:

Code: Select all

sudo apt-get update
sudo apt-get upgrade
and then set the fan control setting again using `raspi-config`.

However, you may also edit the file manually to remove the underscore if you are unable to upgrade.

Snowmanbtw
Posts: 1
Joined: Thu Feb 04, 2021 9:03 pm

Re: RPi 4 case fan always on, fan control not working (fixed)

Thu Feb 04, 2021 9:06 pm

Hi, i recently picked up a case fan and I am also having this "always on" problem.

I did the "apt update" and the "full-upgrade". The fan doesn't seem to turn off.

idym95
Posts: 1
Joined: Wed Mar 31, 2021 5:32 pm

Re: RPi 4 case fan always on, fan control not working (fixed)

Wed Mar 31, 2021 6:44 pm

Snowmanbtw wrote:
Thu Feb 04, 2021 9:06 pm
Hi, i recently picked up a case fan and I am also having this "always on" problem.

I did the "apt update" and the "full-upgrade". The fan doesn't seem to turn off.
It might require a reboot, that seemed to do the trick for me.
Though does anyone know if there's a way to change fan settings in raspi-config without needing to reboot? I tried changing the threshold temperature and doesn't seem to make a difference unless I reboot..

Return to “Device Tree”