Page 1 of 1

[Solved-I think???] MagPi #58 - Fileserver HELL-P!!!

Posted: Wed May 31, 2017 1:26 pm
by Dwozzz
Hi All,

I have been driving myself crazy trying to get this working for weeks. To be fair, I am useless at this :lol: ! Anyway, long story short - when I saw this tutorial in MagPi I was so happy! I followed it almost to the letter the one difference being that I mounted the usb dev to the dir created... I used:

sudo mount /dev/sda1 /share

Could this be the problem? I literally have no idea here :(

My original cry for help is as yet unanswered in Networking:

Thanks in advance,

Re: MagPi #58 - Fileserver HELL-P!!!

Posted: Wed May 31, 2017 1:42 pm
by Dwozzz
Wow, wow, wow - I think it's finally working!!!!

I did a couple of extra things (Not my doing I read various guides from other people but thought it hadn't worked so closed all browsers down. After a sudo reboot it appeared this had worked?!? Sorry if this was your work - I'm not taking credit:

In the /etc/samba/smb.conf I changed:
  • 1) Under [Global]
    WINS support =yes (It was no)
  • 2) Under [homes]
    read only =no (It was yes)
  • 3) I did sudo chown pi:pi /nameofdirectorycreated -R
I restarted Samba each time but got frustrated as it didn't work...
Then gave up, did a sudo reboot and somewhere along the way it fixed it :shock: :? 8-)

Hope this helps someone else too?