Page 2 of 2

Re: STICKY: Help & Support

Posted: Tue Mar 27, 2018 4:22 am
by Whity
Fantastic, Many thanks for your help

Re: STICKY: Help with Spectrum Issue 67 Start Page 24

Posted: Sat Mar 31, 2018 5:47 pm
by RetroVeteran
The Spectrum keyboard is not being picked up by the RetroPie V4.3 and of course does not work with FUSE. I have used the test program to test the Spectrum Keyboard and works as per expectation. I have followed all the steps published in the article and even been on line to which provides a different listing to use. It appears that some parts of the article have disappeared from the printed version. So any help would be appreciated if of practical use. What might really help would be to hear from someone who has managed to get this working from the original article. Many thanks

Re: STICKY: Help & Support

Posted: Thu Apr 05, 2018 4:43 pm
by RetroVeteran
I have finally managed to resolve this issue myself. :lol: :lol: :lol: :lol: :lol: :lol: :lol:
Quite simple really, just never spotted the error in the listing. :evil: :evil:
Of course this could just apply to my system, I don't know.
My solution to missing Spectrum Keyboard on boot Is as follows:

Original Code reads:
/usr/bin/python /home/pi/

On my system is in a further directory zxscanner, so never gets executed using the original code provided.
I moved to the correct directory and problem resolved. Of course I assume you could just have done this:

/usr/bin/python /home/pi/zxscanner/
I have not tested that out.

A massive thank you and appreciation must go to PJEvans the original author for all his help and assistance in trying to resolve my problem.

Re: STICKY: Help & Support - Issue 69, Touchscreen & Data system

Posted: Sun May 27, 2018 4:34 pm
by Dave5910715
Must confess I'm new to all this (but not in age!) so please excuse any obvious blunders / questions etc - more of an Arduino user after a bit more flexibility.

I'm trying the MagPi tutorial by Peter Juett on page 46 of issue 69 (May 2018), much to my amazement I've installed all the various programmes (mosquitto, sqlite3, apache2, PHP etc) up as far as the part at the bottom of page 47 -
"Install the source code modules from GitHub repo (the Python modules, required libraries. webpages, and subfolders). You can find more details in the file on GitHub."
With no links provide what should I be looking for on GitHub to find this file - a link would be appreciated.

Re: STICKY: Help & Support

Posted: Sun May 27, 2018 5:03 pm
by B.Goode
I think maybe it is the site referenced by an obscured url towards to top of that column of text, which is also duplicated in the Download box on the right of the page?

(Apologies if I am wrong, but the paid staff of the MagPi magazine might not be back until Tuesday... )

Re: STICKY: Help & Support

Posted: Sat Sep 29, 2018 6:11 pm
by brentw
I'm trying to go through the series of articles about making games in C++ on Raspberry Pi. (starting with issue 65)
I've spent tons of time searching and I'm just not finding answers. I really want to follow this guide, please help!

I've spent 2 days stuck at issue 66.

The primary issue is that the files the article tells me to link simply are not there.
I've tried using files with similar names that I was hoping might be the right ones, but it's still not working.

Here's what the article tells me to link and what I've actually found to link:

Ariticle -> Mine ->
GLESv2_static.a -> libGLESv2_static.a
EGL_static.a -> libEGLstatic.a
vchiq_arm.a -> libvchiq_arm.a
vcos.a -> (there is no .a file even close to this)
khrn_static.a -> libkhrn_static.a

After trying to build with these files linked I'm getting the error:
undefined reference to symbol 'pthread_getspecific@@GLIBC_2.4'
I've searched this error and tried every suggestion found, like adding compiler flags -pthread or -lpthread or -ldl, with no success.

Please help me, I really want to learn how to do graphics on the Raspberry PI.

Re: STICKY: Help & Support

Posted: Sat Sep 29, 2018 7:29 pm
by DougieLawson
What compiler options are you using? Do you have -lpthread or -pthread as a compiler option?

Re: STICKY: Help & Support

Posted: Sat Sep 29, 2018 7:42 pm
by brentw
I added:
#include <pthread.h>
to OGL.h.

And I've tried building with compiler flags:
-pthread, -lpthread, and -ldl
Each one separately and even all at once.

No matter what I still get the error:
undefined reference to symbol 'pthread_getspecific@@GLIBC_2.4'

Re: STICKY: Help & Support

Posted: Sat Sep 29, 2018 8:02 pm
by DougieLawson
I got it to compile cleanly with
g++ -o Game -I/opt/vc/include -L/opt/vc/lib -lGLESv2 -lbcm_host -lEGL -lvcos Game.cpp OGL.cpp SimpleObj.cpp main.cpp

Note: I've not read the article and I've not changed any of the source code.

Re: STICKY: Help & Support

Posted: Sun Sep 30, 2018 1:08 am
by brentw
I've now tried compiling with that command, instead of Codeblocks like the Tutorial suggested, and this time I'm getting a fatal error that EGL/egl.h doesn't exist, which I can't figure out because it is exactly where it's supposed to be. (opt/vc/include/EGL/egl.h)

Re: STICKY: Help & Support

Posted: Sun Sep 30, 2018 7:06 am
by DougieLawson
brentw wrote:
Sun Sep 30, 2018 1:08 am
..., which I can't figure out because it is exactly where it's supposed to be. (opt/vc/include/EGL/egl.h)
There's a leading slash on /opt/vc... (not opt/vc...).

Re: STICKY: Help & Support

Posted: Sun Sep 30, 2018 4:32 pm
by brentw
That's not a line from the project, i was just explaining where egl.h is located.

Re: STICKY: Help & Support

Posted: Tue Feb 05, 2019 10:02 pm
by spike77

i am experiencing the same problem with the "Coding Games with C++" - Tutorial. In fact i am reading the german version of the MagPi but the Articles are quite similar and they include the same instructions.

I am not able to compile the Code from the second Part and i get error messages. (i am using raspbian stretch / rpi 3B+)

Here is my build messages from codeblocks.

Code: Select all

Build: Debug in MagPiHelloTriangle (compiler: GNU GCC Compiler)
/usr/bin/ld: ../../../../../../opt/vc/lib/libEGL_static.a(khrn_client_platform_linux.c.o)||undefined reference to symbol 'pthread_getspecific@@GLIBC_2.4'|
error: ld returned 1 exit status|
Build failed: 2 error(s), 0 warning(s) (0 minute(s), 0 second(s)) 
i am quite disappointed bc i really want to go through the whole tutorial in order to learn coding c++. But i have no clue, what i can adjust anymore. I hoped this tutorial would work out of the box. :/

Can anyone help? I bet there must be someone out there, who could solve this problem bc i dont believe i am the only one who tried this Tutorial :-)

Greetings and thanks in advance!

Post scriptum, my system is out of the box, i didnt changed anything, and the code of the first article can be compiled without errors.

UPDATE: after constantly trying i solved at least my problem. It was constantly reporting about that problem in this libEGL_static.a - Library. So i removed this line from the Linker settings and then it worked fine! Jeah i am happy :-)

Re: STICKY: Help & Support

Posted: Tue Sep 10, 2019 12:02 am
by SohCahToa
I am hitting a roadblock trying to follow the "Build Your Own NAS" tutorial

I am lost at how to troubleshoot this error and cannot find anything online

Code: Select all

pi@raspberrypi:/ $ sudo apt install mdadm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/400 kB of archives.
After this operation, 1,125 kB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously unselected package mdadm.
(Reading database ... 156741 files and directories currently installed.)
Preparing to unpack .../archives/mdadm_4.1-1_armhf.deb ...
Unpacking mdadm (4.1-1) ...
Setting up mdadm (4.1-1) ...
W: mdadm: failed to load MD subsystem.
update-initramfs: deferring update (trigger activated)
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for systemd (241-5+rpi1) ...
Processing triggers for initramfs-tools (0.133+deb10u1) ...

pi@raspberrypi:/ $ sudo mdadm --create /dev/md0 --level=mirror --raid-devices=2 /dev/sda1 /dev/sdb1
mdadm: Note: this array has metadata at the start and
    may not be suitable as a boot device.  If you plan to
    store '/boot' on this device please ensure that
    your boot-loader understands md/v1.x metadata, or use
Continue creating array? y
modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.19.57-v7l+/modules.dep.bin'
modprobe: FATAL: Module md_mod not found in directory /lib/modules/4.19.57-v7l+
mdadm: Fail create md0 when using /sys/module/md_mod/parameters/new_array
mdadm: unexpected failure opening /dev/md0

Re: STICKY: Help & Support

Posted: Wed Sep 11, 2019 1:34 pm
by MrPJEvans
Could you tell me a bit about your environment? Which Pi and which OS are you using (specifically what type of Raspbian). Did you try it after a reboot?