claytonjordan
Posts: 4
Joined: Tue Jul 03, 2018 7:31 pm

Windows 10 IoT Raspberry Pi 3 Errors

Tue Jul 03, 2018 8:10 pm

I've recently tried to install Windows 10 IoT core build 17134 on my RPI 3 model B. Upon boot, I'm given the error code:
0xc000014c.
It contains the following:
Windows failed to start. A recent hardware or software change may be the cause. To fix the problem:
(it gives me some useless tips that involve using a windows install disc.)
I'm not using one of the 2 recommended micro SD cards, however it is a class 10 and has 14Gb, the minimum being 8. About a year ago, an older build did work on my RPI 2B, so is it maybe a problem with the build? I don't see many using this version online. I've also made sure that I'm providing enough juice to the board. I notice that when I plug in the ethernet cable, the indication light does not flash.

I don't have any more info than that, but any help or advice would be greatly appreciated!

-Clayton

User avatar
DougieLawson
Posts: 34562
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Windows 10 IoT Raspberry Pi 3 Errors

Tue Jul 03, 2018 8:28 pm

Is it a 3B or 3B+?

If it's a 3B+ you need to get a special build of Win10 IoT 17661 (or later).

https://www.microsoft.com/en-us/softwar ... windowsiot

https://social.msdn.microsoft.com/Forum ... WindowsIoT
Note: Having anything remotely humorous in your signature is completely banned on this forum.

Any DMs sent on Twitter will be answered next month.

This is a hippy & doctor free zone.

claytonjordan
Posts: 4
Joined: Tue Jul 03, 2018 7:31 pm

Re: Windows 10 IoT Raspberry Pi 3 Errors

Tue Jul 03, 2018 10:22 pm

It's just a model B. Through some online tutorials I learned that the B+ needs the special build, but I'm still really confused as to why this one isn't working with my unit. Before erasing the card, I had the AIY voice hat installed. Could removing it have an affect on the installation of the IoT build? Do I maybe need to do a factory reset in Raspbian (if that's even an option)?

User avatar
DougieLawson
Posts: 34562
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: Windows 10 IoT Raspberry Pi 3 Errors

Tue Jul 03, 2018 11:42 pm

Win10 IoT doesn't know or care what additional hardware you may or may not have attached. Try the 17692 build on your 3B and see how that goes.
Note: Having anything remotely humorous in your signature is completely banned on this forum.

Any DMs sent on Twitter will be answered next month.

This is a hippy & doctor free zone.

claytonjordan
Posts: 4
Joined: Tue Jul 03, 2018 7:31 pm

Re: Windows 10 IoT Raspberry Pi 3 Errors

Wed Jul 04, 2018 12:50 am

I gave the build you suggested a try, and it spit out the same error with a different text saying something about the hardware configured incorrectly or something on the lines of that. (I didn't get a chance to get a picture because) Shortly after, the windows logo flashed on screen and it started to boot normally. I noticed the ethernet led started flashing normally and the Pi eventually appeared on the "my devices" list. It's taking a long time to boot but maybe it'll come around and work normally. I'll keep you posted in case the error continues

claytonjordan
Posts: 4
Joined: Tue Jul 03, 2018 7:31 pm

Re: Windows 10 IoT Raspberry Pi 3 Errors

Wed Jul 04, 2018 1:07 am

After about 15 minutes of a continuous boot loop, I was left on a screen with the starting error, 0xc000014c. This time, it stated:
File: \efi\microsoft\boot\BCD
Info: The Boot Configuration Data for you PC is missing or contains errors.

Could this be as small of a matter as not ejecting the card safely or something? I don't know what would make the card have a corrupted boot volume.

Return to “Windows 10 for IoT”