Bajtek
Posts: 23
Joined: Fri Feb 02, 2018 7:19 pm

Win IOT don't boot (2014)

Fri Feb 02, 2018 7:31 pm

Hello.
I have 4 Raspberry PIs named on PCB "Raspberry PI 2014".
I'm using latest Dashboard app to flash the card with Windows.
It's hanging on rainbow screen.
It's running Raspbian properly on the same card.
Power supply is OK; I even tried with lab power source (3A). It's not taking to much during bootup (less then 1A).
Green LED is blinking 4 times slow and next 4 times fast. Didn't found explanation of such LED behavior.
When I put the same card (with Windows IOT) into another "Raspberry PI 2015" it's working fine.
Is it possible that there is such difference between year of production? What means such blinking?
I was trying to get some info through RS232 (I have FTDI), but I get only 0 during start. It's working OK with Raspbian (I have good communication on my Terminal using 115200 baud).
I'm stuck, please help me.
Thanks in advance.
Bajtek

fruitoftheloom
Posts: 17838
Joined: Tue Mar 25, 2014 12:40 pm

Re: Win IOT don't boot (2014)

Fri Feb 02, 2018 9:46 pm

Removed as inappropriate response.
Last edited by fruitoftheloom on Fri Feb 02, 2018 11:53 pm, edited 1 time in total.
Adieu

User avatar
DougieLawson
Posts: 34166
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: Win IOT don't boot (2014)

Fri Feb 02, 2018 11:20 pm

You can't run Win10 IoT on anything earlier than a Raspberry Pi 2B. It will NOT run on any model of RPi Zero, any RPi1B, 1A, B+ or CM1.

The Raspberry Pi 2 Model B is the second-generation Raspberry Pi. It replaced the original Raspberry Pi 1 Model B+ in February 2015.
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

2012-18: 1B*5, 2B*2, B+, A+, Z, ZW, 3Bs*3, 3B+

Any DMs sent on Twitter will be answered next month.

Bajtek
Posts: 23
Joined: Fri Feb 02, 2018 7:19 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 10:56 am

IMG_20180203_121916.jpg
IMG_20180203_121916.jpg (64.66 KiB) Viewed 1923 times
I'm using Raspberry Pi 2 Model B V1.2.
With above model it's not booting.
But it's booting properly with model below.
IMG_20180203_122131.jpg
IMG_20180203_122131.jpg (47.99 KiB) Viewed 1919 times
Last edited by Bajtek on Sat Feb 03, 2018 11:24 am, edited 2 times in total.

fruitoftheloom
Posts: 17838
Joined: Tue Mar 25, 2014 12:40 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 11:22 am

Bajtek wrote:
Sat Feb 03, 2018 10:56 am
I'm using Raspberry 2 B V1.2

There are several W10IoT revisions released over the last 3 years, are you using the standard or insider preview ??

Microsoft do have their own support forum: https://social.msdn.microsoft.com/forum ... WindowsIoT
Adieu

Bajtek
Posts: 23
Joined: Fri Feb 02, 2018 7:19 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 11:26 am

I was trying both versions (standard and insider preview). It doesn't matter.
Last edited by Bajtek on Sat Feb 03, 2018 4:52 pm, edited 1 time in total.

Bajtek
Posts: 23
Joined: Fri Feb 02, 2018 7:19 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 11:36 am

And what about led blinking? 4 times slow next 4 times fast? How to read it? Is it 8 or 4?

fruitoftheloom
Posts: 17838
Joined: Tue Mar 25, 2014 12:40 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 11:39 am

Bajtek wrote:
Sat Feb 03, 2018 11:36 am
And what about led blinking? 4 times slow next 4 times fast? How to read it? Is it 8 or 4?
Which one ?? viewtopic.php?f=28&t=58151
Adieu

Bajtek
Posts: 23
Joined: Fri Feb 02, 2018 7:19 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 11:45 am

Green one (act), next to red (power)

Bajtek
Posts: 23
Joined: Fri Feb 02, 2018 7:19 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 4:49 pm

DougieLawson wrote:
Fri Feb 02, 2018 11:20 pm
The Raspberry Pi 2 Model B is the second-generation Raspberry Pi. It replaced the original Raspberry Pi 1 Model B+ in February 2015.
So, how it's possible that I have Raspberry Pi 2 Model B produced in 2014?

B.Goode
Posts: 6544
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 5:13 pm

Bajtek wrote:
Sat Feb 03, 2018 4:49 pm
DougieLawson wrote:
Fri Feb 02, 2018 11:20 pm
The Raspberry Pi 2 Model B is the second-generation Raspberry Pi. It replaced the original Raspberry Pi 1 Model B+ in February 2015.
So, how it's possible that I have Raspberry Pi 2 Model B produced in 2014?
Your photo does not prove that it was produced in 2014. Only that copyright was claimed for it in 2014.

That does not seem unreasonable: for a device that went on sale (and was actually available for purchase and delivery) in February 2015 the designs would need to be finalized some time in advance. And manufacturing probably began in 2014...

User avatar
DougieLawson
Posts: 34166
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 7:13 pm

Boot Raspbian on it and take a look.
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

2012-18: 1B*5, 2B*2, B+, A+, Z, ZW, 3Bs*3, 3B+

Any DMs sent on Twitter will be answered next month.

Bajtek
Posts: 23
Joined: Fri Feb 02, 2018 7:19 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 7:36 pm

Take a look on what?
I wrote already Raspbian is working fine.

Bajtek
Posts: 23
Joined: Fri Feb 02, 2018 7:19 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 7:56 pm

I just read release notes for latest Win IOT build and found out it's reference board is Raspberry PI 3. I think Microsoft is not supporting Raspberry PI 2 anymore and not even test Win IOT on this platform. I have one Raspberry PI 3 and it's working OK with the same card (which is not working with my Raspberry PI 2 from 2014). I remember 1 year ago I was buying Raspberry PI 2 just because current IOT wasn't working with Raspberry PI 3.
One thing left uncleared for me: 4 slow blinks and next 4 fast blinks of ACT LED. Does anybody knows what it means? I will look for it in BSP for Win IOT, but maybe someone could have such experience?

User avatar
rpdom
Posts: 12949
Joined: Sun May 06, 2012 5:17 am
Location: Ankh-Morpork

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 8:05 pm

Bajtek wrote:
Sat Feb 03, 2018 7:36 pm
Take a look on what?
I wrote already Raspbian is working fine.
Take a look at which model of Pi they are.

Try running this command for the EXACT model name

Code: Select all

cat /proc/device-tree/model;echo

Bajtek
Posts: 23
Joined: Fri Feb 02, 2018 7:19 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 9:15 pm

Done.
It's Raspberry Pi 2 Model B Rev 1.2

fruitoftheloom
Posts: 17838
Joined: Tue Mar 25, 2014 12:40 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 9:38 pm

Bajtek wrote:
Sat Feb 03, 2018 9:15 pm
Done.
It's Raspberry Pi 2 Model B Rev 1.2

That is not correct:

Q3 2016 2 Model B (with BCM2837) 1.2

https://elinux.org/RPi_HardwareHistory
Adieu

fruitoftheloom
Posts: 17838
Joined: Tue Mar 25, 2014 12:40 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 9:40 pm

Bajtek wrote:
Sat Feb 03, 2018 7:56 pm
I just read release notes for latest Win IOT build and found out it's reference board is Raspberry PI 3. I think Microsoft is not supporting Raspberry PI 2 anymore and not even test Win IOT on this platform. I have one Raspberry PI 3 and it's working OK with the same card (which is not working with my Raspberry PI 2 from 2014). I remember 1 year ago I was buying Raspberry PI 2 just because current IOT wasn't working with Raspberry PI 3.
One thing left uncleared for me: 4 slow blinks and next 4 fast blinks of ACT LED. Does anybody knows what it means? I will look for it in BSP for Win IOT, but maybe someone could have such experience?

Yes the Fall Creators Update only supports the BCM2837 SoC:

https://docs.microsoft.com/en-us/window ... torsupdate

Unfortunately the MS Web Site is a mess, with lack of up to date info, seems MS only care about ARM Qualcomm SoCs these days !!
Adieu

Bajtek
Posts: 23
Joined: Fri Feb 02, 2018 7:19 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 10:12 pm

Now all seems to be more clear for me. Thanks.
Where can I find images of previous Windows IOT version to run it on Raspberry with BCM2836? Dashboard always use latest builds.
Or maybe it's not possible because IOT never worked with 2836 and Raspberries I bought before (with 2015 year on pcb) had 2837 already (I don't have them anymore to check it)?

Bajtek
Posts: 23
Joined: Fri Feb 02, 2018 7:19 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 10:20 pm

Hmmm... I just checked the boards of Raspberry Pi 2 and 3 I have. Both have BCM2836.

fruitoftheloom
Posts: 17838
Joined: Tue Mar 25, 2014 12:40 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 10:20 pm

Bajtek wrote:
Sat Feb 03, 2018 10:12 pm
Now all seems to be more clear for me. Thanks.
Where can I find images of previous Windows IOT version to run it on Raspberry with BCM2836? Dashboard always use latest builds.
Or maybe it's not possible because IOT never worked with 2836 and Raspberries I bought before (with 2015 year on pcb) had 2837 already (I don't have them anymore to check it)?

MS do monitor their own dedicated support forum:

https://social.msdn.microsoft.com/forum ... WindowsIoT
Adieu

fruitoftheloom
Posts: 17838
Joined: Tue Mar 25, 2014 12:40 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 10:22 pm

Bajtek wrote:
Sat Feb 03, 2018 10:20 pm
Hmmm... I just checked the boards of Raspberry Pi 2 and 3 I have. Both have BCM2836.

Please look at the elinux link I posted as you are totally wrong about SoC / Models......
Adieu

Bajtek
Posts: 23
Joined: Fri Feb 02, 2018 7:19 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 10:24 pm

Sorry. I meant 2837.
So, that confirms I have board Rev 1.2.
So, should it work with the newest IOT for Raspberry 3?
And now in this situation I have to back to previous post that the same image work with Raspberry 2 Rev 1.2 from 2015, but don't work with Raspberry 2 Rev 1.2 from 2014. It seems they are different.
Last edited by Bajtek on Sat Feb 03, 2018 10:35 pm, edited 1 time in total.

fruitoftheloom
Posts: 17838
Joined: Tue Mar 25, 2014 12:40 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 10:34 pm

Bajtek wrote:
Sat Feb 03, 2018 10:24 pm
Sorry. I meant 2837.

Well it can not be 2014 if it has BCM2837, please post the correct information and not make it up !!

https://en.wikipedia.org/wiki/Raspberry_Pi

I am out of here..........
Adieu

Bajtek
Posts: 23
Joined: Fri Feb 02, 2018 7:19 pm

Re: Win IOT don't boot (2014)

Sat Feb 03, 2018 10:43 pm

Have a look at photo
IMG_20180203_234100-733x524.jpg
IMG_20180203_234100-733x524.jpg (106.33 KiB) Viewed 1732 times

Return to “Windows 10 for IoT”