Humphrey181
Posts: 2
Joined: Mon Jun 12, 2017 1:39 am

Failed to unpack Windows 10 IoT core

Mon Jun 12, 2017 1:54 am

Excuse a newbie question

I have downloaded the dashboard and the Windows 10 IoT core but adding it to the SD card produces the following error
Failed to unpack Windows 10 IoT core installation package
Now I have deleted and reinstalled the dashboard but the Windows 10 IoT Core download does not download again. I believe its corrupted (function of dodgy wifi) but i cannot fix it because the Dashboard will not redownload it. Can anyone offer some advice on how to fix this?? I'm dead in the water until i can get this loaded.

Humphrey

beta-tester
Posts: 1207
Joined: Fri Jan 04, 2013 1:57 pm
Location: de_DE

Re: Failed to unpack Windows 10 IoT core

Mon Jun 12, 2017 9:07 am

i don't know, where the dashboard will store the downloaded image... i guess the faulty one is still at that location - even reinstallation. find the locationwhere the faulty image was downloaded and delete it.
maybe then it will start to download it again.

PS.: on my PC the dashboard is downloading the image to "%TEMP%\RPi2\windows_10_iot_core_15063.iso"
so delete the whole content of your temp folder RPi2 and try it again.

but dashboard is downloading the iso file and extracting the included msi file. i am wondering that, if the download is corrupted, the extraction does not fail - there are normally checksums to detect corrupt files.
{ I only give negative feedback }
RPi Model B (rev1, 256MB) & B (rev2, 512MB) & B+, RPi2B (1GB), 64GB microSDXC1 class 10, HDMI 1920x1080, keyboard-mouse-combo (wireless), PiCamera, ethernet-cable, 5V/1.2A power supply, Wifi dongle (rt5370)

Humphrey181
Posts: 2
Joined: Mon Jun 12, 2017 1:39 am

Re: Failed to unpack Windows 10 IoT core

Tue Jun 13, 2017 11:35 am

Many thanks for the pointers.

I've removed the suspect ISO and downloaded it again - to no avail. Same issue. I tried a different brand of SD card - same issue. I will continue to persevere and will update the brains trust if i find a solution.

fruitoftheloom
Posts: 17299
Joined: Tue Mar 25, 2014 12:40 pm

Re: Failed to unpack Windows 10 IoT core

Tue Jun 13, 2017 3:25 pm

Humphrey181 wrote:Many thanks for the pointers.

I've removed the suspect ISO and downloaded it again - to no avail. Same issue. I tried a different brand of SD card - same issue. I will continue to persevere and will update the brains trust if i find a solution.
Windows 10 IoT Core is developed solely by Microsoft, so it may get noticed if you post on their forum as you are not the first to have difficulties:

https://social.msdn.microsoft.com/forum ... WindowsIoT
Adieu

1234
Posts: 1
Joined: Sat Jul 22, 2017 2:42 am

Re: Failed to unpack Windows 10 IoT core

Sat Jul 22, 2017 3:21 am

(1) The Dashboard installs the downloaded files in your USERS\<your name>\AppData\Local \Temp file. To see the AppData folder you will need to turn on hidden folders. You do that by opening up File Explorer, open the View tab and click "Hidden Items". That will show all the hidden folders that a normal user should not see.
The folders are ~~~ Temp\ Rpi2 windows_10_iot_core_15063.iso 771,558 KB
And Temp\Rpi2 \ msi Windows_10_IoT_Core_for_RPi.msi 770,936 KB

If you need to check that the download is correct, you can use a tool from Microsoft "FCIV.exe" and read the directions. Search for it on the Microsoft TechNet website. Use it from a command prompt as
fciv.exe window_10_core_15063.iso -SHA1
I downloaded the Windows_10_iot_files three times using the dashboard and each time I got the SHA1 checksums below.as the output from the FCIV.exe. The dashboard checks your temp file, and if it finds the files there it does not download them again. So to download twice, you will need to move the rpi2 folder out of Temp. the Dashboard program will look in Temp, see nothing and download again.
ISO bccfd6049 01015a530 ea54d06574 c557014 11817 windows_10_iot_core_15063.iso
MSI ffde10 e9e4237 f4fd14605 77f784f 438 edf14 5d8 windows_10_iot_core_for_rpi.msi

(2) The file WindowsIOTDashboard_setup.exe[ installs the wizard "WindowsIOTCoreDashboard. IF the Dashboard "Failed to unpack Windows 10 ....etc." , it is because you as an administrative user do not have enough permission to install a new operating system. As the years go by, Microsoft tries to keep ahead of the hackers and sometimes the need for security conflicts with my desire for freedom.

(3)There is an account in Windows 10 called Administrator. It is similar to the UNIX root user, all powerful. Microsoft starts this account as disabled and it should stay disabled. however if your installation is failing after the download of Windows you will need to activate this account. Then you will need to logon as Administrator. That will show as one of the choices in the logon screen. Then you will need to download the Dashboard again and let the Dashboard will download the windows_10_iot_core_15063.iso file.

(4) After the Dashboard program runs and installs the IOT_Core onto your mini SD, go back and disable the Administrator account. If a hacker hits your computer and you are using the Administrator account, you will be paying Ransomware to somebody in Europe.

Hopes this helps. If you are new to Windows, here are the same instructions in pictures
http://www.keerthiteja.net/2016/10/fail ... -core.html

robbydal
Posts: 4
Joined: Sat Mar 31, 2018 2:18 am

Re: Failed to unpack Windows 10 IoT core

Wed Apr 04, 2018 5:13 pm

Deleting Temporary files https://youprogrammer.com/how-to-delete ... ws-10-8-7/
may help with the issue.

Return to “Windows 10 for IoT”

Who is online

Users browsing this forum: No registered users and 2 guests