doezel
Posts: 5
Joined: Wed Jan 06, 2016 2:27 pm

Display works on Raspbian Jessie, but not on W10 IOT?

Wed Jan 06, 2016 2:32 pm

Hi!

this is really bugging me:

I read that since 10566 the Display part of this 7" touch display is working on windows 10 IOT.

I just received and connected this display.

When I install Raspbian Jessie on my microSD, the PI2 shows a nice colourfull square and boots directly to the touch-screen.

When I power down and insert a microSD with W10 IOT 10586 on it, it just uses the HDMI for display and not the screen.

Do I need to change anything to get it working?

HELP!

ricl
Posts: 657
Joined: Wed Aug 26, 2015 11:55 am

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Wed Jan 06, 2016 4:20 pm

Nope. it just works/ed straight out of the box for me. No touch as yet of ourse
ricl : F/gamma = ma : Law ii(a) : https://climatedatablog.wordpress.com/2016/01/02/an-energy-challenge-2016/ #AnEnergyChallenge2016

doezel
Posts: 5
Joined: Wed Jan 06, 2016 2:27 pm

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Wed Jan 06, 2016 5:37 pm

On 10586?

So you just let your desktop write the image to the sd and let the pi2 boot from it?

talpa
Posts: 3
Joined: Wed Jan 06, 2016 7:38 pm

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Wed Jan 06, 2016 7:41 pm

Try the Windows 10 IoT Core Dashboard tool to create an image.
Then it works out of the box

http://ms-iot.github.io/content/en-US/Downloads.htm

ricl
Posts: 657
Joined: Wed Aug 26, 2015 11:55 am

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Wed Jan 06, 2016 7:50 pm

I just followed the steps on the IOT site and FAQ to write the sd card in a PC. That is the only supported way to create an image.

Followed the steps to install the screen likewise. Add hardware. Power on and bingo
ricl : F/gamma = ma : Law ii(a) : https://climatedatablog.wordpress.com/2016/01/02/an-energy-challenge-2016/ #AnEnergyChallenge2016

talpa
Posts: 3
Joined: Wed Jan 06, 2016 7:38 pm

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Wed Jan 06, 2016 8:57 pm

talpa wrote:Try the Windows 10 IoT Core Dashboard tool to create an image.
Then it works out of the box

http://ms-iot.github.io/content/en-US/Downloads.htm

I have another pi and screen (Model 2015 V1.1) this screen doesn't work!
The working model is Model 2014 V1.0

Does anyone known what's changed?

doezel
Posts: 5
Joined: Wed Jan 06, 2016 2:27 pm

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Thu Jan 07, 2016 7:43 am

Yeah, this is the issue:

The V1.0 (c) Raspberry PI 2014 works with IOT.
The V1.1 (c) Raspberry PI 2015 doesn't work with IOT!!!!

So, what changed and can we reverse or fix it?

ricl
Posts: 657
Joined: Wed Aug 26, 2015 11:55 am

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Thu Jan 07, 2016 11:30 am

You will probably have to ask the someone from the Raspberry Pi Foundation as they produce the hardware and, it what you say is true, then the change has broken the MS interface to the GPU. IoT relies on the GPU and its firmware/software to work.

We will have to wait for MS and the Pi team to talk over what is broken and how to fix it.
ricl : F/gamma = ma : Law ii(a) : https://climatedatablog.wordpress.com/2016/01/02/an-energy-challenge-2016/ #AnEnergyChallenge2016

ricl
Posts: 657
Joined: Wed Aug 26, 2015 11:55 am

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Thu Jan 07, 2016 11:35 am

I have cross posted this to the MS IoT forum on your behalf.
ricl : F/gamma = ma : Law ii(a) : https://climatedatablog.wordpress.com/2016/01/02/an-energy-challenge-2016/ #AnEnergyChallenge2016

doezel
Posts: 5
Joined: Wed Jan 06, 2016 2:27 pm

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Thu Jan 07, 2016 1:30 pm

ricl wrote:I have cross posted this to the MS IoT forum on your behalf.
Thanks, where did you post it?

ricl
Posts: 657
Joined: Wed Aug 26, 2015 11:55 am

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Thu Jan 07, 2016 2:15 pm

ricl : F/gamma = ma : Law ii(a) : https://climatedatablog.wordpress.com/2016/01/02/an-energy-challenge-2016/ #AnEnergyChallenge2016

talpa
Posts: 3
Joined: Wed Jan 06, 2016 7:38 pm

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Thu Jan 07, 2016 3:32 pm

I have an older version of Raspbian Jessie (23-09-2015)
Then the screen V1.1 doesn't work
The V1.0 does work.
With the latest version Raspbian Jessie (21-11-2015) both screens work.

doezel
Posts: 5
Joined: Wed Jan 06, 2016 2:27 pm

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Thu Jan 07, 2016 5:07 pm

Talpa: True, but I'm talking about Windows 10, not Linux.

ricl
Posts: 657
Joined: Wed Aug 26, 2015 11:55 am

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Thu Jan 07, 2016 5:34 pm

Yep. It looks like the hardware update has broken the MS driver to GPU that was working previously. Let's hope the patch requirement to Linux was passed on to MS as well and then this should be solved quickly

As I noted above, I have posted this to the MS site so as to speed responses
ricl : F/gamma = ma : Law ii(a) : https://climatedatablog.wordpress.com/2016/01/02/an-energy-challenge-2016/ #AnEnergyChallenge2016

stonelance
Posts: 3
Joined: Thu Jan 07, 2016 11:08 pm

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Thu Jan 07, 2016 11:10 pm

Yup, I also have revision 1.1 (just got it last week), and am having the same problem. It works in raspbian from Nov, but nothing but black in Win 10 IoT.

Does anyone know the difference between the v1.0 and v1.1 revisions? Are there any fixes or feature differences?

ricl
Posts: 657
Joined: Wed Aug 26, 2015 11:55 am

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Fri Jan 08, 2016 3:05 am

"
This is not an official confirmation, but I can tell you that I have a display with a v1.0, 2014 version of the PCB and it DOES work with my Rpi 2 running Windows 10 IoT Core build 10.0.10586. That is the display works, but does not support the touch functionality.


I have a colleague that has a v1.1, 2015 version of the PCB and it DOES NOT work for him.

Again, this is isn't scientific or official confirmation, but at least mirrors what the site says."

So MS are now aware and looking to find cause
ricl : F/gamma = ma : Law ii(a) : https://climatedatablog.wordpress.com/2016/01/02/an-energy-challenge-2016/ #AnEnergyChallenge2016

Quin Davidson
Posts: 1
Joined: Wed Jan 06, 2016 10:05 am

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Fri Jan 08, 2016 1:20 pm

I too have a RPi2B v1.1 dated 2014 with an official display. This runs Raspbian Jessie perfectly, but IoT Core Build 10586 fails to drive the LCD, but drives the HDMI OK.

spass2000
Posts: 1
Joined: Fri Jan 08, 2016 6:26 am

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Fri Jan 08, 2016 1:46 pm

Also not working on the Raspberry Pi2 Model B V1.1 2014 Version. So we have to wait and hope that microsoft will give us an update... (working fine on Jessie)

ricl
Posts: 657
Joined: Wed Aug 26, 2015 11:55 am

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Fri Jan 08, 2016 2:22 pm

"So we have to wait and hope that microsoft will give us an update... (working fine on Jessie)"

We will have to hope that the RPF hardware changes that require a patch to Linux has made it as an alpha, beta, release from that team to MS.

As it looks like MS were not prepared for the change, from the outside it looks as though that normal release schedule for partners was not followed. Any one in the know at RPF know how this all happened?
ricl : F/gamma = ma : Law ii(a) : https://climatedatablog.wordpress.com/2016/01/02/an-energy-challenge-2016/ #AnEnergyChallenge2016

adrianlovell
Posts: 3
Joined: Sun Jan 10, 2016 9:18 pm

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Sun Jan 10, 2016 9:26 pm

I'm seeing the same as above. Reported it on the MSFT forum:
I have a v1.1 Raspberry Pi Display and it doesn't appear to work with Windows 10 IoT v10.0.10586 and a Raspberry Pi 2 Model B v1.1. If I re-flash the SD card to the latest Raspbian (21 Nov 2015) everything works fine.

ricl
Posts: 657
Joined: Wed Aug 26, 2015 11:55 am

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Sun Jan 10, 2016 9:41 pm

MS are aware of this if you follow the links. I cross posted this finding to MS, got confirmation and work is underway
ricl : F/gamma = ma : Law ii(a) : https://climatedatablog.wordpress.com/2016/01/02/an-energy-challenge-2016/ #AnEnergyChallenge2016

SwampieUK
Posts: 6
Joined: Tue Jun 02, 2015 2:35 pm

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Thu Feb 11, 2016 1:35 pm

I saw an unofficial reply at https://social.msdn.microsoft.com/Forum ... f=required - however, it only says:
"This is not an official confirmation, but I can tell you that I have a display with a v1.0, 2014 version of the PCB and it DOES work with my Rpi 2 running Windows 10 IoT Core build 10.0.10586. That is the display works, but does not support the touch functionality.

I have a colleague that has a v1.1, 2015 version of the PCB and it DOES NOT work for him.

Again, this is isn't scientific or official confirmation, but at least mirrors what the site says."
That said, it's only unofficial confirmation someone reproduced it - I haven't seen anything explicit from MS to say that they're actually working on this problem, or any kind of time scales. Has anyone seen anything elsewhere to confirm they're actually doing something about it?

adrianlovell
Posts: 3
Joined: Sun Jan 10, 2016 9:18 pm

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Thu Feb 11, 2016 2:02 pm

SwampieUK wrote:That said, it's only unofficial confirmation someone reproduced it - I haven't seen anything explicit from MS to say that they're actually working on this problem, or any kind of time scales. Has anyone seen anything elsewhere to confirm they're actually doing something about it?
Nope... :cry:

adrianlovell
Posts: 3
Joined: Sun Jan 10, 2016 9:18 pm

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Fri Feb 19, 2016 5:20 pm

Update:

I just installed the latest Insider Preview build (10.0.14262.1000), and v1.1 of the touchscreen works (including the touch capability).

craigdudley
Posts: 11
Joined: Thu Oct 15, 2015 6:32 pm

Re: Display works on Raspbian Jessie, but not on W10 IOT?

Sun Feb 21, 2016 10:50 pm

Can confirm touch does indeed work on latest preview release.

Trying to figure out how to make it work rotated now though..

Return to “Windows 10 for IoT”