Page 1 of 1

DigitalSignage app is terribly slow

Posted: Thu Aug 13, 2015 2:30 pm
by jpvb
Hi,

I've compiled and run Microsoft' DigitalSignage sample application on my Raspberry Pi2 and it runs terribly slow.

When I click on the slideshow button, I see the horses video at the rate of 1 frame by 2 seconds...

Is someone has been able to run this app correctly?

Thanks for your help!

Re: DigitalSignage app is terribly slow

Posted: Tue Aug 18, 2015 10:19 pm
by DevLoop
I have same problem, tomorrow I'd like resize video to check it is too heavy for raspberry. I don't think it is a license problem because video in sample code is wmv format and not MP4. In MP4 case, video is executed by cpu and not by Gpu which is slower. To improve and play video using gpu mpeg license is required in Linux, but is it required for win?!

Re: DigitalSignage app is terribly slow

Posted: Wed Aug 19, 2015 3:02 am
by haroldpulcher
The GPU is currently not active on Windows 10 core IoT.

They are aware of graphical performance issues and they say they are working on them.

Re: DigitalSignage app is terribly slow

Posted: Wed Aug 19, 2015 3:57 pm
by UndergroundFun
"Windows 10 IoT Core is still being ported to the Raspberry PI. The video driver for the Raspberry PI is still under development, and its performance has not yet been optimized. Animated user elements, such as XAML based drop down menus in particular, may display poorly."

http://ms-iot.github.io/content/en-US/w ... eNotes.htm

Re: DigitalSignage app is terribly slow

Posted: Sun Aug 23, 2015 2:24 pm
by JSingleton
I did some very basic benchmarking on Win 10 IoT and it seems a little slower than Raspbian. If the video isn't hardware accelerated it's not going to have great playback performance.
The full write-up is here: https://unop.uk/dev/windows-10-iot-core ... mpressions

I've had good results with Screenly for digital signage. I made a fork that adds basic authentication to the admin interface. Other than that I have no affiliation, I just like it.
More info here: https://unop.uk/dev/adding-basic-authen ... reenly-ose

Re: DigitalSignage app is terribly slow

Posted: Thu Sep 03, 2015 6:16 pm
by JSingleton
I've had even less luck with the Digital Signage sample app. It builds and deploys but the video doesn't work.

Re: DigitalSignage app is terribly slow

Posted: Fri Sep 04, 2015 7:42 am
by beta-tester
that is pretty normal.
everything that would profit of hardware acceleration does currently not work, because it is not implemented or is implemented in pure raw software only with all its disadvantages.

and there are no information if or when hardware-acceleration will come later. :x :evil: