aherbjornsen
Posts: 5
Joined: Tue Aug 09, 2016 9:35 am

Re: Sense-Hat Problems

Wed Mar 01, 2017 7:08 pm

Thanks again.

When I remove that line, the things behave exactly like the other python examples. The RGB display just flashes random dots of random color.

Tested with the snake.c example again, and it still works fine. So assume that the hardware is ok.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 4607
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Sense-Hat Problems

Wed Mar 01, 2017 7:13 pm

alphanumeric wrote:Both of my Pi's/sense hats are running Jessie Pixel as far as I know. On one I did a sudo apt-get update, sudo apt-get upgrade and some things started acting weird. My sense hat code still worked. I just had other issues. It would boot to the Desktop GUI even though I set it to command line for one thng. That prompted me to leave my other Pi as is. One is an A+ (256 meg of RAM) and a newer A+ (512meg RAM).
Sorry, that doesn't quite answer the question fully.
ShiftPlusOne wrote:What does 'uname -a' say?

alphanumeric
Posts: 1196
Joined: Tue Jan 19, 2016 2:17 pm
Location: Sydney, Nova Scotia, Canada

Re: Sense-Hat Problems

Wed Mar 01, 2017 7:15 pm

ShiftPlusOne wrote:
alphanumeric wrote:Both of my Pi's/sense hats are running Jessie Pixel as far as I know. On one I did a sudo apt-get update, sudo apt-get upgrade and some things started acting weird. My sense hat code still worked. I just had other issues. It would boot to the Desktop GUI even though I set it to command line for one thng. That prompted me to leave my other Pi as is. One is an A+ (256 meg of RAM) and a newer A+ (512meg RAM).
Sorry, that doesn't quite answer the question fully.
ShiftPlusOne wrote:What does 'uname -a' say?
I'll have to connect a monitor etc and have a look. They both run headless and I don't think I setup remote access this time around, got lazy. :oops:

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 4607
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Sense-Hat Problems

Wed Mar 01, 2017 7:27 pm

Does the problem go away if you put 'force_turbo=1' into /boot/config.txt and reboot?

alphanumeric
Posts: 1196
Joined: Tue Jan 19, 2016 2:17 pm
Location: Sydney, Nova Scotia, Canada

Re: Sense-Hat Problems

Wed Mar 01, 2017 7:27 pm

On the Pi I did the update upgrade on it says this, 4.4.38+ #938 Thur Dec 15.......armv61 GNU Linux. Things got kind of broken after but my python file still ran OK afterward. I hope I'm not confusing things as far as the OP goes.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 4607
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Sense-Hat Problems

Wed Mar 01, 2017 7:32 pm

alphanumeric wrote:On the Pi I did the update upgrade on it says this, 4.4.38+ #938 Thur Dec 15.......armv61 GNU Linux. Things got kind of broken after but my python file still ran OK afterward. I hope I'm not confusing things as far as the OP goes.
Ah yup, got a little confused given your similar display names. Yours is working as expected, right?

alphanumeric
Posts: 1196
Joined: Tue Jan 19, 2016 2:17 pm
Location: Sydney, Nova Scotia, Canada

Re: Sense-Hat Problems

Wed Mar 01, 2017 7:38 pm

ShiftPlusOne wrote:
alphanumeric wrote:On the Pi I did the update upgrade on it says this, 4.4.38+ #938 Thur Dec 15.......armv61 GNU Linux. Things got kind of broken after but my python file still ran OK afterward. I hope I'm not confusing things as far as the OP goes.
Ah yup, got a little confused given your similar display names. Yours is working as expected, right?
Yes, its working as expected, that's why I linked to code I knew worked. For me anyway it works. I leave one Pi running that code 24/7 headless. It's my weather clock.

I thought the two similar usernames might be confusing things and figured I'd mention it just in case. So I take it I'm still on kernel 4.4?

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 4607
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Sense-Hat Problems

Wed Mar 01, 2017 7:40 pm

alphanumeric wrote:
ShiftPlusOne wrote:So I take it I'm still on kernel 4.4?
Yes, sounds like it. If the issue is what I think it is then your code will stop working if you run rpi-update and reboot.

aherbjornsen
Posts: 5
Joined: Tue Aug 09, 2016 9:35 am

Re: Sense-Hat Problems

Wed Mar 01, 2017 7:59 pm

ShiftPlusOne wrote: Did you run rpi-update? I was checking this and mine was working fine until I updated the kernel to 4.9. What does 'uname -a' say?
Yes, I was on kernel 4.9 and that was the problem. Reinstalled Jessie and now things are working as expected.

Thanks a lot.

alphanumeric
Posts: 1196
Joined: Tue Jan 19, 2016 2:17 pm
Location: Sydney, Nova Scotia, Canada

Re: Sense-Hat Problems

Wed Mar 01, 2017 8:03 pm

Ah that's good news, I was just about to do a rpi-update as a test but won't bother now.

User avatar
ntn
Posts: 1
Joined: Sun Mar 12, 2017 1:59 pm
Location: Orava

Re: Sense-Hat Problems

Sun Mar 12, 2017 2:57 pm

Just updated Pi3B with rpi-update and the HAT LEDs have gone wild. Not a single py script I did is working. They did worked before the update. Not even a sense.clear() from python shell is working...

Code: Select all

uname -a
Linux malina 4.9.13-v7+ #974 SMP Wed Mar 1 20:09:48 GMT 2017 armv7l GNU/Linux
There is no warning and no error message. The HAT LEDs just don't work as expected. Gonna do some more tests and maybe go back to the previous version.

Edit: the sensors are working fine, looks like its just the led matrix that goes crazy.
[ntn]
Pi 3B & HAT

User avatar
jhansx
Posts: 18
Joined: Tue Apr 04, 2017 4:38 pm
Location: Green River, Wyoming

Re: Sense-Hat Problems

Sat Apr 15, 2017 2:07 am

WTF!!!!
Just got my sense hat hooled up, followed all updates and did RPI update (now kernal 4.9.whatever)
Still get:
OSError: Cannot detect RPi-Sense FB device
on everything I try to run.
Running NOOBS, did update and upgrade.
HELPHELPHELP
I'm getting ready to maker a pitch to NASA to do "AMERICAN PI"
It would kinda help if the thing worked.
Jeff KG7TXI

bensimmo
Posts: 1739
Joined: Sun Dec 28, 2014 3:02 pm
Location: East Yorkshire

Re: Sense-Hat Problems

Sat Apr 15, 2017 7:55 am

jhansx wrote:WTF!!!!
Just got my sense hat hooled up, followed all updates and did RPI update (now kernal 4.9.whatever)
Still get:
OSError: Cannot detect RPi-Sense FB device
on everything I try to run.
Running NOOBS, did update and upgrade.
HELPHELPHELP
I'm getting ready to maker a pitch to NASA to do "AMERICAN PI"
It would kinda help if the thing worked.
Jeff KG7TXI
Don't use a testing branch with Rpi-Update.
Use the normal everyday setup.

User avatar
DougieLawson
Posts: 29736
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: Sense-Hat Problems

Sat Apr 15, 2017 8:00 am

jhansx wrote: Just got my sense hat hooled up, followed all updates and did RPI update (now kernal 4.9.whatever)
sudo apt-get update; sudo apt-get install --reinstall raspberrypi-kernel raspberrypi-bootloader

Anyone who doesn't understand what rpi-update does, how to recovery from it when it breaks and how to report rpi-update errors should NOT EVER RUN rpi-update.
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

Since 2012: 1B*5, 2B*2, B+, A+, Zero*2, 3B*3

Please post ALL technical questions on the forum. Do not send private messages.

User avatar
jhansx
Posts: 18
Joined: Tue Apr 04, 2017 4:38 pm
Location: Green River, Wyoming

Re: Sense-Hat Problems

Sat Apr 15, 2017 3:14 pm

Bes, I am just regular old Pi B+ Debian Jessie.

Dougie, the stinging rebuke aside, thank you! You give away hard earned knowledge every day and as far as I can tell all day and no one ever stops to really thank you or acknowledge your help. It is little wonder you are fed up with newby Colonists who can't even spellcheck a post.
You are a God of this world, I thank you!
Would you consider helping me as tech support with American PI? I am trying to make a US equivalent of Astro Pi. I got an idea and obviously no talent. Got some resources and I think that this might pay off in the end.
What say you sir, a bit of Brexit? That is if consorting with Colonists won't get you outed.
Thanks again, implementing your solution as I type.
KG7TXI
Jeff 3073500199

User avatar
jhansx
Posts: 18
Joined: Tue Apr 04, 2017 4:38 pm
Location: Green River, Wyoming

Re: Sense-Hat Problems

Sat Apr 15, 2017 4:01 pm

Traceback (most recent call last):
File "colour_cycle.py", line 5, in <module>
sense = SenseHat()
File "/usr/lib/python2.7/dist-packages/sense_hat/sense_hat.py", line 39, in __init__
raise OSError('Cannot detect %s device' % self.SENSE_HAT_FB_NAME)
OSError: Cannot detect RPi-Sense FB device

AFTER running Dougies suggested RPI fix

Any suggestions???
Jeff

bensimmo
Posts: 1739
Joined: Sun Dec 28, 2014 3:02 pm
Location: East Yorkshire

Re: Sense-Hat Problems

Sat Apr 15, 2017 4:04 pm

Sorry jhansx, rpi-update puts you on to a testing branch.

If there are still problems with the sense-hat then they do need fixing with the new 4.9 kernel before they release it.
4.4 being the current one today.

Curious, why did you run rpi-update, Dougie's suggest on another thread was a good idea, rpi-update should not be in the default Raspian install.

bensimmo
Posts: 1739
Joined: Sun Dec 28, 2014 3:02 pm
Location: East Yorkshire

Re: Sense-Hat Problems

Sat Apr 15, 2017 4:08 pm

jhansx wrote:Traceback (most recent call last):
File "colour_cycle.py", line 5, in <module>
sense = SenseHat()
File "/usr/lib/python2.7/dist-packages/sense_hat/sense_hat.py", line 39, in __init__
raise OSError('Cannot detect %s device' % self.SENSE_HAT_FB_NAME)
OSError: Cannot detect RPi-Sense FB device

AFTER running Dougies suggested RPI fix

Any suggestions???
Jeff
If you can, i would just start from a fresh Raspian image download, it may be quicker and it's a known good.

Have you rebooted.
Have you ever had it on backwards?

The SenseHat is really designed around Python3.

User avatar
jhansx
Posts: 18
Joined: Tue Apr 04, 2017 4:38 pm
Location: Green River, Wyoming

Re: Sense-Hat Problems

Sat Apr 15, 2017 4:12 pm

root@raspberrypi:~/examples/python-sense-hat# python colour_cycle.py
Traceback (most recent call last):
File "colour_cycle.py", line 5, in <module>
sense = SenseHat()
File "/usr/lib/python2.7/dist-packages/sense_hat/sense_hat.py", line 39, in __init__
raise OSError('Cannot detect %s device' % self.SENSE_HAT_FB_NAME)

after re-enabling the:
#Line to enable SenseHat, I hope, which is apparently not needed in B+

dtoverlay=rpi-sense

Help Mr Wizard... Drizzle Drazzel Drozzel Drone, Time for Zis one to come home....
Betcha don't remember that one!
Jeff

User avatar
jhansx
Posts: 18
Joined: Tue Apr 04, 2017 4:38 pm
Location: Green River, Wyoming

Re: Sense-Hat Problems

Sat Apr 15, 2017 4:14 pm

Will try a fresh install.
No I never got it on backwards.
Thanks for the help.
Jeff

bensimmo
Posts: 1739
Joined: Sun Dec 28, 2014 3:02 pm
Location: East Yorkshire

Re: Sense-Hat Problems

Sat Apr 15, 2017 4:23 pm

As for an American Astronomy Pi, have a chat with the people who have help get the UK AstroPi and the now ESA European AstroPi this year using the two devices up there.
They probably can help better than most.
Start a topic on it.

User avatar
jhansx
Posts: 18
Joined: Tue Apr 04, 2017 4:38 pm
Location: Green River, Wyoming

Re: Sense-Hat Problems

Sat Apr 15, 2017 8:45 pm

Well full fresh install, removed and reinstalled the header pins. Device not recognized, same error.
Gotta be hardware. Gonna try to return it and try again. REALLY worries me though.
NASA doesn't like failure.

User avatar
jhansx
Posts: 18
Joined: Tue Apr 04, 2017 4:38 pm
Location: Green River, Wyoming

Re: Sense-Hat Problems

Sat Apr 15, 2017 10:03 pm

finally, had a bent pin on the header. YEAH!
Remember the first question IBM help desk used to ask was do you have a computer, the second was is it plugged in, the third was is it turned on?

User avatar
DougieLawson
Posts: 29736
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: Sense-Hat Problems

Sat Apr 15, 2017 10:37 pm

jhansx wrote:Remember the first question IBM help desk used to ask was do you have a computer, the second was is it plugged in, the third was is it turned on?
That's, precisely, the reason why I never called the helpdesk in my twenty years working for IBM.

So you've learned a few things
1. Don't run rpi-update (except when told to by an expert)
2. Check the hardware, check it again
3. Don't shout for help until you've completed #1 & #2.
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

Since 2012: 1B*5, 2B*2, B+, A+, Zero*2, 3B*3

Please post ALL technical questions on the forum. Do not send private messages.

User avatar
jhansx
Posts: 18
Joined: Tue Apr 04, 2017 4:38 pm
Location: Green River, Wyoming

Re: Sense-Hat Problems

Sun Apr 16, 2017 8:54 pm

i thought Dougie was an expert. lesson learned.
thank you all
kg7txi
jeff

Return to “Astro Pi”

Who is online

Users browsing this forum: No registered users and 1 guest