NBizzell
Raspberry Pi Certified Educator
Raspberry Pi Certified Educator
Posts: 26
Joined: Mon Jun 09, 2014 9:55 am

Problems with OpenCV

Thu Feb 01, 2018 11:42 am

I am trying to run the full test of the code and had some problems.

I started with a clean install to build up and get a list of the install commands for the entry form.

Unfortunately now I can't get OpenCV to install.

I have been using the instructions from the email 2 week warning:

Code: Select all

sudo apt-get update
sudo apt-get install libatlas-base-dev –y
sudo pip3 install opencv-python -i https://www.piwheels.hostedpi.com/simple
And get an error saying no such package can be found.

Is this my school firewall blocking the page or is there a different issue with what I am doing.

Really can't remember how I got it working the first time.

User avatar
Davespice
Forum Moderator
Forum Moderator
Posts: 1662
Joined: Fri Oct 14, 2011 8:06 pm
Location: The Netherlands
Contact: Twitter

Re: Problems with OpenCV

Thu Feb 01, 2018 3:44 pm

Hi there, can you load this URL in the browser?
https://www.piwheels.hostedpi.com/simple/opencv-python/

NBizzell
Raspberry Pi Certified Educator
Raspberry Pi Certified Educator
Posts: 26
Joined: Mon Jun 09, 2014 9:55 am

Re: Problems with OpenCV

Thu Feb 01, 2018 10:34 pm

Thank you Dave,

I got home and it ran first time with no issues.

The URL - https://www.piwheels.hostedpi.com/simple/ was blocked when I tried on a PC also at school (Smoothwall warning message). So this looks to have been the problem.

User avatar
Davespice
Forum Moderator
Forum Moderator
Posts: 1662
Joined: Fri Oct 14, 2011 8:06 pm
Location: The Netherlands
Contact: Twitter

Re: Problems with OpenCV

Fri Feb 02, 2018 11:11 am

Okay no worries, glad you managed to get it installed.

windy54
Posts: 75
Joined: Sat Dec 29, 2012 3:37 pm

Re: Problems with OpenCV

Tue Jul 10, 2018 10:59 am

Hi,

I have just tried this on a PI 0 using latest stretch release.

The command sudo pip3 install python-opencv ......

fails with an error message
"could not find a version that satisfies the requirement python-opencv ( from versions)
no matching distribution found for python-opencv"

Any ideas what the problem is ?

Also, I know I have read somewhere about piwheels and opencv but can't find the article, not sure if it was in pi-weekly or magpi.
If you know where the article was published I would be grateful for a link, just to put my mind at rest! I have gone though some of the back issues of pi weekly and tried googling but have not found a link.

cheers

Steve

Return to “Astro Pi”

Who is online

Users browsing this forum: No registered users and 1 guest