Posts: 7
Joined: Wed May 04, 2016 10:36 am

Arduino GPRS SHIELD Geeetech with Raspberry PI

Mon May 09, 2016 5:37 pm


I have a geeetech GPRS Shield for Arduino and I would like to use it with my new Raspberry PI 3.

the spec of my shield are at http://www.geeetech.com/wiki/index.php/ ... PRS_Shield

Some questions:

1-Is it possibile?
2-Can I use the pwr 5.5 and GND from my raspberry? or external?

Any help would be kind, I have the terror to burn something out!

Posts: 13
Joined: Sat May 23, 2015 8:56 am

Re: Arduino GPRS SHIELD Geeetech with Raspberry PI

Tue Jun 14, 2016 9:10 am


Yes it is possible to use the GPRS shiels with the Pi. However, you need a level converter for the serial port signals and optional power up pin (D9 on the shield). The pins on the Pi are 3.3V and the pins on the shield are 5V. You can supply power to the level converter from the GPIO connector. Something like this works fine https://www.sparkfun.com/products/12009

And it would be best to provide 5V to the shield directly. In some cases the shield can use pretty much power (>150mA).

All commands are AT modem style and are very well documented. So that should be no problem. I have a tested a SIM900A module (http://www.ebay.com/itm/New-SIM900A-Ext ... 1209981501) and worked fine.


Posts: 81
Joined: Fri May 10, 2013 4:52 pm

Re: Arduino GPRS SHIELD Geeetech with Raspberry PI

Wed Apr 26, 2017 2:37 pm

I have one of these boards for my arduino also and I'm in the process of trying to figure out how to connect it to the pi. On mine I seemed to be getting some kind of 'noise' if I tried connecting an FTDI 5v directly to the tx/rx holes on the arduino pin-out with the hardware tx/rx jumpers configured if I was using 115200 or any other high baud rates. I was able to get clean data at 19200 which is the speed they used in their 'passthrough' script and also tested that script through the arduino itself.

I noticed, however, that they have a 'uart' connector that appears to go directly to the 2v8 logic pins on the sim900 itself - or claims to. I wasn't able to get any kind of response out of it testing with a 3.3v ftdi. I noted they had a 'third' jumper configuration image on their wiki that was labelled 'uart' so I tried moving one jumper to the center two pins (rotated) and didn't have any luck there either. I sent an email to their tech support asking how to get the uart to work but I'll have to wait for a response. If anyone has ever used the uart on these things, I'd appreciate knowing anything you found out or did to make it work.

If I learn anything new, I'll try to find my way back here even though it's an old thread to post anything I find.


Return to “HATs and other add-ons”