XBMC compilation error: vchost_config.h: No such file or dir


10 posts
by braghettos » Sun Feb 17, 2013 6:41 pm
Hi everyone! I'm trying to compile xbmc on my wheezy and during compilation I get this error:

CPP xbmc/cores/dvdplayer/DVDPlayerVideo.o
In file included from /usr/include/bcm_host.h:50:0,
from /home/pi/xbmc-rbp/xbmc/linux/DllBCM.h:34,
from /home/pi/xbmc-rbp/xbmc/windowing/egl/WinEGLPlatformRaspberryPI.h:31,
from /home/pi/xbmc-rbp/xbmc/windowing/egl/WinEGLPlatform.h:28,
from /home/pi/xbmc-rbp/xbmc/windowing/egl/WinSystemGLES.h:29,
from /home/pi/xbmc-rbp/xbmc/windowing/WindowingFactory.h:40,
from DVDPlayerVideo.cpp:24:
/usr/include/interface/vmcs_host/vcgencmd.h:33:27: fatal error: vchost_config.h: No such file or directory

Can anyone please tell me what should I do in order to continue to compile?

Thank you so much in advance,

Diego
Posts: 1
Joined: Sun Feb 17, 2013 6:37 pm
by kaze » Sun Feb 17, 2013 9:05 pm
Hi

I have the same problem. I edited the file and added the relative path. Right now it is compiling, I don't know whether it works yet.

I tell you something else in a few hours ;)

Regards,
kaze
Posts: 4
Joined: Fri Feb 08, 2013 11:50 pm
by kaze » Mon Feb 18, 2013 6:20 am
Hi

Go to the line 33 in the file /usr/include/interface/vmcs_host/vcgencmd.h and replace that line with this:

Code: Select all
#include "interface/vmcs_host/linux/vchost_config.h"


This solved my problem compiling xmbc. I hope this helps you.

Regards
kaze
Posts: 4
Joined: Fri Feb 08, 2013 11:50 pm
by hereticmaggot » Mon Feb 18, 2013 8:32 pm
Hello, I was able to get past the compilation error but there is a problem playing video.
When I run xbmc, the GUI displays correctly but when trying to play a video, the image stays black...
Does someone have an idea?
Posts: 2
Joined: Mon Feb 18, 2013 8:27 pm
by kaze » Tue Feb 19, 2013 8:38 am
I have a similar problem. It tries to reproduce videos, but I just see the console. If I move the mouse then I see the interface in the bottom.
Also, I have a message in the console prompt saying something about video format.
Posts: 4
Joined: Fri Feb 08, 2013 11:50 pm
by hereticmaggot » Tue Feb 19, 2013 7:06 pm
Yes, just the same problem. Anyone? I tried installing a precompiled package of XBMC frodo rc2, it plays video but with an awful lag... What is the problem?
Posts: 2
Joined: Mon Feb 18, 2013 8:27 pm
by bboyandru » Wed Mar 06, 2013 12:50 pm
I also had this problem with the old Raspbian from 2012. With the latest one video is playing nice.
You can use my tutorial to build XBMC.
http://www.engineering-diy.blogspot.ro/ ... ce-in.html
I have Raspberry PI model B and it is working quite well with Frodo final release and 1080p videos from Youtube.
A video can be seen here: https://www.youtube.com/watch?v=WbxRf8BejnY

Andrei
http://www.engineering-diy.blogspot.com
Posts: 24
Joined: Thu Feb 14, 2013 7:34 am
by fabrou » Sun Mar 17, 2013 10:02 am
Hello

Same problem for me. There are two possible solutions :

The first one consists in modifying the vcgencmd.h file :

sudo sed -i 's/#include "vchost_config.h"/#include "linux\/vchost_config.h"/' /usr/include/interface/vmcs_host/vcgencmd.h


The second one consists in adding a symbolic link to create the missing file : linux/vchost_config.h
Posts: 2
Joined: Sun Feb 03, 2013 6:02 am
by robindegen » Thu Apr 18, 2013 12:49 pm
You should NEVER modify system headers. Copying, moving or symlinking is quite bad too. Modify the makefile of whatever you're building. Under cflags or something similar, just add:

Code: Select all
-I /opt/vc/include/interface/vmcs_host/linux
Posts: 1
Joined: Thu Apr 18, 2013 12:48 pm
by ypl » Thu Nov 28, 2013 8:32 pm
I experienced the same problem and changing the header file as stated by fabrou seems to work. If you look at the header files there seems to be a mistake. The referred to header vchost_config.h in the file vcgencmd.h is actually located in a subdirectory "linux".

If you backup the file vcgencmd.h and then change the one line in /usr/include/interface/vmcs_host/vcgencmd.h on line 33 from:

#include "vchost_config.h"

to:

#include "linux/vchost_config.h"

Run the make again and it will work.

If your are concerned about integrity, then do your build and then return the backed up header file.

I tried the include option but could not edit the makefile to make it work.

Good Luck!
--
Year 2200: 2 aliens stand on a cliff overlooking a diverse landscape. One bends down, to pick up a fossilized skull, the second on seeing the artifact responds, "A promising lot, if only they were able to co-operate and to stop eating."
Posts: 1
Joined: Thu Nov 28, 2013 7:49 pm