Go to advanced search

by antiriad
Tue Aug 21, 2018 10:42 pm
Forum: Troubleshooting
Topic: Raspbian stretch No OpenGL driver
Replies: 21
Views: 16987

Re: Raspbian stretch No OpenGL driver

Hello,
aside from the fact that PIXEL Desktop is now Raspbian Desktop, it would be useful to know how to activate OpenGL acceleration on Raspbian Stretch LITE with manually-installed UI.

Thanks
by antiriad
Sat Aug 18, 2018 5:20 pm
Forum: General discussion
Topic: Raspbian Stretch LITE SDL 1.2 / SDL 2 question
Replies: 0
Views: 290

Raspbian Stretch LITE SDL 1.2 / SDL 2 question

Hello! I'm a Raspbian Stretch LITE (no desktop) user. Despite numerous research, still it's not clear to me if/how can I get SDL 1.2 / SDL 2 hardware acceleration on CLI: a) which graphic driver option (full kms; fake kms; legacy) should I enable in raspi-config to allow SDL 1.2 and/or SDL 2.x hardw...
by antiriad
Wed Mar 21, 2018 1:43 pm
Forum: Gaming
Topic: Raspbian Stretch LITE and SDL 2.0.X?
Replies: 0
Views: 662

Raspbian Stretch LITE and SDL 2.0.X?

Hello, recently there is so much talk about SDL 2.0.X on Raspberry Pi, since these libraries are a requirement of many interesting projects (last but not least the official release of SCUMMVM). However, I still have some doubts as to what the current and "official" state is: 1. Which version of SDL ...
by antiriad
Tue Mar 06, 2018 8:11 am
Forum: Advanced users
Topic: STICKY: HOWTO: Create Custom HDMI modes
Replies: 214
Views: 368901

Re: STICKY: HOWTO: Create Custom HDMI modes

Hello,
not really being a "video modes" guru, I'd like to ask for a little help.
What would be the right syntax to get a 320 x 200 VGA "Mode 13h" video mode with hdmi_timings?

Thank you very much
by antiriad
Sat Dec 02, 2017 1:41 pm
Forum: Gaming
Topic: Megadrive emulator: Picodrive v1.91 with OpenGLES
Replies: 18
Views: 5224

Re: Megadrive emulator: Picodrive v1.91 with OpenGLES

Even in black screen, pressing UP and ENTER I was able to quit, so this is the verbose: Picodrive for Raspberry Pi 0.1 by Chips plat_sdl: using 1920x1080 as fullscreen resolution plat_sdl: overlay: fmt 59565955, planes: 1, pitch: 1280, hw: 0 warning: video overlay is not hardware accelerated, not go...
by antiriad
Sat Dec 02, 2017 1:19 pm
Forum: Gaming
Topic: Megadrive emulator: Picodrive v1.91 with OpenGLES
Replies: 18
Views: 5224

Re: Megadrive emulator: Picodrive v1.91 with OpenGLES

Thank you very much for your feedback.

Unfortunately I get a black full screen running the binary (both versions) on my RPi3 with Gert's VGA 666... any hint? :?
by antiriad
Fri Dec 01, 2017 6:37 am
Forum: Gaming
Topic: Megadrive emulator: Picodrive v1.91 with OpenGLES
Replies: 18
Views: 5224

Re: Megadrive emulator: Picodrive v1.91 with OpenGLES

Hi Chips, thank you very much for your great work! OK, today Retroarch is a "must", but I find that stand-alone emulators are still useful for RPi. So maybe would you make a small update on Notaz/libretro versions? ;) It's possibile to build it on RPi 3 (openGLES) for better optimization? (don't kno...
by antiriad
Mon Nov 06, 2017 9:02 am
Forum: Advanced users
Topic: Reduce customized Raspbian image size for sharing
Replies: 14
Views: 5317

Re: Reduce customized Raspbian image size for sharing

Hello, I have abandoned the idea of expanding the boot partition (for transferring data I set up a shared Samba folder), but I'm stil trying to make my Raspbian (not NOOBS) customized image as light as possible (would be great to keep below 1GB). I successfully built this Raspbian Shrink script for ...
by antiriad
Sun Oct 22, 2017 12:20 pm
Forum: Advanced users
Topic: Reduce customized Raspbian image size for sharing
Replies: 14
Views: 5317

Re: Reduce customized Raspbian image size for sharing

Thank you very much for your feedback.
Going a bit further: is technically possibile to make in Raspbian another (third) partition like "boot", readable both in Raspbian and Windows/Mac?
And maybe to make users to expand it with a custom script?
Thanks
by antiriad
Sun Oct 22, 2017 11:09 am
Forum: Advanced users
Topic: Reduce customized Raspbian image size for sharing
Replies: 14
Views: 5317

Re: Reduce customized Raspbian image size for sharing

Hello and thank you for your answer.

Actually I make a SD-card image with Win32DiskImager (I'm on Windows, but I can eventually use OSX or Ubuntu).

So should I use gParted to open the ISO file?
by antiriad
Sun Oct 22, 2017 7:24 am
Forum: Advanced users
Topic: Reduce customized Raspbian image size for sharing
Replies: 14
Views: 5317

Reduce customized Raspbian image size for sharing

Hello,
I'd like to share my customized Raspbian as a downloadable ISO for a project.

What would be a good (and easy?) approach to get an ISO smaller than the SD card size, and to allow users to resize it easily afterwards?

Thank you very much.
by antiriad
Mon Apr 03, 2017 1:30 pm
Forum: Python
Topic: Is still possible to install Python 2.7 on RPi?
Replies: 8
Views: 12980

Re: Is still possible to install Python 2.7 on RPi?

As it says "In early 2015, Mystic introduced a stable release for Raspberry Pi with 1.10. Mystic now provides the only integrated BBS and echomail solution for the Raspberry Pi (ARM Linux) and OS-X (Macintosh) platforms." I would assume yes. That's right, but only Python 2.7 is supported (not 3). T...
by antiriad
Mon Apr 03, 2017 1:06 pm
Forum: Python
Topic: Is still possible to install Python 2.7 on RPi?
Replies: 8
Views: 12980

Re: Is still possible to install Python 2.7 on RPi?

gordon77 wrote:
antiriad wrote:Thank you very much for your feedback.
So it's the 2.7 version?
You can use 2.7.9 or 3.4.2, use IDLE or IDLE3
Thank you. I suppose that Mystic will check for 2.7 engine, so it's the same? :)
by antiriad
Mon Apr 03, 2017 12:30 pm
Forum: Python
Topic: Is still possible to install Python 2.7 on RPi?
Replies: 8
Views: 12980

Re: Is still possible to install Python 2.7 on RPi?

Thank you very much for your feedback.
So it's the 2.7 version?
by antiriad
Mon Apr 03, 2017 12:13 pm
Forum: Python
Topic: Is still possible to install Python 2.7 on RPi?
Replies: 8
Views: 12980

Is still possible to install Python 2.7 on RPi?

Hi,
since Mystic BBS only supports Python 2.7, I'd like to know if it's still possible to easily install Python ver. 2.7 on Raspberry Pi (1B).
Yes, I'm a noob. :lol:
by antiriad
Mon Apr 03, 2017 12:11 pm
Forum: Gaming
Topic: Angband (or mAngband) in cli?
Replies: 2
Views: 799

Re: Angband (or mAngband) in cli?

topguy wrote: Or maybe its as easy as "./configure --disable-X11".
Hi and thank you very much for your kind feedback.
The right parameter is with lowercase x, so:
--disable-x11
Thanks again ;)
by antiriad
Mon Apr 03, 2017 12:06 pm
Forum: Gaming
Topic: gzdoom on raspberry pi
Replies: 69
Views: 13241

Re: gzdoom on raspberry pi

Hi, I'm happy to join this conversation because I'm still searching for the "definitive" source port of (not-vanilla) DOOM on Raspberry Pi. Currently the scene, IMHO, is a bit confused on RPi, with A LOT of "untapped potential": in Raspbian repos there is PrBOOM that seems GLES accelerated but old a...
by antiriad
Fri Mar 31, 2017 5:18 am
Forum: Gaming
Topic: Angband (or mAngband) in cli?
Replies: 2
Views: 799

Angband (or mAngband) in cli?

Hi,
Angband is available in Raspbian repository, but it has a lot of X11 dependencies.
Since I'd like to play it in pure terminal, there is a way to manually install only the main package and other packages required to play it on cli?
Thanks
by antiriad
Wed Mar 15, 2017 6:28 am
Forum: Graphics programming
Topic: Quake 1 Port, Optimization Questions
Replies: 34
Views: 25659

Re: Quake 1 Port, Optimization Questions

Well, I've compiled Qurp on RPi and... what can I say? This port is awesome! Performances are outstanding! It only needs a couple of refinements: - Qurp does not save settings because it does not create and write on a config.cfg (I had to manually create an autoexec.cfg in the ID1 folder) - (probabl...
by antiriad
Tue Mar 14, 2017 1:21 pm
Forum: Graphics programming
Topic: Quake 1 Port, Optimization Questions
Replies: 34
Views: 25659

Re: Quake 1 Port, Optimization Questions

Hi, I was looking for a source port of Quake "easy" to install on Raspberry Pi, and now I have discovered this gem! I saw this video and... WHOOHOOOO!!! :D Qurp looks fantastic, can't wait to try it on RPi3 tonight! The project is still in development? There are hopes for the future support of some ...
by antiriad
Tue Mar 14, 2017 12:44 pm
Forum: Gaming
Topic: Quakespasm and DOOM Retro on Rpi3 (help)
Replies: 4
Views: 1491

Re: Quakespasm and DOOM Retro on Rpi3 (help)

Unfortunately I get the infamous black screen at boot after activating the experimental OpenGL driver... :(

I just have to keep hoping for a GLES optimized version of QuakeSpasm.
by antiriad
Mon Mar 13, 2017 1:06 pm
Forum: Gaming
Topic: Quakespasm and DOOM Retro on Rpi3 (help)
Replies: 4
Views: 1491

Re: Quakespasm and DOOM Retro on Rpi3 (help)

Sorry for the late reply, The QuakeSpasm engine needs desktop OpenGL to play the game smoothly . The DarkPlaces engine is a great alternative to this, as it runs smoothly and uses OpenGL ES, the engine that RaspPi supports. My bad, there is a solution to this. You can try the experimental OpenGL en...
by antiriad
Fri Mar 10, 2017 6:51 am
Forum: Gaming
Topic: NEW: Darkplaces Quake engine up and running on Raspberry PI
Replies: 112
Views: 58237

Re: NEW: Darkplaces Quake engine up and running on Raspberry

Hello,
I'd like to enjoy Darkplaces on RPi3.

Are "unofficial" SDL 2.X (2.0.4, 2.05) needed for better performance, or since the engine is yet GLES optimized I can build it with SDL2 in the official Jessie repository?

Thanks!
by antiriad
Mon Mar 06, 2017 6:44 am
Forum: Raspbian
Topic: SDL2 version 2.0.4 package availability
Replies: 13
Views: 5140

Re: SDL2 version 2.0.4 package availability

Hello,
a lot of projects are "switching" to SDL2 (e.g. Chocolate DOOM V3) and a lot of other great projects that could run on RPi are unusable because of "broken" SDL2 support on Jessie (e.g. Quakespasm).
Maybe some skilled user could share SDL2 2.05 in an "unofficial" repository?

Thanks
by antiriad
Sun Feb 26, 2017 3:32 pm
Forum: Gaming
Topic: Quakespasm and DOOM Retro on Rpi3 (help)
Replies: 4
Views: 1491

Quakespasm and DOOM Retro on Rpi3 (help)

Hi, I'd really like some help to enjoy these two source ports on Raspberry Pi. Quakespasm is available in Raspbian Jessie repository, but I get a "Couldn't load video device" error when I try to run it in CLI... perhaps due to GLES acceleration? DOOM Retro is a minimalist, refined DOOM source port b...

Go to advanced search