Go to advanced search

by andies
Sat Mar 04, 2017 5:01 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1516
Views: 400010

Re: PiKrellCam: motion vector detect + OSD web interface

Unfortunately, the information seems to be scattered in those 40 pages and I do not know whether I will find all questions answered. Have you read the web Help page? Yes, I did. Thank you for your post I will try all the details in the coming days. Would it be possible to establish something like a...
by andies
Thu Mar 02, 2017 6:28 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1516
Views: 400010

Re: PiKrellCam: motion vector detect + OSD web interface

billw: This is great software and I enjoyed using it but I have several questions that are not answered in the doc or in github. I posted it in another thread but maybe this one is better. Unfortunately, the information seems to be scattered in those 40 pages and I do not know whether I will find al...
by andies
Tue Feb 28, 2017 4:52 am
Forum: Camera board
Topic: Using PikrellCam with bash, config etc
Replies: 0
Views: 497

Using PikrellCam with bash, config etc

I have been using motion-mmalcam for two years or so but recently had trouble installing and running it (I am using RPi2 and RPi3 with the Pi module on WLAN). So I switched to PikrellCam and this program is running now for months smoothlessly. That is great. The downside is that I had several script...
by andies
Sat Jan 21, 2017 5:50 pm
Forum: Troubleshooting
Topic: Noise with 433MHz receiver [Completely solved]
Replies: 65
Views: 22015

Re: Noise with 433MHz receiver [Completely solved]

joan wrote:They can then be used to configure the send side if needed.
How is this done? I did not find any argument for the command line.
by andies
Sat Jan 21, 2017 4:56 pm
Forum: Troubleshooting
Topic: Noise with 433MHz receiver [Completely solved]
Replies: 65
Views: 22015

Re: Noise with 433MHz receiver

Have you tried http://abyz.co.uk/rpi/pigpio/examples.html#pdif2__433D ? Joan: I read that I can decode as well as transmit codes to a 433-device. What I do not understand is the following. If I am decoding a code I get the information of low signal, high signal and intersignal length (three numbers...
by andies
Fri Jan 20, 2017 8:33 pm
Forum: Automation, sensing and robotics
Topic: RFSniffer - Can't get it working
Replies: 53
Views: 25930

Re: RFSniffer - Can't get it working

What is your receiver? Try to get an arduino and a transmitter and send a 200ms-200ms signal to your receiver and check whether you can read this 200-200 signal. If not, the receiver is bad. I am pretty sure that it is the receiver. It took me a fruitless month to accept that. And how do you read th...
by andies
Sat Jan 14, 2017 2:39 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1516
Views: 400010

Re: PiKrellCam: motion vector detect + OSD web interface

stephencassidy wrote:I have just rolled back to 4.4.34.
I am new to this rolling-back stuff. How am I doing this?
by andies
Fri Jan 13, 2017 5:41 pm
Forum: Troubleshooting
Topic: Noise with 433MHz receiver [Completely solved]
Replies: 65
Views: 22015

Re: Noise with 433MHz receiver [Solved (sort of)]

I got a new receiver a few days ago, both from the guy who maintains pilight (see https://www.pilight.org/shop/#sender ). The difference is stricking. Even if I am simply recording the signal from the garage opener I do not get any noise at all as this "screen shot" from the raw data shows: 433gpio:...
by andies
Fri Jan 06, 2017 10:16 pm
Forum: Troubleshooting
Topic: Noise with 433MHz receiver [Completely solved]
Replies: 65
Views: 22015

Re: Noise with 433MHz receiver [Solved (sort of)]

I looked at my tools again. I used two different transmitters (Superregeneration or XY-MV-5, for example http://www.avc-shop.de/433Mhz-Sender-Empfaenger-Superregeneration-Modul-FS1000A-XY-FST-XY-MK-5V and superheterodyn, for example http://www.ebay.de/itm/like/401158124585?lpid=106&chn=ps&ul_noapp=t...
by andies
Fri Jan 06, 2017 8:40 pm
Forum: Automation, sensing and robotics
Topic: pigpio and pilight-raw
Replies: 7
Views: 2174

Re: pigpio and pilight-raw

joan wrote:If that is with pigpio you are not using it properly.
You are right (and it has nothing to do with python): I made a mistake in my breadboard. Now I am capturing 50-50-signals correctly with both software codes.
by andies
Fri Jan 06, 2017 7:45 pm
Forum: Automation, sensing and robotics
Topic: pigpio and pilight-raw
Replies: 7
Views: 2174

Re: pigpio and pilight-raw

I have used the code for a while and compared it to pilight-raw. Unfortunately, python (or the RPi) seems to be too slow. The values differ a lot, as far as I can see from actual values that I recorded, in particular using histograms, pilight-raw gives more reliable results. If I am transmitting a 5...
by andies
Wed Jan 04, 2017 8:54 am
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1516
Views: 400010

Re: reliable storage for stills and video

Fox Mulder wrote:I moved /tmp and /var/log to a ramdisk because these are the most frequent written directories for the native linux system.
How did you do this?
by andies
Fri Dec 30, 2016 5:00 am
Forum: Troubleshooting
Topic: Noise with 433MHz receiver [Completely solved]
Replies: 65
Views: 22015

Re: Noise with 433MHz receiver [Solved]

Using higher delays resulted in the following pictures (the name of the file corresponds to the μ-seconds in the above code) 100mueseec.JPG 200muesec.JPG 500muesec.JPG (I cannot add the 700muesec picture - it is similar to the 500 one but even more "distorted"). [EDIT] As in the above post I have no...
by andies
Fri Dec 30, 2016 4:53 am
Forum: Troubleshooting
Topic: Noise with 433MHz receiver [Completely solved]
Replies: 65
Views: 22015

Re: Noise with 433MHz receiver [Solved]

I did some further research (mainly because I am still unable to re-engineer my door opener) and I am about to come to the conclusion that with this kind of cheap receiver a proper analysis of a 433MHz signal is impossible. Let me explain why. I started with a simple arduino program that produces a ...
by andies
Thu Dec 29, 2016 6:52 pm
Forum: Automation, sensing and robotics
Topic: Measuring duty cycle
Replies: 8
Views: 3803

Re: Measuring duty cycle

Python is not fast enough to get the speed you require and it will show systematic and random errors due to the Python interpreter and other processes and interrupts that Linux is executing. I have a comparable problem as OP. I want to sent a AM-signal (via 433MHz) with a frequency around 10kHz usi...
by andies
Thu Dec 29, 2016 11:59 am
Forum: Beginners
Topic: How to run PiScope?
Replies: 27
Views: 8969

Re: How to run PiScope?

OK, I burned both receivers. Just checked it with an oscilloscope. Sorry...
by andies
Thu Dec 29, 2016 11:34 am
Forum: Beginners
Topic: How to run PiScope?
Replies: 27
Views: 8969

Re: How to run PiScope?

I have trouble running Piscope again. I was using it for several days and out of a sudden it stopped working. The problem is the following. If I am touching any of the Pins I see a reaction in Piscope ("noise"). If I am attaching a 433MHz receiver (in fact I have two of them, both working - checked ...
by andies
Mon Dec 26, 2016 5:51 pm
Forum: Camera board
Topic: Motion - MMAL camera
Replies: 472
Views: 414162

Re: Motion - MMAL camera

I am getting error messages after a complete new install: [1] [ERR] [VID] [Dec 26 18:44:19] mmal_output_process_buffer: Output mmalcam - buffer size 499968 does not match destination 488064 [1] [ERR] [VID] [Dec 26 18:44:20] mmal_output_process_buffer: Output mmalcam - buffer size 499968 does not mat...
by andies
Sun Dec 25, 2016 9:17 am
Forum: Troubleshooting
Topic: Noise with 433MHz receiver [Completely solved]
Replies: 65
Views: 22015

Re: Noise with 433MHz receiver [Solved]

A final remark. My ultimate goal was to analyze a garage opener from Came. My problem was that I used RFSniffer, debug and similar software - but they will output only signals they understand (=where the protocol is known). But Came's protocol isn't understood yet. In this thread ( https://forum.pil...
by andies
Sun Dec 25, 2016 9:09 am
Forum: Automation, sensing and robotics
Topic: RFSniffer - Can't get it working
Replies: 53
Views: 25930

Re: RFSniffer - Can't get it working

I finally solved my issue, see this thread: https://forum.pilight.org/Thread-Came-door-opener-automatic-gates . The problem is the following. If you start recording a signal that is unknown to the software no useful output will be produced, sometimes nothing shows up. In this case you have to use an...
by andies
Fri Dec 23, 2016 10:22 am
Forum: Automation, sensing and robotics
Topic: pigpio and pilight-raw
Replies: 7
Views: 2174

Re: pigpio and pilight-raw

Thank you, great code. May I ask you again: I would like to stop the recording after a defined amount of time. I do see that the particular step to be changed is while True: but unfortunately I do not understand the rest of the code (for example: where is tick defined? Could I add a counter without ...
by andies
Thu Dec 22, 2016 6:00 pm
Forum: Automation, sensing and robotics
Topic: RFSniffer - Can't get it working
Replies: 53
Views: 25930

Re: RFSniffer - Can't get it working

Got it working. But I do not receive anything:

Code: Select all

pi@RPi:~/433Utils/python $ python3 signal.py
2016-12-22 18:58:09 - [INFO] signal: Listening for codes on GPIO 27
^Cpi@RPi:~/433Utils/python $
by andies
Thu Dec 22, 2016 5:34 pm
Forum: Automation, sensing and robotics
Topic: RFSniffer - Can't get it working
Replies: 53
Views: 25930

Re: RFSniffer - Can't get it working

I borrrowed an oscilloscope and record the "noise" as well as the signal from the button. Difference (according to the adjustments from the oscilloscope) is about 0.45V, the signal starts with a 400us pulse. Noise: noise.gif The signal (button pressed) signal.gif The adjustments of the oscilloscope ...
by andies
Thu Dec 22, 2016 3:16 pm
Forum: Automation, sensing and robotics
Topic: RFSniffer - Can't get it working
Replies: 53
Views: 25930

Re: RFSniffer - Can't get it working

Found it:

Code: Select all

 sudo easy_install3 -U pip
by andies
Thu Dec 22, 2016 3:02 pm
Forum: Automation, sensing and robotics
Topic: RFSniffer - Can't get it working
Replies: 53
Views: 25930

Re: RFSniffer - Can't get it working

I have difficulties installing it: pi@Zimmer:~/433Utils/python $ pip3 install rpi-rf Traceback (most recent call last): File "/usr/bin/pip3", line 9, in <module> load_entry_point('pip==1.5.6', 'console_scripts', 'pip3')() File "/usr/lib/python3/dist-packages/pkg_resources.py", line 356, in load_entr...

Go to advanced search