Go to advanced search

by emgi
Sat Mar 14, 2015 5:20 pm
Forum: Troubleshooting
Topic: Accessing CIFS mount hangs after target server reboots
Replies: 5
Views: 2083

Re: Accessing CIFS mount hangs after target server reboots

And unmounting and remounting isn't really a solution - a client shouldn't hang just because the server rebooted. Well, it's windoze after all so you never know until you try. And anyway, with M$ I would not be surprised when a non windows client is unable to reconnect after a service outage. Your ...
by emgi
Sat Mar 14, 2015 5:12 pm
Forum: General programming discussion
Topic: Which language?
Replies: 30
Views: 3547

Re: Which language?

What about Python? What is Python useful for? I know it is not very easy to teach. Other than that I know little to nothing about Python (I use RISC OS on the RPi, Mac OS 7.5.5 on the PPC Macintosh, and Atari TOS on the Atari TT), as it is not easy to play with on any system I have. So what is the ...
by emgi
Sat Mar 14, 2015 4:39 pm
Forum: Troubleshooting
Topic: Accessing CIFS mount hangs after target server reboots
Replies: 5
Views: 2083

Re: Accessing CIFS mount hangs after target server reboots

Try what happens when you unmount and the remount the shares.
For me that was the solution to a similar issue with NFS shares.

/emgi
by emgi
Sun Mar 08, 2015 4:37 pm
Forum: Beginners
Topic: Connect a fan to a pi
Replies: 19
Views: 4446

Re: Connect a fan to a pi

Temperatures are rising. I'm logging the temperature on one of my Pi's since february. Today was the first time the temperature exceeded 50 degrees celsius. The time of the day when this machine gets the hottest is around four so here is an overview of the readings at that time: 2015-02-21 16:00:02 ...
by emgi
Sat Mar 07, 2015 10:41 pm
Forum: Troubleshooting
Topic: Crontab
Replies: 18
Views: 2014

Re: Crontab

python101 wrote:No
That's bad. :mrgreen:

Then back to square one. Does the script work when you run it from the cli?
by emgi
Sat Mar 07, 2015 10:34 pm
Forum: Troubleshooting
Topic: SSH Port forwarding not working
Replies: 19
Views: 4294

Re: SSH Port forwarding not working

Check for a howto on this site: http://portforward.com/english/routers/ ... rindex.htm
TP-link is listed so perhaps you're lucky.

/emgi
by emgi
Sat Mar 07, 2015 10:32 pm
Forum: Troubleshooting
Topic: Crontab
Replies: 18
Views: 2014

Re: Crontab

python101 wrote:Now it is but it wasn't earlier
You must have made a typo then, things like this don't work intermittedly on linux.
Anyway, did this resolve the problem :?:
by emgi
Sat Mar 07, 2015 10:28 pm
Forum: Networking and servers
Topic: problem with connection
Replies: 2
Views: 428

Re: problem with connection

Two most likely causes:
-no default gateway set
-no dns servers configured

This happens to many people, especially when they configured a static IP address.
Feel free to browse this forum or use google to find the correct answer.

/emgi
by emgi
Sat Mar 07, 2015 10:24 pm
Forum: Troubleshooting
Topic: Crontab
Replies: 18
Views: 2014

Re: Crontab

python101 wrote:Says "Command Not Found"
Like this: :?:

Code: Select all

[email protected] ~ $ sudo /etc/init.d/cron restart
[ ok ] Restarting periodic command scheduler: cron[....] Stopping periodic command scheduler: cron.
[ ok ] Starting periodic command scheduler: cron.
[email protected] ~ $
by emgi
Sat Mar 07, 2015 10:20 pm
Forum: Troubleshooting
Topic: SSH Port forwarding not working
Replies: 19
Views: 4294

Re: SSH Port forwarding not working

No worries about that then. An address starting with 130 is most probably a genuine public IP. To be sure that you set up port forwarding correctly, you can try to do the same for port 80. Be sure to set it up for tcp in both cases, not udp. When you install the lighttpd webserver you should be able...
by emgi
Sat Mar 07, 2015 10:09 pm
Forum: Troubleshooting
Topic: Crontab
Replies: 18
Views: 2014

Re: Crontab

Various other users with a similar issue were able to resolve it by simply restarting crond.

Code: Select all

/etc/init.d/cron restart
You should use sudo in front if you're not running as root.

/emgi
by emgi
Sat Mar 07, 2015 9:44 pm
Forum: Troubleshooting
Topic: SSH Port forwarding not working
Replies: 19
Views: 4294

Re: SSH Port forwarding not working

Since you claim to have "network in the wall" whatever that may be :mrgreen: , do you have a public IP or a translated one? If the IP is a translated (NATted) one, it will not work without help from your provider. In case you don't understand: The external address should NOT start with 10. or 172. t...
by emgi
Sat Mar 07, 2015 9:28 pm
Forum: Troubleshooting
Topic: Unable to mount ext4 read write
Replies: 8
Views: 9645

Re: Unable to mount ext4 read write

My usb drive is mounted via fstab like this:

Code: Select all

/dev/sda1       /usb1           ext4    defaults,noatime  0       0
Did you format and create the partition properly?

Code: Select all

sudo mkfs.ext4 /dev/sdb1
/emgi
by emgi
Thu Mar 05, 2015 4:03 pm
Forum: Troubleshooting
Topic: sudo anything gives:- cannot execute binary file
Replies: 13
Views: 2625

Re: sudo anything gives:- cannot execute binary file

morphy_richards wrote:

Code: Select all

[email protected] ~ $ file /usr/bin/sudo
-bash: /usr/bin/file: cannot execute binary file

This is what I got a while ago with a corrupted SD card.
Re-flash or replace it. :|

/emgi
by emgi
Thu Feb 26, 2015 6:53 pm
Forum: Troubleshooting
Topic: Lighttpd web server - 403 forbidden
Replies: 5
Views: 8583

Re: Lighttpd web server - 403 forbidden

This is a very interesting problem, especially since I'm a big fan of lighttpd on the Pi. It's simply so much leaner (faster) than Apache. I'm using light on other platforms as well and I'm very happy with it, perhaps because the configuration is also simpler :oops: . Anyway, to my knowledge the web...
by emgi
Thu Feb 26, 2015 6:14 pm
Forum: Troubleshooting
Topic: Ethernet/Internet Not Working
Replies: 13
Views: 1119

Re: Ethernet/Internet Not Working

Thanks. I checked my router and it was properly registering the PI as on that IP address. Plus I don't know how you'd get a duplicate plugging it into the modem directly, but will double-check this. But yeah, I'm going to initiate a return process. Guess it will be a few weeks until I actually get ...
by emgi
Thu Feb 26, 2015 5:17 pm
Forum: Troubleshooting
Topic: Ethernet/Internet Not Working
Replies: 13
Views: 1119

Re: Ethernet/Internet Not Working

Ping your router (192.168.0.1) to check if the packet loss is occurring there.
If so, the issue is on your local LAN hub or switch which is probably integrated in the router?
If not, it might be the router itself or your Internet connection.

/emgi
by emgi
Thu Feb 26, 2015 3:51 pm
Forum: Troubleshooting
Topic: Ethernet/Internet Not Working
Replies: 13
Views: 1119

Re: Ethernet/Internet Not Working

Duplicate IP perhaps :?:
by emgi
Wed Feb 25, 2015 6:50 pm
Forum: Advanced users
Topic: gpio input on one pi to output pin on another pi
Replies: 5
Views: 1503

Re: gpio input on one pi to output pin on another pi

You obviously have to connect GND as well.

/emgi
by emgi
Wed Feb 25, 2015 5:43 pm
Forum: General programming discussion
Topic: Prevent script running simoultaneously
Replies: 9
Views: 1990

Re: Prevent script running simoultaneously

This is what I'm using for a similar situation:

Code: Select all

cd /home/books #Or anywhere else you like. 

if [ -s busyflag ]; then
    rm busyflag
    echo "Running"
    #Your-script-here
    touch busyflag
fi
/emgi
by emgi
Wed Feb 25, 2015 5:30 pm
Forum: Beginners
Topic: Deleting 'pi' user
Replies: 8
Views: 3874

Re: Deleting 'pi' user

A standard user is unlikely to have the same group memberships as user pi. This causes all sorts of issues with application permissions. In case of problems, check this: $ cat /etc/group | grep pi adm:x:4:pi dialout:x:20:pi cdrom:x:24:pi sudo:x:27:pi audio:x:29:pi video:x:44:pi,leo plugdev:x:46:pi g...
by emgi
Mon Feb 23, 2015 6:47 pm
Forum: For sale
Topic: SALE: Lot of 100 RPI model B 512MB
Replies: 13
Views: 3609

Re: SALE: Lot of 100 RPI model B 512MB

Sketchy to say the least. :|
I wouldn't go for this for more than 10 euro a piece (including shipping.)

/emgi
by emgi
Sat Feb 21, 2015 8:50 am
Forum: Troubleshooting
Topic: Internet access thru DSL modem & router
Replies: 6
Views: 1701

Re: Internet access thru DSL modem & router

There are already too many topics about this subject. Is searching the forum really that difficult :?: :cry: If you had searched just a bit you would have found this: http://portforward.com/ For the rest, your post is one of just too many with only a brief description of the problem and no details o...
by emgi
Fri Feb 20, 2015 10:23 pm
Forum: Beginners
Topic: Port Forwarding not an option
Replies: 8
Views: 1718

Re: Port Forwarding not an option

Provided you have a webserver running and you forwarded tcp port 80 (www), it is sufficient to enter the external ip address. There may be a domain name linked to it. to check: http://remote.12dt.com/ or some other site offering this service. If there is, you could alternatively use that name. You c...
by emgi
Fri Feb 20, 2015 8:48 pm
Forum: Off topic discussion
Topic: Solar Shed / Charge controller keeps cutting the power.
Replies: 34
Views: 5706

Re: Charge controller keeps cutting the power.

I'm intrigued by this project. But I do have a query about this: The battery is definitely too small. 7.2Ah is the rated capacity when the current drawn from it does not exceed 10% of that. ( =0,72Amp) So you could draw ~0,7Amp for about seven hours. By doubling or tripling (2A) the current draw, t...

Go to advanced search