Go to advanced search

by ab1jx
Tue Feb 05, 2019 5:18 pm
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

If you have the batteries and inverter and all that I would think 3 KW worth of panels would do unless you have electric heat. Not sure about A/C. Newer panels are slightly more efficient but still only about 13% I think. That's why the heat collecting ones are good, much more efficient. I used to h...
by ab1jx
Tue Feb 05, 2019 4:57 am
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

These little ARM chips can execute Java bytecode directly I think, it's built into their instruction set. Most of what happens in millions of Android phones is in Java because there's no real speed penalty like with old style interpreted Java bytecode. The compiler doesn't actually make an executabl...
by ab1jx
Tue Feb 05, 2019 2:05 am
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

Hey I got some of those PB137 years ago, never got around to using them as I still have to get a spare panel. Might have a look for secondhand refit panels, sometimes going free if you take them away ;) What language/toolset are you using? Language/toolset is just plain GCC in retirement. Used to d...
by ab1jx
Mon Feb 04, 2019 1:51 pm
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

That's probably more down to the timer resolution than anything. If you start at dead on a second (e.g. 0.0s) then your loop will run for ~10 seconds. If however you start part way through a second (e.g. 0.9s) then your loop will only run for ~9.1s and at ~100 lines per second that accounts for ~90...
by ab1jx
Mon Feb 04, 2019 7:51 am
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

No real interest in doing baremetal without Linux. I used OpenBSD for about 15 years but Linux has a bigger userbase so it's more refined. A lot of things won't build under OpenBSD, it's like pulling hen's teeth. And I like Firefox, Libre Office, Gimp, I couldn't do baremetal. Even my Zeroes have Ra...
by ab1jx
Mon Feb 04, 2019 2:02 am
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

Hmm, I can't afford to fly to Europe. I have a few dishes, mostly TVRO, but one big old 4 footer I grabbed from the dump andnever used. For all those MHz up there not much of it's very interesting. I happened to hear the state police catching the Boston Bomber a few years back at 900+ MHz. A real si...
by ab1jx
Sun Feb 03, 2019 4:06 am
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

There's always /opt/vc/src/hello_pi/hello_fft as an example. Not sure if it's really going to be faster than fftw or not but it's one less thread. Passing stuff back and forth to and from the GPU may be slower than what you gain. Computers are a lot faster than in 8088 days. I have a gphoto project ...
by ab1jx
Sun Feb 03, 2019 2:44 am
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

Now I'm not sure what to think. I used this code https://stackoverflow.com/questions/19542029/how-to-get-pixel-colour-from-framebuffer-on-linux-raspberry-pi and it not only worked, it seemed very fast. They open /dev/fb0 (standard framebuffer device) as a file, then use mmap() to get a pointer. So v...
by ab1jx
Sat Feb 02, 2019 2:47 pm
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

Only £149.99 (inc VAT) That can wait, that's for sure (Trilby hat) I don't have a 3B+, just 3 3Bs, don't plan on buying one. I'd be more apt to get a RockPro64 https://www.pine64.org/?page_id=61454 but I'm definitely interested in a 14 inch Pinebook when they're available again. https://www.pine64.o...
by ab1jx
Sat Feb 02, 2019 1:48 am
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

I was hoping the TV hat could be used as a SDR, but first look perhaps not? Maybe, but you can't buy one in the US because it doesn't do ATSC so it won't work. It does DVB-T or something like that, only useful in Europe. Our TV isn't worth bothering with anyway. Not marketed here. I have an ATI HD-...
by ab1jx
Fri Feb 01, 2019 10:33 pm
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

From 2012. Done by changing frequencies on an Icom radio (maybe). I came late to $10 SDR dongles. I have an IC-7000(?) and did a bunch with Hamlib, but it's not exactly fast. test2.jpg This (and libjpeg) is all it takes to turn my memory array into a jpeg. That array could be a framebuffer. My array...
by ab1jx
Fri Feb 01, 2019 5:39 pm
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

Spectrogram, have you looked at rtl_power? rtl_power, a simple FFT logger for RTL2832 based DVB-T receivers Use: rtl_power -f freq_range [-options] [filename] -f lower:upper:bin_size [Hz] (bin size is a maximum, smaller more convenient bins will be used. valid range 1Hz - 2.8MHz) [-i integration_int...
by ab1jx
Thu Jan 31, 2019 9:24 pm
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

https://www.raspberrypi.org/app/uploads/2012/10/Architecture-and-Source.png The key is probably in there, but it's not likely to be portable to anything else. Unless I go up to something standard like OpenGL ES so it goes through OpenGL ES implementations on other machines. There was this project h...
by ab1jx
Thu Jan 31, 2019 6:13 pm
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

It all sounds way more complicated than just using a framebuffer. If you want to make an image height * width (* 3 colors) you allocate (malloc or calloc) height * width * 3 bytes. If you want to turn on a pixel in there at x,y you write to offset (y * width) + x. Colors are in sequence (rgb) along ...
by ab1jx
Thu Jan 31, 2019 4:13 am
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

OpenVG may be simpler but does it have shaders? Being able to launch a shader and have it run independently of the CPU is really appealing. I could put my data into an array and have the shader plot it (I think) while I'm calculating the next batch. But accelerated X drivers aren't bad. There's Xlib...
by ab1jx
Thu Jan 31, 2019 1:49 am
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

I think you were confusing EGL with OpenGL. EGL is a library that connects the rendering libraries (OpenGL, OpenGL|ES, OpenVG) to the underlying display libraries (X, framebuffer, DispmanX etc.). The Broadcom libraries are EGL 1.4 and OpenGL|ES 2.0. To use OpenGL 2.1 would need the MESA drivers (or...
by ab1jx
Wed Jan 30, 2019 9:55 pm
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

For whatever it's worth glxinfo (in the mesa-utils deb) says name of display: :0.0 display: :0 screen: 0 direct rendering: Yes server glx vendor string: SGI server glx version string: 1.4 server glx extensions: GLX_ARB_create_context, GLX_ARB_create_context_profile, GLX_ARB_fbconfig_float, GLX_ARB_f...
by ab1jx
Wed Jan 30, 2019 9:14 pm
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

Now it flies but it's still black. See https://www.raspberrypi.org/forums/view ... 3#p1423533

800+ FPS
by ab1jx
Wed Jan 30, 2019 9:12 pm
Forum: OpenGLES
Topic: Has anyone been able to get glfw running?
Replies: 21
Views: 10235

Re: Has anyone been able to get glfw running?

Not that it's glfw, but I downloaded https://raw.githubusercontent.com/ehsan/gl-samples/master/01-es2sdlgears/es2gears.c and worked out this makefile: CC = gcc es2g:es2g.c $(CC) -o es2g es2g.c -I/opt/vc/include -L/opt/vc/lib -lm -lEGL -lGLESv2 -lglut fast_pi_es2gears.png I have some recent problem (...
by ab1jx
Wed Jan 30, 2019 4:41 pm
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

Re: My es2gears went black

OK, thanks. I thought the version was dependent on firmware, but then again somebody would have to write the firmware. And Broadcom would probably not find it profitable to invest time doing that. I was looking a little at GLFW yesterday and a guy at http://discourse.glfw.org/t/glfw-on-rpi-with-open...
by ab1jx
Wed Jan 30, 2019 3:44 am
Forum: Troubleshooting
Topic: My es2gears went black
Replies: 52
Views: 3145

My es2gears went black

Es2gears is like glxgears except for OpenGL ES instead of OpenGL. It used to work, apparently something I installed broke it. es2black.png It's running and doing benchmarks but with a black window. And why is it EGL_VERSION 1.4? I don't remember what that used to say but I thought the pI used EGL 2....
by ab1jx
Wed Jan 30, 2019 1:22 am
Forum: OpenGLES
Topic: Has anyone been able to get glfw running?
Replies: 21
Views: 10235

Re: Has anyone been able to get glfw running?

Well, somebody got it working on a Mali, there's probably hope for hardware OpenGL ES on a Pi too: http://discourse.glfw.org/t/building-options-for-egl-gles2/1252 From https://www.glfw.org/docs/latest/group__window.html#ga7d9c8c62384b1e2821c4dc48952d2033 GLFW_INCLUDE_ES1 makes the GLFW header includ...
by ab1jx
Tue Jan 29, 2019 11:40 pm
Forum: OpenGLES
Topic: Has anyone been able to get glfw running?
Replies: 21
Views: 10235

Re: Has anyone been able to get glfw running?

I have installed (from the Raspbian debs) upstairs# dpkg-query -l | grep glfw ii libglfw3:armhf 3.2.1-1 armhf portable library for OpenGL, window and input (x11 libraries) ii libglfw3-dev:armhf 3.2.1-1 armhf portable library for OpenGL, window and input (development files) ii libglfw3-doc 3.2.1-1 al...
by ab1jx
Tue Jan 29, 2019 4:56 pm
Forum: OpenGLES
Topic: Has anyone been able to get glfw running?
Replies: 21
Views: 10235

Re: Has anyone been able to get glfw running?

But back to glfw, I'm trying to run simple.c from quick_guide.html and it segfaults. GDB is no help: Reading symbols from ./simple...done. (gdb) run Starting program: /usr/programs/c/glfw/simple/simple Program received signal SIGSEGV, Segmentation fault. 0x00000000 in ?? () (gdb) backtrace #0 0x0000...
by ab1jx
Tue Jan 29, 2019 3:17 am
Forum: OpenGLES
Topic: Has anyone been able to get glfw running?
Replies: 21
Views: 10235

Re: Has anyone been able to get glfw running?

Well, that was worthwhile, I updated my userland from github by doing a git pull and built the new version. Hello_teapot still didn't work, it still complained about needing more GPU memory at the CPU/GPU split in raspi-config. 64 MB was always enough for the GPU before but I pushed it up to 128, re...

Go to advanced search