Go to advanced search

by leol
Mon Mar 17, 2014 4:17 pm
Forum: HATs and other add-ons
Topic: Wolfson audio card install and worth
Replies: 41
Views: 44605

Re: Wolfson audio card install and worth

Not sure I can help much. I did install it this way. You are right that the image was not in the documented folder, and the instructions for running the git patch were incorrect and should be "git am -3 /home/pi/rpi_wlf_3.10_beta/*.patch". If run as documented, an error was reported although it was ...
by leol
Mon Feb 24, 2014 2:56 pm
Forum: HATs and other add-ons
Topic: Wolfson audio card install and worth
Replies: 41
Views: 44605

Re: Wolfson audio card install and worth

I got one over the weekend. First impressions: It connects directly to the Pi using P1 the GPIO connector and also has spring loaded legs that connect with the new P5 connector. So you don't need to solder any additional connectors to the Pi. Because it uses P5 it is incompatible with an old Rev 1 P...
by leol
Tue Feb 18, 2014 4:48 pm
Forum: General discussion
Topic: Serial data scrambled (solved)
Replies: 19
Views: 14422

Re: Serial data scrambled

Well, I checked the Arduino's specs (8n1 and no flow control). I ran this: screen -fn /dev/ttyACM0 115200,cs8,-ixon,-ixoff,-istrip But yet again, after a while my JSON arrays that the Arduino was sending got garbled and stuttered out after two minutes. What's odd is that this doesn't happen in the ...
by leol
Tue Feb 18, 2014 11:32 am
Forum: Camera board
Topic: 2Pis and 2camers - how to stream on same network?
Replies: 3
Views: 871

Re: 2Pis and 2camers - how to stream on same network?

Not sure why they should interfere with each other. Each will be coming from its own address.

leo
by leol
Wed Feb 05, 2014 1:53 pm
Forum: Camera board
Topic: image goes black after a couple of minutes
Replies: 36
Views: 7937

Re: image goes black after a couple of minutes

flok wrote:Ah yes, that looks indeed like an ipv6 problem.

sudo modprobe ipv6

or
echo ipv6 >> /etc/modules
(and reboot)

should fix it.
Fantastic. Thanks that works.
by leol
Wed Feb 05, 2014 1:20 pm
Forum: Camera board
Topic: image goes black after a couple of minutes
Replies: 36
Views: 7937

Re: image goes black after a couple of minutes

Koudevoeten ( http://www.vanheusden.com/koudevoeten/ ) 0.5 was released to the web! It now retrieves JPEG encoded images directly from the camera/GPU dramatically reducing the CPU load. It has been streaming MJPEG data for a couple of days now from the birdhouse in my garden without any crashes and...
by leol
Tue Feb 04, 2014 4:41 pm
Forum: Camera board
Topic: Image pocessing with python and Pi camera
Replies: 4
Views: 2310

Re: Image pocessing with python and Pi camera

Not certain, but if you install the new Official V4L2 drivers , you should be able to use OpenCV.

Leo
by leol
Tue Jan 21, 2014 5:23 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5069
Views: 1343736

Re: RPi Cam Web Interface

I addded a PIR sensor to my RPi camera setup to capture activity around my fish pond. The most interesting activity occurs at night so I added a relay activated spotlight. Setting exposure mode to "night" seems to give better exposure than "auto", although the spotlight is bright enough for auto mo...
by leol
Fri Jan 10, 2014 2:08 pm
Forum: General discussion
Topic: CPC out of stock of Model Bs
Replies: 1
Views: 425

CPC out of stock of Model Bs

CPC is quoting begining of Feb for Model Bs.
Is there another shortage?

Leo
by leol
Mon Dec 16, 2013 6:21 pm
Forum: HATs and other add-ons
Topic: Piface CAD and LCDproc problem
Replies: 10
Views: 5614

Re: Piface CAD and LCDproc problem

thomaspreston wrote:I'm one of the developers at PiFace. We're working on an LCDProc driver. I'll keep you posted.

There are also C libraries available here: http://piface.github.io/libpifacecad/
Just what I was looking for. Glad I found this post.

Leo
by leol
Wed Dec 11, 2013 10:57 am
Forum: General discussion
Topic: RS Components Dispatch Times
Replies: 3
Views: 610

Re: RS Components Dispatch Times

I haven't bought any Pis from RS myself but I would take the lack of recent complaints as an indication they have got their act together. Reason I have not posted any issues lately is that I have abandoned using RS. Every time I used them for Pi products it has been late, or a drama of some sort. W...
by leol
Mon Dec 02, 2013 12:03 pm
Forum: Camera board
Topic: infrared v.s. normal camera
Replies: 6
Views: 3562

Re: infrared v.s. normal camera

The cameras are exactly the same except that the PiNoir does not have an Infra-red filter. Firmware and software identical.
by leol
Fri Nov 29, 2013 1:33 pm
Forum: HATs and other add-ons
Topic: ATmega setup, etc.
Replies: 39
Views: 12066

Re: ATmega setup, etc.

worked the first time except that I got the command syntax wrong for gdset and didn't notice until I started the halt. But now I cannot get it to work, /bin/bash: line 0: echo: write error: Invalid argument hwclock: Cannot access the Hardware Clock via any known method. hwclock: Use the --debug opti...
by leol
Fri Nov 29, 2013 1:18 pm
Forum: HATs and other add-ons
Topic: ATmega setup, etc.
Replies: 39
Views: 12066

Re: ATmega setup, etc.

Thanks Gordon I have got past that bit now by loading the modules on boot. The next problem I get is when I run make in the gdset folder. This time I get this. [email protected] ~/gertduino/gdset $ make [Compile] gdset.c gdset.c:45:25: fatal error: wiringPiI2C.h: No such file or directory compilation ...
by leol
Fri Nov 29, 2013 11:47 am
Forum: HATs and other add-ons
Topic: ATmega setup, etc.
Replies: 39
Views: 12066

Re: ATmega setup, etc.

-i4 works fine for me.

Thanks
by leol
Fri Nov 29, 2013 11:44 am
Forum: HATs and other add-ons
Topic: ATmega setup, etc.
Replies: 39
Views: 12066

Re: ATmega setup, etc.

Whilst you are updating the code Gordon, the tgz file contains another tgz file which is empty.

Leo
by leol
Fri Nov 29, 2013 11:09 am
Forum: HATs and other add-ons
Topic: ATmega setup, etc.
Replies: 39
Views: 12066

Re: ATmega setup, etc.

Let me have a look at my own board - it's actually been some time since I flashed mine, so will just go & refresh my memories.. (There is a potential timing issue with this version of avrdude - do you have an overlocked Pi? mine aren't...) -Gordon Yes my arm_freq is set to 900 Just tried removing t...
by leol
Fri Nov 29, 2013 8:58 am
Forum: HATs and other add-ons
Topic: ATmega setup, etc.
Replies: 39
Views: 12066

Re: ATmega setup, etc.

Hi Gordon, I'm having problems uploading the m48 firmware. Running the avrsetup works but the upload of the firmware fails [email protected]:~/gertduino/m48# ../avrdude/avrsetup Initialising a new ATmega microcontroller for use with the Gertboard or the Gertduino Raspberry Pi Interface boards. Mak...
by leol
Thu Nov 28, 2013 10:11 pm
Forum: HATs and other add-ons
Topic: ATmega setup, etc.
Replies: 39
Views: 12066

Re: ATmega setup, etc.

Fantastic stuff Gordon.
Thanks very much.
by leol
Thu Nov 28, 2013 3:58 pm
Forum: HATs and other add-ons
Topic: RPi Reboots instead of Halting
Replies: 19
Views: 6264

Re: RPi Reboots instead of Halting

AndyD wrote: I can confirm the same finding here. Once I uploaded the low_power example to the m48, I was able to halt and no longer needed avoid_safemode.
Same here.

Leo
by leol
Thu Nov 28, 2013 2:37 pm
Forum: General discussion
Topic: Short MicroSD adapter
Replies: 2
Views: 572

Re: Short MicroSD adapter

Looks quite expensive
by leol
Thu Nov 28, 2013 10:45 am
Forum: HATs and other add-ons
Topic: Gertduino
Replies: 4
Views: 2027

Re: Gertduino

Fantastic!

Thanks Gordon.
by leol
Thu Nov 28, 2013 10:40 am
Forum: HATs and other add-ons
Topic: RTC
Replies: 34
Views: 27716

Re: RTC

The original tar file (gertduino.tar) on the Element14 website (which was replaced with gertduino.zip). Had a file called setup which contained the following:- #!/bin/bash echo Settup the Pi for DS1374 gpio load i2c sudo modprobe rtc-ds1374 sudo /bin/bash -c "echo ds1374 0x68 > /sys/class/i2c-adapt...
by leol
Wed Nov 27, 2013 7:40 pm
Forum: HATs and other add-ons
Topic: RPi Reboots instead of Halting
Replies: 19
Views: 6264

Re: RPi Reboots instead of Halting

The I2C SCL line is used to wake-up the PI after it goes into sleep mode. I am not sure if the same applies if it goes into 'halt' mode. Yes, a falling edge on GPIO3 after the system has halted will cause it to reboot. You can avoid this by halting in the ARM kernel instead of the GPU firmware: sud...
by leol
Wed Nov 27, 2013 4:30 pm
Forum: HATs and other add-ons
Topic: RPi Reboots instead of Halting
Replies: 19
Views: 6264

Re: RPi Reboots instead of Halting

redhawk wrote:What happens when you run: sudo init 0 ??

RIchard S.
I almost replied without checking that it was the same behaviour, but did quickly check. It is the same.
Surely "halt" and init 0 do the same thing.

Go to advanced search