Go to advanced search

by pcmanbob
Tue Sep 10, 2019 7:32 pm
Forum: General discussion
Topic: Starting script via a pushbotton
Replies: 14
Views: 421

Re: Starting script via a pushbotton

That's what it's supposed to do then when you press the switch connected to gpio 20 the program should advance to your LED sequence, then it will loop around again to waiting for the switch press.
by pcmanbob
Tue Sep 10, 2019 6:58 pm
Forum: Beginners
Topic: 3.3v relays
Replies: 1
Views: 71

Re: 3.3v relays

The problem is the sellers will claim what ever they like so you could end up buying many relay boards before you find one that works. The simplest answer may be to buy a 5V version that is active low , that is applying a low on the In pin turns the relay on, and then suing a simple transistor inter...
by pcmanbob
Tue Sep 10, 2019 4:57 pm
Forum: Troubleshooting
Topic: Ye Old unknown-block(179,2)
Replies: 16
Views: 324

Re: Ye Old unknown-block(179,2)

Glad you finally solved your SD card problem.

With the ever changing SD card ranges and specifications I can see this becoming more of a problem as people don't tend to upgrade there card readers very often.
by pcmanbob
Tue Sep 10, 2019 4:47 pm
Forum: Other projects
Topic: Going to make lock with piano HAT
Replies: 2
Views: 86

Re: Going to make lock with piano HAT

Hi.

If you Google electric door lock you will find many different types.

Non of them can be driven directly from the 3.3v gpio pins so what ever one you decide to use you will need a separate power supply and an interface circuit that will allow your pi to operate it.
by pcmanbob
Tue Sep 10, 2019 1:05 pm
Forum: Beginners
Topic: Creatief cron job
Replies: 5
Views: 84

Re: Creatief cron job

Hi.

Does the command work if you try it at the command line ?
by pcmanbob
Tue Sep 10, 2019 1:03 pm
Forum: Troubleshooting
Topic: Ye Old unknown-block(179,2)
Replies: 16
Views: 324

Re: Ye Old unknown-block(179,2)

Maybe you should check the md5 checksum of the Raspbian image file you originally downloaded, or redownload it again. I would normally agree with that statement , except in this case the OP has 4 SD cards the 2 SanDisk ones don't work, but the 2 Microcenter ones do work, assuming same image file us...
by pcmanbob
Tue Sep 10, 2019 11:29 am
Forum: Troubleshooting
Topic: Oops - unable to determine board type... model: 17
Replies: 3
Views: 156

Re: Oops - unable to determine board type... model: 17

Hi.

If you run

Code: Select all

sudo apt update 
sudo apt full-upgrade
it should update wiring pi
or
you could just update wiringpi with

Code: Select all

sudo apt-get install wiringpi

http://wiringpi.com/download-and-install/
by pcmanbob
Tue Sep 10, 2019 11:18 am
Forum: Troubleshooting
Topic: Ye Old unknown-block(179,2)
Replies: 16
Views: 324

Re: Ye Old unknown-block(179,2)

If your SD card passed the test but still cant write to block(179,2), then I as stumped.

An error like that would normally be because the card is faulty or a fake, but yours passed the test so should not be either,

have you tried flashing them again with raspbian and if they work now.
by pcmanbob
Tue Sep 10, 2019 11:13 am
Forum: General discussion
Topic: Only 1 motor is working on two motor robot
Replies: 7
Views: 273

Re: Only 1 motor is working on two motor robot

we cant help you if you don't show us your pi, as has been asked please post pictures so we can see how things are wired.
by pcmanbob
Tue Sep 10, 2019 11:11 am
Forum: General discussion
Topic: Starting script via a pushbotton
Replies: 14
Views: 421

Re: Starting script via a pushbotton

As I said gpio 38 does not exist that is a board pin number , you are using BCM numbering so pin 38 is actually gpio 20 https://i.imgur.com/3CdmwXv.jpg So change your references to 38 to 20 and it will work io.setmode(io.BCM) io.setup(20, io.IN, pull_up_down=io.PUD_DOWN) while True: # waiting for bu...
by pcmanbob
Mon Sep 09, 2019 2:39 pm
Forum: General discussion
Topic: Menu display lcd
Replies: 1
Views: 89

Re: Menu display lcd

I suggest you have a read of this thread https://www.raspberrypi.org/forums/view ... 2&t=225021
the hardware side of it will not match yours as the LCD and buttons were connected directly to the pi gpio , but the logic and layout may help you get started.
by pcmanbob
Mon Sep 09, 2019 1:59 pm
Forum: Beginners
Topic: How to wire pi, battery and servo
Replies: 18
Views: 376

Re: How to wire pi, battery and servo

Maybe connect battery GND to one of the pi Ground pins (female to female DuPont cable). Then the servo brown (gnd) to a different GND on the pi. Those pi GND pins are all connected to each other, so OK. This not something I would recommend as the full current drawn by the servo from the battery wil...
by pcmanbob
Mon Sep 09, 2019 12:51 pm
Forum: Troubleshooting
Topic: Ye Old unknown-block(179,2)
Replies: 16
Views: 324

Re: Ye Old unknown-block(179,2)

I would suggest you test the SD cards you got from Amazon using H2testw to see if they are in fact fakes or low quality seconds.

https://www.softpedia.com/get/System/Sy ... estw.shtml
by pcmanbob
Mon Sep 09, 2019 9:37 am
Forum: Beginners
Topic: Connecting whilte LED strip to Pi
Replies: 14
Views: 327

Re: Connecting whilte LED strip to Pi

Depending on how much current your LED's are going to draw look at the NPN transistor or FET examples on this web site

https://elinux.org/RPi_GPIO_Interface_Circuits
by pcmanbob
Mon Sep 09, 2019 9:26 am
Forum: General discussion
Topic: Only 1 motor is working on two motor robot
Replies: 7
Views: 273

Re: Only 1 motor is working on two motor robot

Photos of the actual wiring are always better if they are clear enough to show all the connections , as how you think its connected may not actually be how its connected. simplest option for a diagram is pencil and paper then scan or photograph paper. you can upload pictures to imgur.com and post li...
by pcmanbob
Sun Sep 08, 2019 11:11 pm
Forum: General discussion
Topic: Only 1 motor is working on two motor robot
Replies: 7
Views: 273

Re: Only 1 motor is working on two motor robot

You have given us to little information to even guess at what might be wrong.

pictures showing how things are connected would be a start.........
by pcmanbob
Sun Sep 08, 2019 9:31 pm
Forum: Troubleshooting
Topic: Almost Only Red Led
Replies: 4
Views: 130

Re: Almost Only Red Led

It does sound like you pi has failed , is it in a case or is it uncased , if its uncased could you have put it down on something conductive and shorted out some thing ? if you have a digital voltmeter , have you tried measuring the voltage on one of the 3.3v gpio pins ? be careful not to short the p...
by pcmanbob
Sun Sep 08, 2019 8:27 pm
Forum: Automation, sensing and robotics
Topic: Detecting a 24v Impulse via GPIO Pins
Replies: 8
Views: 476

Re: Detecting a 24v Impulse via GPIO Pins

The first thing is the pi gpio is 3.3v and is not 5v tolerant. Connecting 5v to a gpio input will damage you pi and eventually kill it. It sounds like you have your opto isolator incorrectly connected. As for the strange voltages are you sure you are measuring them correctly as the pi has no negativ...
by pcmanbob
Sun Sep 08, 2019 8:01 pm
Forum: Troubleshooting
Topic: New Raspberry Pi 4 won't boot
Replies: 6
Views: 246

Re: New Raspberry Pi 4 won't boot

I would suggest downloading a copy of the raspbian image

https://www.raspberrypi.org/downloads/raspbian/

and then use etcher to flash the image directly on the SD card.

https://www.raspberrypi.org/documentati ... /README.md

https://www.balena.io/etcher/
by pcmanbob
Sun Sep 08, 2019 7:54 pm
Forum: Troubleshooting
Topic: Almost Only Red Led
Replies: 4
Views: 130

Re: Almost Only Red Led

So does the red led ever flash or go out .

Have you got or had anything connected to the gpio.

Does any part of the pi get hot very quickly.
by pcmanbob
Sun Sep 08, 2019 5:20 pm
Forum: Beginners
Topic: red LED, wont start, salvagable?
Replies: 4
Views: 159

Re: red LED, wont start, salvagable?

It sounds like you might have discovered what damaged you pi's , which is good news. If your non working pi's are not getting hot a would try a fresh install of raspbian and see if they will boot from that , you never know you might have corrupted your SD card. If you get activity on the green led b...
by pcmanbob
Sun Sep 08, 2019 3:02 pm
Forum: Beginners
Topic: red LED, wont start, salvagable?
Replies: 4
Views: 159

Re: red LED, wont start, salvagable?

So first I would suggest you tell us how you were connecting the LED's and switches to your pi , A simple hand draw diagram will do if you don't want to post actual pictures. Remember that the pi gpio is not 5v tolerant so you should be using 3.3v with your switches and possibly your LED's depending...
by pcmanbob
Sun Sep 08, 2019 2:54 pm
Forum: Troubleshooting
Topic: Broken part hdmi1
Replies: 2
Views: 81

Re: Broken part hdmi1

benji241 wrote:
Sun Sep 08, 2019 9:35 am

I tried to upload images but every image said it was too large
upload your image to imgur.com and just post the link to it here.
by pcmanbob
Sun Sep 08, 2019 2:51 pm
Forum: Troubleshooting
Topic: RPi 2 headless ssh doesn´t work
Replies: 9
Views: 173

Re: RPi 2 headless ssh doesn´t work

So if you have the correct IP ( I would check again just in case your router has given the pi another IP ), you are using the IP for your pi in putty, and you can ping the pi successfully from your pc, I think you may have reached the limit for fault finding you can do without having your pi connect...
by pcmanbob
Sun Sep 08, 2019 10:49 am
Forum: Troubleshooting
Topic: RPi 2 headless ssh doesn´t work
Replies: 9
Views: 173

Re: RPi 2 headless ssh doesn´t work

I think the question here is how do you know you have the correct IP for your pi ?

connection refused suggests you have attempted to connect to a pc but it may not be your pi.

Go to advanced search