Go to advanced search

by RaspISteve
Sun Nov 22, 2020 4:28 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

Re: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop

Guys, Reporting back... Turns out the 8GB card that snapped into action on Ubuntu and then programmed quite quickly took over an hour and a quarter to complete write/verify on my Windows 10. The 16GB card that today took 13 minutes to start writing was being written to in just less than a minute and...
by RaspISteve
Sun Nov 22, 2020 1:53 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

Re: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop

Expecting that your imager might do the same as dd with a different user interface, just try again and see whether it inexplicably works the second time. It is not the programmatic equivalent of "dd" that his -7 year old- SD card has a problem with. Didn't think I was using a ~7 year old SD Card. T...
by RaspISteve
Sun Nov 22, 2020 1:44 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

Re: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop

Guys, Remembering that at one point I had the Imager 1.4 running without any delay when run from the cmdline, I think with a SD freshly formatted by the WIndows SD Formatter App I tried this again using a freshly formatted card but with the Imager 1.5 from above. A note here that I had to wait just ...
by RaspISteve
Sat Nov 21, 2020 4:36 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

Re: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop

incognitum,

Be aware that the card/card reader is the same when I use my laptop in Windows 10 so the issue could be outside normal user space. Maybe the Win10 OS cheats in some way.

Hope I haven't ruined your weekend.
by RaspISteve
Sat Nov 21, 2020 3:32 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

Re: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop

incognitum, Note: timings a bit approximate while balancing laptop on knees, clicking and fumbling my digital watch. Run "Raspberry Pi Imager 1.5" under sudo from cmdline as: sudo rpi-imager 2>/tmp/debuglog I get: Sits at: "Preparing to write,,, (discarding existing data on drive)" strobeing for: ~3...
by RaspISteve
Sun Nov 15, 2020 9:28 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

Re: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop

incognitum, You may have missed it amongst my nonsense but this HP Laptop is a dual booter, Windows10 or Ubuntu 18.04 . How the SD card logic responds is perhaps down to what, maybe how, its asked, a bit like me. Thanks again for the interest and feel free to ask again, I'm in lockdown. What else is...
by RaspISteve
Sun Nov 15, 2020 3:20 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

Re: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop

incognitum, Per your request: [Desktop Entry] Type=Application Version=1.0 Name=Imager Comment=Raspberry Pi Imager Icon=rpi-imager Exec=bash -c 'rpi-imager 2>/tmp/debuglog' Categories=Utility StartupNotify=false Terminal=true and run from the favourite it sits there strobing at "Write 0%" for 3:45 m...
by RaspISteve
Sun Nov 15, 2020 2:55 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

Re: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop

Guys, Update: Just re-tried running from the console but redirecting the output to a file: rpi-imager &> rpi-imager.log and sudo rpi-imager &> rpi-imager.log In both cases it gets stuck in the " Write " loop followed by the " Cancel " loop before recovering back the ready-to-Write position after sev...
by RaspISteve
Sun Nov 15, 2020 1:29 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

Re: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop

Guys, Thanx for the input on this one and apologies for the delay, got to sleep, eat etc else my wheels fall off. My system is an HP Elitebook I5: 00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09) Subsystem: Hewlett-Packard Company 3rd Gen Core processor DRAM Con...
by RaspISteve
Sat Nov 14, 2020 10:00 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

Re: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop

incognitum, I have been fiddling with the thing and getting nowhere. Have also removed and re-installed. If run from the GUI favourite it barfs every time. I did try adding " Terminal=true (and false)" to the " /usr/share/applications/rpi-imager.desktop " file to no avail. I also tried adding " bash...
by RaspISteve
Sat Nov 14, 2020 7:44 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

Re: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop

It does prompt you for authentication after pressing the "write" button? And if you start Imager by opening a "terminal" first and typing "rpi-imager" there, what are the last lines it wrote to console when progress stays at 0% ? YES I do get an authentication prompt on pressing "write". And on sup...
by RaspISteve
Sat Nov 14, 2020 5:19 pm
Forum: Troubleshooting
Topic: Got new router and raspi4 will not connect to wifi
Replies: 5
Views: 265

Re: Got new router and raspi4 will not connect to wifi

OK, it's all my bad. Even after checking the network and password at least five times there was one lower case f in there that i never saw. Four hours for one letter! Welcome to the world of fallibility. Remember, its always cleverer than you and is always out to get you. This gets worse as you get...
by RaspISteve
Sat Nov 14, 2020 5:06 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

Re: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop

Guys, Phew! It got moved again! re: Obviously you have the impression that RPI software can run on an X86 based system, <LONG LESSON SNIPPED> Ah.... No I don't. I actually do have a small grasp of what runs on what having started way back in the early 1970's on a CDC160 when a desk top computer was ...
by RaspISteve
Sat Nov 14, 2020 1:37 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

Re: RPi Imager 1.4 Not Working for Me on UBUNTU 18.4

Yep, I'm running Ubuntu 18.04.5 LTS on X86 64-bit and the Pi Imager 1.4 is not working for me. Turns out on my actual distro there are lots of little bits not there. Maybe I got the "Office" version not the "Geek" version. Anyone want to volunteer to beam my problem back to "Trouble Shooting" or per...
by RaspISteve
Sat Nov 14, 2020 1:24 pm
Forum: Troubleshooting
Topic: Got new router and raspi4 will not connect to wifi
Replies: 5
Views: 265

Re: Got new router and raspi4 will not connect to wifi

Daseitz, It occurs to add that if you are using your Windows system to edit the SD card after its been in a Pi you will only see the FAT32 partition. Its very unlikely you'll see the anything of the default Pi file system partition. The better solution is to get a version of ssh running to attack th...
by RaspISteve
Sat Nov 14, 2020 1:01 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

Re: RPi Imager 1.4 Not Working for Me on UBUNTU 18.4

Guys, Can I first give a great big THANK YOU to the hero that beamed my problem into the depths of total obscurity of "Operating System Distributions -> Other -> Ubuntu". It was late last night/early this morning when I posted and I had a near melt down this morning when it wasn't where I left it la...
by RaspISteve
Sat Nov 14, 2020 2:04 am
Forum: Troubleshooting
Topic: Got new router and raspi4 will not connect to wifi
Replies: 5
Views: 265

Re: Got new router and raspi4 will not connect to wifi

A long shot but are you editing the right "wpa_supplicant.conf"? I haven't got as far as Octoprint but have used other headless start-ups like "MotionEye". I recall starting with "wpa_supplicant.conf" in the FAT32 "/boot" directory of a freshly imaged SD card. Once the thing is up and working it nee...
by RaspISteve
Sat Nov 14, 2020 1:35 am
Forum: Raspberry Pi Desktop for PC and Mac
Topic: RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop
Replies: 34
Views: 1231

RPi Imager 1.4 Not Working for Me on X86 UBUNTU 18.4 Laptop

Guys, Per thread title I have yet to get the Raspberry Pi Imager 1.4 working on my Unbuntu system. Having selected the OS and the SD card the thing just sits there reporting "Writing 0%" and the progress bar just strobes left to right. If I "Cancel" the thing just sits there a bit more without chang...
by RaspISteve
Tue Apr 28, 2020 11:34 pm
Forum: Beginners
Topic: A Birthday Pi4 with Argon1 Case SOUND??
Replies: 3
Views: 298

Re: A Birthday Pi4 with Argon1 Case SOUND??

Quickly flipping a Pi4 plastic case off its easy to work out which is hdml0 and hdmi1. With the Argon1 case this one is a major strip and I didn't want to disturb things. The answer is in the documentation on page 2, labelled 06 for HDMI0 and 07 for HDMI1. HDMI0 is located under power button. Thank...
by RaspISteve
Tue Apr 28, 2020 9:12 pm
Forum: Beginners
Topic: A Birthday Pi4 with Argon1 Case SOUND??
Replies: 3
Views: 298

A Birthday Pi4 with Argon1 Case SOUND??

Guys, This is a daft one. I bought my grand boy a Pi4 and an Argon1 case. I put it all together, got it going and added CUPS and accounts for the family. What I didn't check (failed to check) was the sound output, important for a ten year old. What's compounded my problems is the Covid-19 lock-down ...
by RaspISteve
Mon Nov 19, 2018 10:03 am
Forum: C/C++
Topic: Problems with mixing WiringPi Interrupts with forking to a child process
Replies: 2
Views: 2978

Re: Problems with mixing WiringPi Interrupts with forking to a child process

Gordon,

Thank you for your update and WiringPi.

Turns out I haven't had the time to go investigate why it wouldn't work either. Just thought I'd share my experience for the benefit of others.

My program simply polls a GPIO pin but includes a sleep so as not of hog anything.
by RaspISteve
Sun Nov 04, 2018 12:34 am
Forum: C/C++
Topic: Problems with mixing WiringPi Interrupts with forking to a child process
Replies: 2
Views: 2978

Problems with mixing WiringPi Interrupts with forking to a child process

Guys, I have a little program which connects to a signal using a controlled relay and spawns a child process that calls "aplay..." with parameters to play an appropriate voice message before disconnecting the relay when the message plays out. Rather that fire off the "aplay..." and wait enough time ...
by RaspISteve
Fri Aug 03, 2018 6:41 pm
Forum: Other projects
Topic: audio delay device - Echo - up to 2 seconds
Replies: 1
Views: 557

Re: audio delay device - Echo - up to 2 seconds

GH1, Given my minor break through using a Pi to emulated Caller ID I have a little experience using a USB sound dongle with the Pi. I used to make my living bluffing folk I knew enough of the C programming language to get paid for it. If you don't program yet it will be a bit of an up hill ride. If ...
by RaspISteve
Fri Aug 03, 2018 5:36 pm
Forum: Other projects
Topic: Domestic Caller ID Revisited
Replies: 6
Views: 1532

Re: Domestic Caller ID Revisited

The problem with Caller ID signaling is that it appears before the first ring cycle which means the modem has to be ON-HOOK and line therefore open to a new call. But caller ID systems are designed to detect the number calling, then not allow the ring to come through if blacklisted, or not whitelis...
by RaspISteve
Thu Aug 02, 2018 10:07 pm
Forum: Other projects
Topic: Domestic Caller ID Revisited
Replies: 6
Views: 1532

Domestic Caller ID Revisited

Guys, Just did a little search here looking for Caller ID. Seems lots of folk are having either little success, or just want it. A few have an expensive or hard to find modem which can do it. So far nothing really definitive. Being retired and at home I get a lot of calls from folk wanting something...

Go to advanced search