Go to advanced search

by peepo
Mon Mar 16, 2015 1:30 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Bug? RPi reboots on shutdown.
Replies: 3
Views: 759

Re: Bug? RPi reboots on shutdown.

SCL is pin to avoid in my tests.

tx again!
by peepo
Mon Mar 16, 2015 8:59 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Bug? RPi reboots on shutdown.
Replies: 3
Views: 759

Re: Bug? RPi reboots on shutdown.

@rpdom

thanks for that,
is there any workaround, beyond not using?

GPIO 3 - SDA pin has data across it,
will check if it is the only one and report

tx again

Jonathan
by peepo
Sun Mar 15, 2015 9:56 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Bug? RPi reboots on shutdown.
Replies: 3
Views: 759

Bug? RPi reboots on shutdown.

attached evidence that activity on GPIO pins can cause reboot.** anyone know of this? point me to description, rationale etc...? tx Jonathan Chetwynd **from initial LogiPi discussion: http://valentfx.com/vanilla/discussion/comment/463/ "I found that with some bitfiles: LogiPi caused Raspberry Pi to ...
by peepo
Sat Jan 31, 2015 1:40 pm
Forum: Advanced users
Topic: New device tree kernel is in testing
Replies: 356
Views: 74957

Re: New device tree kernel is in testing

Phil, tx that makes much more sense, the first post felt like flannel... had been looking for the rpi-update post (i2c), but Google found this first... not the one, but: http://raspberrypi.stackexchange.com/questions/27073/firmware-3-18-x-breaks-i2c-spi-audio-lirc-1-wire-e-g-dev-i2c-1-no-such-f shou...
by peepo
Sat Jan 31, 2015 1:21 pm
Forum: Advanced users
Topic: New device tree kernel is in testing
Replies: 356
Views: 74957

Re: New device tree kernel is in testing

PhilE not clear to me this is exactly the problem I now need to understand, but LogiPi instructions do not seem to mention any issues around spi or spidev, yet I cannot currently seem to use.... so how do I load if hashing raspi-blacklist.conf and modprobe are no longer the way to go? apologies if I...
by peepo
Thu Jan 29, 2015 12:09 pm
Forum: General discussion
Topic: The Pi as a development platform
Replies: 79
Views: 11153

Re: The Pi as a development platform

yup, on AHRS having great difficulty finding working code, plenty abandoned, buggy, unresolved dependencies etc... see: http://wobl.in/imu/index.html running in chrome, but not wobblin and no real data.... my confusion is lack of understanding https://github.com/ZiCog/madgwick.js in particular: "Rea...
by peepo
Mon Jan 26, 2015 12:54 pm
Forum: General discussion
Topic: The Pi as a development platform
Replies: 79
Views: 11153

Re: The Pi as a development platform

Heater,

love the madgwick demo,
beyond providing the source,
breaking the project into modules,
and writing each up in a blog,
would be a great help to my understanding.

I hope to post on AHRS project soon, still scoping.

Jonathan
by peepo
Mon Jan 26, 2015 11:49 am
Forum: General discussion
Topic: The Pi as a development platform
Replies: 79
Views: 11153

Re: The Pi as a development platform

Bill, very excited to find this, I strongly recommend using SVG with HTML5, nodeJS, JSON and websockets. http://www.peepo.com was an experiment of mine from a few years ago. I use Redis and steer clear of JQuery, closure does take a little practice, as well as callbacks, function factories... peepo....
by peepo
Mon Jan 26, 2015 8:54 am
Forum: OpenGLES
Topic: QtOpenGL & openGL conflict?
Replies: 2
Views: 2111

Re: QtOpenGL & openGL conflict?

that seems to be near the mark...

will check with author

tx
by peepo
Sun Jan 25, 2015 8:57 pm
Forum: OpenGLES
Topic: QtOpenGL & openGL conflict?
Replies: 2
Views: 2111

QtOpenGL & openGL conflict?

anyone know of potential conflict between QtOpenGL & openGL?
ie may be different drivers or such?

trying to resolve my previous query:
QGLTempContext: No GL capable X visuals available.

I had been using openGL on this machine then upgraded because of need for QtOpenGL,
by peepo
Sun Jan 25, 2015 5:54 pm
Forum: OpenGLES
Topic: QGLTempContext: No GL capable X visuals available.
Replies: 4
Views: 4288

Re: QGLTempContext: No GL capable X visuals available.

PeterO, yup one might think this was the case, but many other people are using the program quite happily.

for this reason I believe it may be a configuration issue...
by peepo
Sun Jan 25, 2015 4:46 pm
Forum: OpenGLES
Topic: QGLTempContext: No GL capable X visuals available.
Replies: 4
Views: 4288

QGLTempContext: No GL capable X visuals available.

originally I had thought this was an ssh issue, however I have now plugged a keyboard directly into the RPi, same result. from the web found: check the X11 configuration and your video driver. but not clear what I might do... RTIMULibDemoGL QGLTempContext: No GL capable X visuals available. Settings...
by peepo
Wed Jul 23, 2014 8:26 am
Forum: Camera board
Topic: STICKY: Foundation (old) Camera Board information
Replies: 446
Views: 291684

Re: Foundation Camera Board information

not at all,

please search before posting,
this topic has been extensively replied to...

~:"
by peepo
Wed Jun 11, 2014 4:13 pm
Forum: Camera board
Topic: Prizes for video
Replies: 0
Views: 566

Prizes for video

I need some action video for a proposal. must be Point Of View, or first person, ie as worn on chest, shoulder or helmet. any topic, Sports, Science, Arts whatever. can be tragic, comic, dramatic, educational or.... but must be short and to the point and must be original, shot by you in 720 or 1080p...
by peepo
Mon Jun 02, 2014 1:46 pm
Forum: Camera board
Topic: Camera and Compute Module I/O Board working together?
Replies: 6
Views: 1114

Re: Camera and Compute Module I/O Board working together?

any reason 2 cameras have not been tried?

thanks again

Jonathan
by peepo
Mon Jun 02, 2014 1:45 pm
Forum: Compute Module
Topic: 2x camera->new RPi.C model?
Replies: 8
Views: 3412

Re: 2x camera->new RPi.C model?

Gert et all,

A two data-lane one and a four data-lane one

iirc the camera board uses the 2 data-lane, so is there another sensor planned or available that uses the 4 lanes?
ie why provide access, if we cannot use it?

thanks again

Jonathan
by peepo
Fri May 23, 2014 7:50 pm
Forum: Camera board
Topic: CME -x postponed?
Replies: 56
Views: 15622

Re: CME -x postponed?

please do not fork threads??

this thread is already quite hard to follow.

~:"
by peepo
Thu May 15, 2014 1:17 pm
Forum: Camera board
Topic: CME -x postponed?
Replies: 56
Views: 15622

Re: CME -x postponed?

if anyone could explain the current CME codebase, it would be appreciated.
as I prefer tinkering at the core.
I find more layers of code gums up the works...

~:"

ie ethanol100-Gordon's collaboration,
though likely another voice may help.
by peepo
Wed May 14, 2014 6:27 pm
Forum: Raspbian
Topic: [Release] NOODS: NOOBS + Raspbian, stripped down.
Replies: 28
Views: 7807

Re: [Release] NOODS: NOOBS + Raspbian, stripped down.

I really, really like server version, it seemed to boot much faster, only been up an hour or so... could we please have a 4Mb version or something even tighter than 175? thanks again ~:" 3 issues: barfed at apt-get install raspi-config 8Gb card, short of space or some such and various linking proble...
by peepo
Tue May 13, 2014 4:39 pm
Forum: Camera board
Topic: CME -x postponed?
Replies: 56
Views: 15622

Re: CME -x postponed?

6by9 wfm thanks so much

thanks a!!

~:"
by peepo
Tue May 13, 2014 3:48 pm
Forum: Camera board
Topic: CME -x postponed?
Replies: 56
Views: 15622

Re: CME -x postponed?

absolutely agree, encode_OGL is not a great reduced test case,

I have taken some more openGL stuff out, mainly the 3d aspect.

It would be great to have a minimal test case tutorial, both for testing and for teaching

feel this thread is being poached

~:"
by peepo
Tue May 13, 2014 3:02 pm
Forum: Camera board
Topic: CME -x postponed?
Replies: 56
Views: 15622

Re: CME -x postponed?

ok tx for that iiuc rpi-update f0eeb5b9431a87906ee77bc70a5baa9203c361e2 to regress to April 07 reboot then try encode_OGL if it then encodes as expected, we may surmise 'bug' introduced subsequently. am enacting as above did not resolve issue, still remains black, this rpi-update was backwards, next...
by peepo
Tue May 13, 2014 1:01 pm
Forum: Camera board
Topic: CME -x postponed?
Replies: 56
Views: 15622

Re: CME -x postponed?

I am currently concerned that CME might be already breaking OMX thread: rpi-update: encode -> black http://www.raspberrypi.org/forums/viewtopic.php?f=43&t=77066 and encode_OGL encoding to black, intermittent? https://github.com/peepo/openGL-RPi-tutorial/issues/3 the issue being that recent images wi...
by peepo
Tue May 13, 2014 12:55 pm
Forum: Camera board
Topic: rpi-update: encode -> black
Replies: 2
Views: 1232

Re: rpi-update: encode -> black

**however when I tried to update latest userland over 140107 img:
$ raspivid -t 5000
mmal: mmal_vc_port_parameter_set: failed to set port parameter 48:2:ENOSYS
mmal: failed to set INLINE VECTORS parameters

Go to advanced search