Go to advanced search

by PeterO
Mon Jul 08, 2019 11:52 am
Forum: Troubleshooting
Topic: I can´t boot from usb in pi 4
Replies: 74
Views: 3581

Re: I can´t boot from usb in pi 4

One thing to note is that the boot partition on the latest raspbian images is now 250M rather that 40M in the older versions.

You might want to make sure there is space on any hard disk you use for a root file system to add a boot partition later when usb boot becomes available.

PeterO
by PeterO
Mon Jul 08, 2019 9:18 am
Forum: Beginners
Topic: "apt-get update testing to stable" [FIXED]
Replies: 18
Views: 7456

Re: "apt-get update testing to stable" [FIXED]

I guess this is because Debian Buster was released today. Is it worth waiting until this is fixed, I fear using: apt-get update --allow-releaseinfo-change Will do something irreversible or mess it up at a later date. Thanks What are you basing that on ? There is nothng to fix ! --allow-releaseinfo-...
by PeterO
Mon Jul 08, 2019 9:03 am
Forum: General discussion
Topic: Pi4 as Desktop computer
Replies: 52
Views: 3192

Re: Pi4 as Desktop computer

by PeterO
Mon Jul 08, 2019 8:01 am
Forum: Beginners
Topic: "apt-get update testing to stable" [FIXED]
Replies: 18
Views: 7456

Re: Update confusing me...

I'm sure lots of people will be running into this today, so maybe the OP could change the title to something more informative (like "apt-get update testing to stable" and append [FIXED] as well.
PeterO
by PeterO
Mon Jul 08, 2019 7:55 am
Forum: Beginners
Topic: "apt-get update testing to stable" [FIXED]
Replies: 18
Views: 7456

Re: Update confusing me...

https://superuser.com/questions/1456989/how-to-configure-apt-in-debian-buster-after-release "I had to do apt-get update --allow-releaseinfo-change once, and then the error disappeared." sudo apt-get update --allow-releaseinfo-change Get:1 http://raspbian.raspberrypi.org/raspbian buster InRelease [15...
by PeterO
Mon Jul 08, 2019 7:34 am
Forum: Beginners
Topic: "apt-get update testing to stable" [FIXED]
Replies: 18
Views: 7456

Re: Update confusing me...

At a guess I would say this is due to Buster being officially released
https://www.debian.org/News/2019/20190706
PeterO
by PeterO
Sun Jul 07, 2019 8:32 pm
Forum: General discussion
Topic: Raspberry Pi 4 Dual Monitors
Replies: 39
Views: 2318

Re: Raspberry Pi 4 Dual Monitors

I just did an rpi-update and both my monitors are now waking up from sleep during the boot 8-)
PeterO
by PeterO
Sun Jul 07, 2019 8:27 pm
Forum: Raspbian
Topic: Buster bug report thread
Replies: 108
Views: 7798

Re: Buster bug report thread

I just plugged in one of the old "official pi logo" usb hubs. It has it's own power connected, and the tool bar disappeared because /dev/sda (where the root file system resides) disappeared ! /dev/sda is a segate HDD plubbed directly into one of the PI's USB3 ports.

PeterO
by PeterO
Sun Jul 07, 2019 9:10 am
Forum: Troubleshooting
Topic: Pi 3, Yellow light bolt with official 2.5A charger
Replies: 4
Views: 140

Re: Pi 3, Yellow light bolt with official 2.5A charger

itsmedoofer wrote:
Sun Jul 07, 2019 9:05 am
It sounds silly, but is the usb c all the way in? I was seeing the same, when I checked the connector had not "clicked", pushed it right in and it was fine.
FYI: 2.5A one is the old "Pi3" supply, so not a USB C.
PeterO
by PeterO
Thu Jul 04, 2019 10:17 am
Forum: OpenGLES
Topic: Thread from Pi4 discussion
Replies: 80
Views: 4358

Re: Thread from Pi4 discussion

Generally we'd seen significant improvements with xcompmgr. There were a few discussions on scheduling, as the window composition stage is using also the 3D hardware, therefore your GL app has slightly less resource to do what it wants, but I hadn't previously noted a significant difference. So far...
by PeterO
Thu Jul 04, 2019 10:08 am
Forum: Raspbian
Topic: Buster bug report thread
Replies: 108
Views: 7798

Re: Buster bug report thread

xcompmgr seems to be contributing to poor openGL and openGLES performance. See this thread.
https://www.raspberrypi.org/forums/view ... 2#p1491828

Since it's raison d'être is "It enables basic eye-candy effects." can it be disabled by default please ?

PeterO
by PeterO
Thu Jul 04, 2019 10:03 am
Forum: OpenGLES
Topic: Thread from Pi4 discussion
Replies: 80
Views: 4358

Re: Thread from Pi4 discussion

So what does the 'xcompmgr composition manager' do? I've been googleing that very question, and the most informative thing I've found so far s this xcompmgr is a sample compositing manager for X servers supporting the XFIXES, DAMAGE, RENDER, and COMPOSITE extensions. I t enables basic eye-candy eff...
by PeterO
Thu Jul 04, 2019 6:20 am
Forum: OpenGLES
Topic: Thread from Pi4 discussion
Replies: 80
Views: 4358

Re: Thread from Pi4 discussion

glxgears still only managing 40 fps in a full screen window. But Tearing on vertical lines in my demo code is gone :-) PeterO Disable the compositor with the A8 option of raspi-config... Here 60fps with glxgears running in 2 screens at 1920x1080 :o :shock: So what are the consequences of disabling ...
by PeterO
Thu Jul 04, 2019 5:42 am
Forum: OpenGLES
Topic: Does the Raspberry Pi 4 (4 GB) support OpenGL 3.3?
Replies: 9
Views: 629

Re: Does the Raspberry Pi 4 (4 GB) support OpenGL 3.3?

pik33 wrote:
Thu Jul 04, 2019 5:04 am
My glxinfo says

OpenGL version string: 3.1 Mesa 19.1.0-devel
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 19.1.0-devel
I suspect you've somehow broken hardware acceleration and that is just software emulation provided by mesa.

PeterO
by PeterO
Wed Jul 03, 2019 9:42 pm
Forum: OpenGLES
Topic: OpenGL on Buster on both Pi 3 and Pi 4
Replies: 66
Views: 2504

Re: OpenGL on Buster on both Pi 3 and Pi 4

Good to note there is work being done though and they will probably be available soon. I guess in a year we'll all be posting how do I get Vulkan to work requests :D Sakaki has got pics of 1st spin of Gentoo64 on a Pi4 :D I found OpenGL worked really well on Gentoo64 on Pi3B+. Been playing with Ope...
by PeterO
Wed Jul 03, 2019 9:17 pm
Forum: Device Tree
Topic: Gpio-fan overlay not working
Replies: 25
Views: 555

Re: Gpio-fan overlay not working

It didn't make sense reading it either way :-)

But now it is working so all is good :-)

PeterO
by PeterO
Wed Jul 03, 2019 9:06 pm
Forum: Device Tree
Topic: Gpio-fan overlay not working
Replies: 25
Views: 555

Re: Gpio-fan overlay not working

The new overlay is active high - that's the only change. This suggests its active low 4. Wait until "vcgencmd measure_temp" exceeds the limit, then repeat "raspi-gpio get <gpiopin>"; I see "level=0". 5. Stop the background threads - "kill %1 %2" (substituting the relevant job numbers). 6. Wait unti...
by PeterO
Wed Jul 03, 2019 8:20 pm
Forum: Device Tree
Topic: Gpio-fan overlay not working
Replies: 25
Views: 555

Re: Gpio-fan overlay not working

So can the new overlay be made active high ?
PeterO
by PeterO
Wed Jul 03, 2019 7:19 pm
Forum: General discussion
Topic: Raspberry Pi 4 Dual Monitors
Replies: 39
Views: 2318

Re: Raspberry Pi 4 Dual Monitors

With Raspbian there should be nothing special required. The Pi will probe the monitors and run with what it finds. Monitors generally reply with their EDID whether they are on or sleeping. Some even reply when turned off (HDMI provides a low power supply for this purpose). My experience is that doe...
by PeterO
Wed Jul 03, 2019 7:14 pm
Forum: Device Tree
Topic: Gpio-fan overlay not working
Replies: 25
Views: 555

Re: Gpio-fan overlay not working

I'm back at home now (after a day at TNMOC) so I'll try this after I've cooked and eaten.

PeterO
by PeterO
Wed Jul 03, 2019 3:24 pm
Forum: Device Tree
Topic: Gpio-fan overlay not working
Replies: 25
Views: 555

Re: Gpio-fan overlay not working

PhilE wrote:
Wed Jul 03, 2019 2:43 pm
I can confirm that the output was active high on 4.14, but I can't yet explain why. Watch this space.
I would just like mine to be active ! SO far I've not seen any transitions either way on the selected pin.

PeterO
by PeterO
Tue Jul 02, 2019 9:36 pm
Forum: Device Tree
Topic: Gpio-fan overlay not working
Replies: 25
Views: 555

Re: Gpio-fan overlay not working

I'm not sure I understand all of that, so what should be in config.txt ?

PeterO
by PeterO
Tue Jul 02, 2019 9:09 pm
Forum: Device Tree
Topic: Gpio-fan overlay not working
Replies: 25
Views: 555

Re: Gpio-fan overlay not working

Testing it on a Pi 4 it appears to be working, provided an active-low output is what you want. The GPIO starts out on, then switches off when the temperature hits the limit, remaining on until the temperature drops below (limit - 10000) at which time it switches on again. How did it used to behave?...
by PeterO
Tue Jul 02, 2019 7:20 pm
Forum: Troubleshooting
Topic: Pi 4 not booting
Replies: 14
Views: 1065

Re: Pi 4 not booting

when turning on the Pi 4 (plugging in or from reboot) I have to power cycle one of my monitors (plugged in hdmi port 1) so that the monitor does not time out (no signal displayed on monitor) before the pi displays the 4 pis on the primary screen. If i time it right, i get a rainbow square on the ot...

Go to advanced search