Go to advanced search

by rego21
Sat Oct 20, 2018 8:36 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Ipv6 : ADDRCONF(NETDEV_UP) eth0 link not ready
Replies: 2
Views: 1260

Re: Ipv6 : ADDRCONF(NETDEV_UP) eth0 link not ready

DougieLawson wrote:
Fri Oct 19, 2018 9:13 pm
I don't think the driver supports IPv6.
Didnt understand you... Because it worked perfectly with SPI0 and SPI2, the only problem is with SPI1
by rego21
Fri Oct 19, 2018 11:39 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Ipv6 : ADDRCONF(NETDEV_UP) eth0 link not ready
Replies: 2
Views: 1260

Ipv6 : ADDRCONF(NETDEV_UP) eth0 link not ready

Hello, Im using the ENC28j60 to establish connection to my laptop or router. Also im using SPI 1 from the Compute Module so: CLK - 21 MOSI - 20 MISO - 19 CE0 - 18 I also create one overlay for it: // Overlay for the Microchip ENC28J60 Ethernet Controller - SPI1 Compute Module // Interrupt pin: 39 /d...
by rego21
Thu Oct 18, 2018 2:12 pm
Forum: Compute Module
Topic: ENC28J60 on others SPIs
Replies: 4
Views: 2882

Re: ENC28J60 on others SPIs

When you create a post like this, try and anticipate what the first questions might be and provide the information upfront. Anyone hoping to help you will need to know how you configured the device - hardware and software - on spi0, and what you changed to try to use spi2 instead. You are rigth sor...
by rego21
Thu Oct 18, 2018 1:55 pm
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

Re: ENC28J60 on SPI1

That's not surprising unless your PC is running a DHCP server. Try giving the Pi and PC static IP addresses, or configure the PC to bridge the Ethernet port to WiFi to allow the Pi to share it (depending on your requirements). See my new post! Thanks for your help i fixed the problem today! See if ...
by rego21
Thu Oct 18, 2018 1:46 pm
Forum: Compute Module
Topic: ENC28J60 on others SPIs
Replies: 4
Views: 2882

ENC28J60 on others SPIs

Hello all! Yesterday i successful connected the ENC28J60 trough the SPI0 on Compute Module. However when i try it with SPI2 everything seems fines but doesn't assign an IP to the Compute Module. Im runing an DHCP server on my laptop and worked before with SPI0. Any clue what this problem can be? Tha...
by rego21
Wed Oct 17, 2018 9:57 pm
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

Re: ENC28J60 on SPI1

It's working but only whe connected to the router. When directly connected to the PC i cant ssh...
by rego21
Wed Oct 17, 2018 3:45 pm
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

Re: ENC28J60 on SPI1

PhilE wrote:
Wed Oct 17, 2018 2:33 pm
You shouldn't need to change anything else in Raspbian.
Now ifconfig show me the eth0 however doesnt assign an inet addr to it
by rego21
Wed Oct 17, 2018 2:26 pm
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

Re: ENC28J60 on SPI1

PhilE wrote:
Wed Oct 17, 2018 1:31 pm
Then I am out of ideas for now - sorry.
The dmesg | grep -e spi0.0 -ie eth output seems correct:

net eth0: enc28j60 driver registered

I believe the problem can be the file /network/interfaces
by rego21
Wed Oct 17, 2018 1:26 pm
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

Re: ENC28J60 on SPI1

PhilE wrote:
Wed Oct 17, 2018 11:55 am
Have you had the enc28j60 working on SPI0, or did you just mean the SPI0 is working for something else?
Tried on SPI0 with the INT pin and no success...

Code: Select all

[email protected]:~$ dmesg | grep spi
[   15.053446] enc28j60 spi0.0: enc28j60 Ethernet driver 1.02 loaded
by rego21
Wed Oct 17, 2018 12:03 pm
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

Re: ENC28J60 on SPI1

PhilE wrote:
Wed Oct 17, 2018 11:55 am
Have you had the enc28j60 working on SPI0, or did you just mean the SPI0 is working for something else?
Yeah SPI0 is working for something else
by rego21
Wed Oct 17, 2018 11:52 am
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

Re: ENC28J60 on SPI1

If you have had the enc28j60 on SPI0 then you may not need it, but I think you might. The dmesg output shows the driver being loaded and registering, so I'm surprised it didn't show up in the lsmod output. Have you changed something else? I will try to connect the INT pin, but i think the problem i...
by rego21
Wed Oct 17, 2018 11:41 am
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

Re: ENC28J60 on SPI1

Did you change the interrupt pin assignment? What does "dmesg" report? Im not using the INT pin, i really need it? 0.000000] Booting Linux on physical CPU 0x0 [ 0.000000] Linux version 4.9.59+ ([email protected]) (gcc version 4.9.3 (crosstool-NG crosstool-ng-1.22.0-88-g8460611) ) #1047 Sun Oct 29 ...
by rego21
Wed Oct 17, 2018 11:30 am
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

Re: ENC28J60 on SPI1

You may need to disable spidev on spi1.0 because the enc28j60 has a kernel driver - use "dtoverlay=spi1-1cs,cs0_spidev=off". Nothing... I check ifconfig : lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536 inet 127.0.0.1 netmask 255.0.0.0 inet6 ::1 prefixlen 128 scopeid 0x10<host> loop txqueuelen 1 (Local...
by rego21
Wed Oct 17, 2018 11:04 am
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

Re: ENC28J60 on SPI1

I suspect your overlay is failing to load. "sudo vcdbg log msg" will show you the log messages from the firmware - they are sent to stderr, so if you want to put them in a file you will need "sudo vcdbg log msg >& vcdbg.txt" (or "sudo vcdbg log msg > vcdbg.txt 2>&1" for a simpler shell). My gpio ge...
by rego21
Wed Oct 17, 2018 10:16 am
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

Re: ENC28J60 on SPI1

Show the output of "raspi-gpio get 18-21" and "lsmod" when using the enc28j60-spi1 overlay. lsmod give me this Module Size Used by cfg80211 527100 0 rfkill 21373 2 cfg80211 spidev 7034 0 snd_bcm2835 23131 0 snd_pcm 97825 1 snd_bcm2835 snd_timer 22706 1 snd_pcm spi_bcm2835aux 5235 0 snd 68784 3 snd_...
by rego21
Wed Oct 17, 2018 9:59 am
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

Re: ENC28J60 on SPI1

No, the command is correct: # Copy spi2 overlay source to a new file, changing spi2 to spi1 along the way [email protected]:~$ sed -e 's/spi2/spi1/' enc28j60-spi2-overlay.dts > enc28j60-spi1-overlay.dts # Now compile it [email protected]:~$ dtc [email protected] -I dts -O dtb -o enc28j60-spi1.dtbo enc28j60-spi1-overlay...
by rego21
Wed Oct 17, 2018 9:07 am
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

Re: ENC28J60 on SPI1

Yes - that looks good so far. Now change the default interrupt pin if you want to, compile it, copy it to /boot/overlays and add dtoverlay=enc28j60-spi1 to config.txt. The command line you suggested dtc [email protected] -I dts -O dtb -o enc28j60-spi1.dtbo enc28j60-spi1-overlay.dts i belive the correct is dtc [email protected] ...
by rego21
Tue Oct 16, 2018 4:38 pm
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

Re: ENC28J60 on SPI1

There isn't an overlay that supports this yet, but there is one for spi2: https://github.com/raspberrypi/linux/blob/rpi-4.14.y/arch/arm/boot/dts/overlays/enc28j60-spi2-overlay.dts A simple search and replace of spi2 to spi1, and a change of the default irq pin (I'm guessing), and you should have a ...
by rego21
Tue Oct 16, 2018 4:05 pm
Forum: Compute Module
Topic: [SOLVED] ENC28J60 on SPI1
Replies: 28
Views: 8387

[SOLVED] ENC28J60 on SPI1

Hello all!

I have one Compute Module and want to use the SPI1 interface wich are the GPIOS 17,18,19,20 and 21. However the SPI1 interface is ALT4 for these GPIOS. My question is: i want to know how to make these GPIO use their ALT4.

Thank you all!
by rego21
Sat Jul 28, 2018 4:39 pm
Forum: Compute Module
Topic: CMIO with CM1
Replies: 0
Views: 350

CMIO with CM1

Hello all!

I have an CMIO board with the CM1. Im using the RPi-Boot executble (https://www.raspberrypi.org/documentati ... lashing.md) and it works fine, however the board doesnt appear as eemc. What could be? Im using Windows 10.

Thank you!
by rego21
Tue Mar 06, 2018 4:29 pm
Forum: General discussion
Topic: Raspberry CM Pin assigments
Replies: 1
Views: 245

Raspberry CM Pin assigments

Hello all! Im building a new board for the Raspberry Computer Module. However i dont need the CSI interface (cameras) neither the DSI interface (dislplay). My question is, can i change the pin assignments of these interfaces? I really would like to take advantages of these pins for other purposes. T...
by rego21
Sat Feb 17, 2018 11:50 am
Forum: General discussion
Topic: UDEV on the last Raspbian
Replies: 6
Views: 706

Re: UDEV on the last Raspbian

Ok very strange, my rule is working now but i dont know why ahah Thanks for your help @topguy!
by rego21
Sat Feb 17, 2018 11:11 am
Forum: General discussion
Topic: UDEV on the last Raspbian
Replies: 6
Views: 706

Re: UDEV on the last Raspbian

Somehow my first rule worked, but dont know how, because i try to plug in and out my usb keyboard and nothing works... I also tried your rule, but no success @topguy...
by rego21
Sat Feb 17, 2018 9:13 am
Forum: General discussion
Topic: UDEV on the last Raspbian
Replies: 6
Views: 706

Re: UDEV on the last Raspbian

Ok gonna give it a try @topguy!
by rego21
Fri Feb 16, 2018 5:48 pm
Forum: General discussion
Topic: UDEV on the last Raspbian
Replies: 6
Views: 706

Re: UDEV on the last Raspbian

@topguy but i cant make a generic udev rule? I´m new with this, can you guide me please?

Go to advanced search