Go to advanced search

by kadamski
Tue Jul 24, 2012 9:23 am
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

That's why i was sceptic about that solving the problem. Please verify if your problem is not USB problem. Check dmesg to see if the card wasn't reset or even turned off. This may be due to power problems for example or some USB bug (USB driver is quite buggy in RPi right now).
by kadamski
Mon Jul 23, 2012 6:08 pm
Forum: Raspbian
Topic: Netsurf Framebuffer
Replies: 8
Views: 5510

Re: Netsurf Framebuffer

It didn't work for me even with framebuffer_ignore_alpha=1 (i only have overscan disabled in config file and some overclock options). I had black screen and nothing more. It started workin however, when i used "-b 16" option to run it, which changes BPP to 16. There are some problems like I don't se...
by kadamski
Mon Jul 23, 2012 5:34 pm
Forum: General discussion
Topic: Is the Raspberry Pi for me?
Replies: 6
Views: 1174

Re: Is the Raspberry Pi for me?

Well, that really depends on you. First of all, Linux is different than Windows in a lot of ways. To use it you would actually need not only to learn new things but also to "unlearn" some old habits. It can be both exciting and painful, depending on how you see it. You don't need RaspberryPi to chec...
by kadamski
Mon Jul 23, 2012 11:40 am
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

Well.. I though that snd-usb-audio provides mmap support without problems. But maybe my config just solves some strange side effect or something.
by kadamski
Mon Jul 23, 2012 11:11 am
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

And your USB card needed MMAP emulation? That's strange..
by kadamski
Mon Jul 23, 2012 10:08 am
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

I'm glad i could help. My config should not be related to the usb card however. Unless you disabled internal soundcard.
by kadamski
Mon Jul 23, 2012 7:02 am
Forum: General discussion
Topic: Shouldn't Rpi developers be payed by the Foundation?
Replies: 36
Views: 4337

Re: Shouldn't Rpi developers be payed by the Foundation?

Remember that RPF is a charity and I believe it doesn't make much profit on RaspberryPi so I don't think they have enough resources to pay developers.
by kadamski
Sun Jul 22, 2012 4:18 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

http://www.raspberrypi.org/phpBB3/viewt ... 25#p125513 Take a look at this post and put configuration I posted there in /etc/asound.conf file (you will need to create this file as root). This should do the trick.
by kadamski
Sun Jul 22, 2012 3:38 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

Code: Select all

mplayer -v  FILE.MP3 >logfile.txt 2>&1
should work. You can also just copy/paste content of terminal. Plase use -v option to mplayer.
by kadamski
Sun Jul 22, 2012 1:46 pm
Forum: General discussion
Topic: Please fix the audio driver
Replies: 14
Views: 4436

Re: Please fix the audio driver

XBMC uses omxplayer which in turn uses direct sound access, without kernel driver. So it's a bug in omxplayer on in firmware.
by kadamski
Sun Jul 22, 2012 11:40 am
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

Right now I have no idea what can be wrong so you can hear .wav files but not .mp3. Could you run vlc from terminal and post all the messages it outputs to the terminal here? I'm don't know vlc that much, could you test the same mp3 with mplayer (from commandline) and also paste all the output here ...
by kadamski
Sun Jul 22, 2012 6:23 am
Forum: General discussion
Topic: Please fix the audio driver
Replies: 14
Views: 4436

Re: Please fix the audio driver

If you are using raspian image from foundation, you should already have this fix installed. Since omxplayer does not use ALSA but "talks" to the sound in more direct way, could you test if you are having similar problems using other playes - mplayer or vlc for example?
by kadamski
Sat Jul 21, 2012 10:07 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

That's a good tip too. Dom fixed this issue just today but it's not in the repository yet.
by kadamski
Sat Jul 21, 2012 10:04 pm
Forum: General discussion
Topic: Please fix the audio driver
Replies: 14
Views: 4436

Re: Please fix the audio driver

This commit was an attempt (successful for me) at fixing this: https://github.com/raspberrypi/firmware/commit/234c19de7cbaaf4997671d61df20a05759066295 It was Jun 24 so all the new OS images should already contain it. Are you using up to date firmware on you Rpi ? Besides, note that all the software ...
by kadamski
Sat Jul 21, 2012 9:56 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

Using speaker-test can get sound to play reasonably from the USB sound, but not from the bcm2835 - the program runs but no sound. I have checked with alsamixer and there is a level set. Which output are you using? HDMI or analog? Did you read and try tips from http://elinux.org/R-Pi_Troubleshooting...
by kadamski
Sat Jul 21, 2012 8:08 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

Icm not surprised, for some reason it doesn't work for me too. I wonder why it's working for Dom.
by kadamski
Sat Jul 21, 2012 7:43 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

Efcis wrote:@Dom @kadamski
Actually, I had to recreate a complete SD from scratch :-( I wonder if I could modify/rename start.elf from the raspi itself in use?
You can modify all the files. Remember not to plug power off just after write. Do proper shutdown so the file is fully written to the SD card.
by kadamski
Sat Jul 21, 2012 7:33 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

There is probably problem with " characters. Replace them typing them manually.
by kadamski
Sat Jul 21, 2012 5:31 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

Do you see colorful test screen or only black screen? Is green led flashing? How many green led flashes do you have? Which OS image are you using?
by kadamski
Sat Jul 21, 2012 5:27 pm
Forum: Other projects
Topic: Simple Ham Radio FM receiver with rtl-sdr
Replies: 26
Views: 58693

Re: Simple Ham Radio FM receiver with rtl-sdr

5.3 V is out of spec too. So now you have to much voltage! As for underruns, it is possible that rtl_fm is just not able to deliver sound fast enough. There may be some buffering issues - it may buffer too much data before sending it to stdout and aplay has no data to play, thus underrun messages.
by kadamski
Sat Jul 21, 2012 5:07 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

Tested, can't reproduce the problem anymore. How about you @Efcis ? This should probably close the https://github.com/raspberrypi/firmware/issues/62
by kadamski
Sat Jul 21, 2012 4:32 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

That's true. I'm trying to figure that out right now. I found out that 10 s is a timeout for draining to finish (using schedule_timeout_interruptible). I'll be back with more details about this problem. I'm very curious why asoundrc trick fixes that for you but not for me, however. BTW, there are a ...
by kadamski
Sat Jul 21, 2012 4:09 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

For now, I was only able to find out that the 10s wait is on a SNDRV_PCM_IOCTL_DRAIN ioctl.
by kadamski
Sat Jul 21, 2012 3:49 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

Actually the output audio buffer is 32-bits per sample, and stereo (whatever the input size). So >16K of 16-bit stereo is going to lockup. So, 32K is being sent before the start command? I think that should lockup. Once the start command has been sent, there's no lockup but the bulk queue transmit ...
by kadamski
Sat Jul 21, 2012 3:10 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 169165

Re: ALSA on Raspbian

But am I right about the implementation of the blocking? It uses semaphore that us upped after DMA copy has occurred? Where in code does this up happen? Is it from notify_bulks? And what calls notify_bulks? Thank you for clarifications.

Go to advanced search