Go to advanced search

by kadamski
Thu Sep 13, 2012 12:08 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 168790

Re: ALSA on Raspbian

Well, not really HUB problem but RPi USB stack. Using other HUB may (or may not) help, however.
by kadamski
Thu Sep 13, 2012 9:38 am
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 168790

Re: ALSA on Raspbian

First, try it without hub. And also check if you are having similar error messages in dmesg when no other USB devices are connected. You could repost your dmesg output here in this scenario. Please connect only keyboard, without USB hub and test everything in such configuration, before starting X se...
by kadamski
Thu Sep 13, 2012 9:11 am
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 168790

Re: ALSA on Raspbian

Ok so I didn't understand you at first. Could you test this when everything except soundcard is disconnected from USB (including USB hub)? Ideally, you should use SSH for this. But if this is a problem, you can try connecting keyboard after everything has finished booting.
by kadamski
Thu Sep 13, 2012 6:16 am
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 168790

Re: ALSA on Raspbian

It shouldn't matter if ALSA is already loaded or not when USB device is detected. And if I understand your situation correctly, the card works OK without unplugging after full power cycle, right?
by kadamski
Wed Sep 12, 2012 10:01 am
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 168790

Re: ALSA on Raspbian

Keep in mind that It's just a suggestion and I don't really know if my assumptions about rebooting are correct.
by kadamski
Wed Sep 12, 2012 8:30 am
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 168790

Re: ALSA on Raspbian

I believe it's not ALSA nor USB detection problem. It seems to me that the card have problem with resetting itself when RPi is rebooted. I may be wrong at this but it may require power cycle when rebooting the system to properly initialize and I believe it is not happening on RPi unless you do full ...
by kadamski
Wed Sep 12, 2012 7:52 am
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 168790

Re: ALSA on Raspbian

So the problem only occur after rebooting RaspberryPI, right?
by kadamski
Wed Sep 12, 2012 6:41 am
Forum: Advanced users
Topic: dynamic memory split
Replies: 16
Views: 4587

Re: dynamic memory split

I acctualy is technicaly possible. @dom was working on it some time ago, you can read about it here. Then @jamesh even said that it is almost ready here. I believe it doesn't have big priority but it may eventually be available. @dom is probably the one who knows this best.
by kadamski
Tue Aug 28, 2012 8:16 am
Forum: Linux Kernel
Topic: Hard Float kernel for Rasbrian
Replies: 5
Views: 3469

Re: Hard Float kernel for Rasbrian

Yes, greping kernel sources one can find that floats are only used in x86 specific code and raid6 implementation.
by kadamski
Thu Aug 23, 2012 7:28 am
Forum: Linux Kernel
Topic: How do I replace/change the kernel for the PI?
Replies: 2
Views: 7372

Re: How do I replace/change the kernel for the PI?

Replacing one file on boot partition is not enough. It will let you boot but you won't have kernel modules loaded. They should be copied too.
by kadamski
Thu Aug 23, 2012 7:27 am
Forum: Linux Kernel
Topic: Kernel recompile does not support mouse/kb in X
Replies: 2
Views: 1489

Re: Kernel recompile does not support mouse/kb in X

It seems for me that you forgot about kernel modules. You have to copy them too, not only kernel.img. X server need some kernel modules (evdev, IIRC) to use mouse/keyboard device. Your kernel modules have to always match kernel image. You should have couple of them loaded after system has started. C...
by kadamski
Thu Aug 23, 2012 7:21 am
Forum: Linux Kernel
Topic: Hard Float kernel for Rasbrian
Replies: 5
Views: 3469

Re: Hard Float kernel for Rasbrian

That's not entirely true. Floats can be used inside of kernel but their usage is discouraged (as there is no good way to do it cross platform) . Also it is used in a very specific way which is independent from the float ABI so it doesn't matter if you are using hardfp or softfp compiler. softfp comp...
by kadamski
Tue Aug 21, 2012 7:45 am
Forum: General discussion
Topic: Use initramfs?
Replies: 58
Views: 42003

Re: Use initramfs?

In theory, the upper limit would be something like avail_memory-compressed_initramfs_size-uncompressed_initramfs_size-8MB but I didn't test that. avail_memory depends on the memory split you have chosen.
by kadamski
Fri Aug 17, 2012 7:44 am
Forum: Troubleshooting
Topic: YA sound problem
Replies: 1
Views: 556

Re: YA sound problem

Try the solution form this post.
by kadamski
Fri Aug 17, 2012 7:36 am
Forum: Troubleshooting
Topic: Eth fail: Xfi Surrond 5.1 USB device & Dell U2412M powerhub
Replies: 1
Views: 509

Re: Eth fail: Xfi Surrond 5.1 USB device & Dell U2412M power

First of all it would be good to test if it's a problem when you connect third device to USB hub or if it's a problem when you connect one particular device. Then it would be good idea to test the voltage between TP1 and TP2 to see if it's in spec (4.75V to 5.25V) after connecting each device. Then ...
by kadamski
Thu Aug 16, 2012 5:35 pm
Forum: Raspbian
Topic: Downloading by Midori?
Replies: 2
Views: 808

Re: Downloading by Midori?

I do have problems with downloads on Midori. It sometimes just hangs at 0% creating empty file on disc. I can't even cancel this download. It's not always the case - if it starts properly (write any data to disc) then it will finish properly. I had no time to investigate this, I'm just using wget in...
by kadamski
Thu Aug 16, 2012 7:08 am
Forum: General discussion
Topic: Use initramfs?
Replies: 58
Views: 42003

Re: Use initramfs?

This one should be working. It will drop you to shell and nothing else but it should be enough for testing. https://dl.dropbox.com/u/37803348/init.gz
by kadamski
Fri Aug 10, 2012 1:36 pm
Forum: Raspbian
Topic: No sound from on-board card
Replies: 10
Views: 7582

Re: No sound from on-board card

You can choose where sound should be outputed (HDMI or analog) using amixer command, see http://elinux.org/R-Pi_Troubleshooting#Sound_does_not_work_at_all.2C_or_in_some_applications . Note that you have some problems with your /etc/asound.conf as it can't be parsed, it's probably some problem with w...
by kadamski
Mon Aug 06, 2012 7:17 am
Forum: General discussion
Topic: Use initramfs?
Replies: 58
Views: 42003

Re: Use initramfs?

There are some troubleshooting led flashes that can tell you what went wrong but there is no more than 6 flashes: http://elinux.org/R-Pi_Troubleshooting#Red_power_LED_is_on.2C_green_LED_does_not_flash.2C_nothing_on_display So i don't really know what can be wrong in your situation. The only thing I ...
by kadamski
Mon Jul 30, 2012 8:59 am
Forum: General discussion
Topic: Use initramfs?
Replies: 58
Views: 42003

Re: Use initramfs?

You should have recent start.elf, your kernel should have CONFIG_BLK_DEV_INITRD=y (AFAIK kernel from github does not support this, you have to compile your own kernel). I'm using "initramfs <file>" file option and I don't remember if ramfsfile is working too. No additional kernel parameters are need...
by kadamski
Sun Jul 29, 2012 7:41 am
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 168790

Re: ALSA on Raspbian

While this is working for mplayer, it may not work for other applications. This is why later I posted even better solution in this post: http://www.raspberrypi.org/phpBB3/viewt ... 25#p125513
by kadamski
Wed Jul 25, 2012 8:20 am
Forum: Raspbian
Topic: Netsurf Framebuffer
Replies: 8
Views: 5506

Re: Netsurf Framebuffer

I'm still intrested what does "not set the alpha the way we want it" means and why isn't it working in 24 bit. Maybe it's worth investigating. Dom?
by kadamski
Tue Jul 24, 2012 6:22 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 168790

Re: ALSA on Raspbian

I'm not sure what is the preffered way. I'm just downloading files manually from github. Since I don't think it has anything to do with kernel (it wasn't loaded yet), you only have to check bootcode.bin and loader.bin. They are not updated to often and Icm not really sure how much are.they dependent...
by kadamski
Tue Jul 24, 2012 5:59 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 168790

Re: ALSA on Raspbian

And you are sure the file is not currupted or anything? Those fat on boot partition likes to be corrupted. And are all other firmware files up to date?
by kadamski
Tue Jul 24, 2012 3:40 pm
Forum: Raspbian
Topic: ALSA on Raspbian
Replies: 167
Views: 168790

Re: ALSA on Raspbian

What you mean? Does it stop on black screen or on colorful one? Do you overclock your pi?

Go to advanced search