Go to advanced search

by epoch1970
Sun Jul 10, 2016 4:12 pm
Forum: Troubleshooting
Topic: Jessie not showning advanced messages like wheezy
Replies: 8
Views: 1066

Re: Jessie not showning advanced messages like wheezy

Ok, 2 workarounds then: a) OpenVPN seems to run by default with a status file defined in /run/openvpn/<conf_name>.status. You could parse that. b) This is really beyond me but, if you copy /etc/init.d/openvpn under another name, e.g. "/usr/local/bin/foo.sh" and have in your tunnel conf file a line t...
by epoch1970
Sun Jul 10, 2016 3:29 pm
Forum: Networking and servers
Topic: Secure VPN
Replies: 2
Views: 512

Re: Secure VPN

Welcome. I would look at how the router / networking gear is protected against physical access on that site. If it isn't, then having the Pi stark naked next to them will be just good enough... (because of the DoS or MitM things) If the networking gear is deemed secured, then simply move the Pi to t...
by epoch1970
Sun Jul 10, 2016 11:37 am
Forum: Raspbian
Topic: Help, I did a mistake - Corrupted XAuthority
Replies: 13
Views: 1915

Re: Help, I did a mistake - Corrupted XAuthority

Kuroma wrote:What files does a tty auto login ?
According to the source of raspi-config here auto login is defined either in /etc/inittab or in /etc/systemd/system/getty.target.wants/

I wouldn't mess with inittab, it's a sure way to make a machine unusable...
by epoch1970
Sat Jul 09, 2016 6:08 pm
Forum: General discussion
Topic: Having problems with Huawei E173
Replies: 2
Views: 1463

Re: Having problems with Huawei E173

Not sure, esp. about the usb-modeswitch thing, but I see your are using ATTRS and not ATTR. ATTR S and KERNEL S , SUBSYTEM S ... will match parent devices, not the device itself. Unfortunately, I *think* there is a limit to the distance between the device subject of the current rule and a matched pa...
by epoch1970
Sat Jul 09, 2016 5:30 pm
Forum: Advanced users
Topic: RPI 2 version 1.1 not connect to the Internet with wireless
Replies: 22
Views: 2452

Re: RPI 2 version 1.1 not connect to the Internet with wire

You have 2 default routes pointing to 192.168.1.1 active at the same time. That's no good. (The one on eth0 has a lower metric but I am unsure how this is taken into account in routing.) Your resolv.conf is decent, except "search 8.8.4.4" is not correct. The correct form is "search domain_name". Jus...
by epoch1970
Sat Jul 09, 2016 5:14 pm
Forum: Raspbian
Topic: Help, I did a mistake - Corrupted XAuthority
Replies: 13
Views: 1915

Re: Help, I did a mistake ;--;

Welcome. I suppose you've tried ctrl-alt-f1, ctrl-alt-f2... ctrl-alt-f7 to cycle through the available consoles already (I don't know how many ttys are created in NOOBS, or even in Raspbian) Also, in a graphical console, ctrl-alt-backspace (not del) usually kills X, you can try that but perhaps you ...
by epoch1970
Sat Jul 09, 2016 4:33 pm
Forum: Troubleshooting
Topic: Keyboard layout changes back to UK - USB problem?
Replies: 3
Views: 750

Re: Keyboard layout changes back to UK - USB problem?

Welcome and congratulations on a well articulated first post! I'm afraid I don't have enough expertise to give you a straight answer, but I will share this: My hypothesis is that you have devices behind a hub behind a hub, and when the bridge is removed (the screen's hub disconnects) individual disc...
by epoch1970
Sat Jul 09, 2016 1:43 pm
Forum: Troubleshooting
Topic: Terminal access for new user
Replies: 2
Views: 397

Re: Terminal access for new user

Welcome. This new user doesn't look like a full-fledged user, it probably has permission issues with starting services etc. I don't know how you created that user; I don't use the Raspbian GUI so I don't know if there is an utility available to create a user. - If there is, I'd advise to use that an...
by epoch1970
Sat Jul 09, 2016 1:30 pm
Forum: Advanced users
Topic: RPI 2 version 1.1 not connect to the Internet with wireless
Replies: 22
Views: 2452

Re: RPI 2 version 1.1 not connect to the Internet with wire

Are you expecting a lot of responses from a post like this?
No info and just links is useless to this forum and its current and future users.
by epoch1970
Sat Jul 09, 2016 1:26 pm
Forum: Troubleshooting
Topic: Jessie not showning advanced messages like wheezy
Replies: 8
Views: 1066

Re: Jessie not showning advanced messages like wheezy

Systemd, the Jessie replacement for init.d, is a bit shy... You can use commands "service xxx status" and also "journalctl" to get more info.
by epoch1970
Fri Jul 08, 2016 7:43 pm
Forum: Troubleshooting
Topic: Accessing PI remotely
Replies: 6
Views: 774

Re: Accessing PI remotely

Pressing ctrl-alt-del on a keyboard connected to the Pi should command orderly shutdown and reboot.
The long term solution is to install networking and use ssh from another computer, I guess.
by epoch1970
Fri Jul 08, 2016 6:40 pm
Forum: Networking and servers
Topic: OpenVPN log OptionsError
Replies: 1
Views: 496

Re: OpenVPN log OptionsError

Welcome. This says the local openvpn process cannot find the certificates and keys that are specified in the configuration file. Indeed, files named "XX.something" look a bit suspicious... You have generated, somehow, a cert/key pair. Find where these files are (and their name), and then edit the op...
by epoch1970
Fri Jul 08, 2016 6:21 pm
Forum: Français
Topic: Carte SD et perfromances
Replies: 8
Views: 1329

Re: Carte SD et perfromances

Cool !
by epoch1970
Fri Jul 08, 2016 6:14 pm
Forum: Troubleshooting
Topic: SSH not working (WIFI)
Replies: 8
Views: 1119

Re: SSH not working (WIFI)

If you reboot the tunable returns to what its default value... You can persist the value in /etc/sysctl.conf or another conf file in /etc/sysctl.d/ I'm so sorry, but I don't understand what are you referring to. All the configuration changes I made are persistent because I made them in the config f...
by epoch1970
Fri Jul 08, 2016 12:48 pm
Forum: Media centres
Topic: Pi 3 + Plex + Chromecast
Replies: 5
Views: 3413

Re: Pi 3 + Plex + Chromecast

Would it also make a difference if i would move the plex application support dir from the SDCard to the HDD? and then adapting "PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR" ? I guess that would move the DB over the USB drive? I haven't done that (I wanted "pure" data drives) but that might be worth t...
by epoch1970
Fri Jul 08, 2016 12:42 pm
Forum: General discussion
Topic: USB ethernet gigabit adapter
Replies: 16
Views: 11774

Re: USB ethernet gigabit adapter

I decided to run a test too and post it here, at least I will be able to get back to it when I need :) Test using iperf between a Pi 3 and a VM in a server. 2 physical switches + 2 bridges in the path (+ misc.). Freshly booted, very light load on both machines. On the Pi 3, the USB adapter uses an A...
by epoch1970
Thu Jul 07, 2016 7:23 pm
Forum: Troubleshooting
Topic: SSH not working (WIFI)
Replies: 8
Views: 1119

Re: SSH not working (WIFI)

If you reboot the tunable returns to what its default value...
You can persist the value in /etc/sysctl.conf or another conf file in /etc/sysctl.d/
by epoch1970
Thu Jul 07, 2016 12:11 pm
Forum: Troubleshooting
Topic: SSH not working (WIFI)
Replies: 8
Views: 1119

Re: SSH not working (WIFI)

The internet seems to point at a path MTU discovery issue... Does SSH work with ethernet and not with wifi?
On my machine "cat /proc/sys/net/ipv4/tcp_mtu_probing" returns 0, you can enable it with "echo 2 > /proc/sys/net/ipv4/tcp_mtu_probing"
by epoch1970
Thu Jul 07, 2016 11:44 am
Forum: Media centres
Topic: Pi 3 + Plex + Chromecast
Replies: 5
Views: 3413

Re: Pi 3 + Plex + Chromecast

Welcome. It's better to avoid wifi and prefer ethernet for the server. If the drive sleeps, you can expect to wait for a little while. If seek works poorly, either network bandwidth isn't good (wifi), or the system transcodes. When it transcodes it uses a scratch directory to output the transcoded s...
by epoch1970
Thu Jul 07, 2016 11:35 am
Forum: Troubleshooting
Topic: External HDD unmounts on its own
Replies: 5
Views: 1304

Re: External HDD unmounts on its own

You should look at the specs of the HDD. If it is old enough as 500GB capacity seems to indicate, it might consume too much power for a single USB port. Some drives/enclousures used to come with "Y-cables" that would allow to draw power from 2 USB ports. USB2HAUBYX.main.jpg In addition 5V/1A power i...
by epoch1970
Thu Jul 07, 2016 11:14 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: udev rule file device re-mapping
Replies: 2
Views: 899

Re: udev rule file device re-mapping

Udev behavior changed years ago (to the worse IMHO). The following keys can get values assigned: NAME The name to use for a network interface. See systemd.link(5) for a higher-level mechanism for setting the interface name. The name of a device node cannot be changed by udev, only additional symlink...
by epoch1970
Wed Jul 06, 2016 4:08 pm
Forum: Troubleshooting
Topic: iphone 5 tethering on raspberry pi 3
Replies: 3
Views: 3825

Re: iphone 5 tethering on raspberry pi 3

Out of curiosity I tried this with an iPhone SE, should be close enough to a 5. Using Raspbian Lite: - apt-get install usbmuxd - connect the phone w/ hotspot started - the phone asks you if you want to trust the computer, say yes (otherwise I think you don't get access to the hotspot network) - ifco...
by epoch1970
Wed Jul 06, 2016 10:29 am
Forum: Troubleshooting
Topic: FSCK /dev/bbcblk0p1 returns Dirty bit se
Replies: 1
Views: 368

Re: FSCK /dev/bbcblk0p1 returns Dirty bit se

I would advise to look at both first and last posts in an old thread like that. Right now looking at a Pi 3 running an up-to-date Raspbian Lite install I see $ dpkg -l | grep dosfstools ii dosfstools 3.0.27-1 armhf utilities for making and checking MS-DOS FAT filesystems That version is later than a...
by epoch1970
Wed Jul 06, 2016 10:08 am
Forum: Raspbian
Topic: Pi3 and Watchdog ping issue
Replies: 1
Views: 1189

Re: Pi3 and Watchdog ping issue

I have posted recently about my use of watchdog with Raspbian. I found that pinging every 10 secs or less was not desirable, so instead I decided to setup watchdog to watch a file that gets refreshed more slowly by an external ping deamon. That ping daemon is launched by systemd. Since the daemon is...
by epoch1970
Wed Jul 06, 2016 9:19 am
Forum: Advanced users
Topic: Connot connect to www.google.com thru openvpn
Replies: 1
Views: 504

Re: Connot connect to www.google.com thru openvpn

You could dig, traceroute, and wget that should help debug the issue.
Perhaps there is something going on with HTTPS?
Are you using TCP or UDP for the tunnel? TCP over TCP can be troublesome. It would be better to use UDP for OpenVPN.

Go to advanced search