Go to advanced search

by wallarug
Wed May 29, 2013 10:07 pm
Forum: Python
Topic: RPi Camera Python Module
Replies: 13
Views: 11147

Re: RPi Camera Python Module

You have a missing bracket at the end of both your 'call' commands, that could be causing problems. Dave. that was just a problem with copying the code across... I do have brackets in my code and the call() function works. The problem seems to be with the IF IF commands. The camera does what it wan...
by wallarug
Wed May 29, 2013 12:49 pm
Forum: Camera board
Topic: STICKY: Foundation (old) Camera Board information
Replies: 443
Views: 279296

Re: Foundation Camera Board information

jamesh wrote:apt-get should do it.
Ok, done that now.

How can I tell if it is working as expected?
by wallarug
Wed May 29, 2013 12:38 pm
Forum: Camera board
Topic: Default still image size is not using the whole sensor
Replies: 16
Views: 8358

Re: Default still image size is not using the whole sensor

Jamesh informed here that it has been fixed as of last Friday:

http://www.raspberrypi.org/phpBB3/viewt ... 2&e=359042
by wallarug
Tue May 28, 2013 10:24 pm
Forum: Camera board
Topic: STICKY: Foundation (old) Camera Board information
Replies: 443
Views: 279296

Re: Foundation Camera Board information

Yes, 10k. Problems with demand predictions but also actually getting enough parts. 9900 or so were actually released I think - 80-100 kept back for testing/Foundation use. Production is being ramped, but again, parts supply may cause delays. How are software improvements going? i) Frame rate above ...
by wallarug
Tue May 28, 2013 10:23 pm
Forum: Camera board
Topic: STICKY: Foundation (old) Camera Board information
Replies: 443
Views: 279296

Re: Foundation Camera Board information

9900 or so were actually released I think - 80-100 kept back for testing/Foundation use. Production is being ramped, but again, parts supply may cause delays. Wow, I thought there would be more, so I feel lucky to have got one. I am looking forward to getting a few more, so I will feel better about...
by wallarug
Tue May 28, 2013 11:21 am
Forum: Camera board
Topic: STICKY: Foundation (old) Camera Board information
Replies: 443
Views: 279296

Re: Foundation Camera Board information

Yes, 10k. Problems with demand predictions but also actually getting enough parts. 9900 or so were actually released I think - 80-100 kept back for testing/Foundation use. Production is being ramped, but again, parts supply may cause delays. How are software improvements going? i) Frame rate above ...
by wallarug
Sun May 26, 2013 9:06 am
Forum: Python
Topic: RPi Camera Python Module
Replies: 13
Views: 11147

Re: RPi Camera Python Module

I am having a little problem here: My Program is randomly choosing what it wants to do: #!/usr/bin/env python import RPi.GPIO as GPIO from subprocess import call from time import sleep GPIO.setmode(GPIO.BCM) GPIO.setup(23, GPIO.IN) # Green Light, still GPIO.setup(24, GPIO.IN) # Yellow Light, video i...
by wallarug
Wed May 22, 2013 12:52 pm
Forum: Camera board
Topic: Using VLC to stream from the camera - Help needed
Replies: 166
Views: 161560

Re: Using VLC to stream from the camera - Help needed

Surfinger wrote:Yep! Tryed it right now. Only Pi+Ethernet.

Same result as before. Btw. Images work.
so you are having a problem with just normal video from the camera? which means that the network stream isn't working?
by wallarug
Wed May 22, 2013 12:32 pm
Forum: Camera board
Topic: Using VLC to stream from the camera - Help needed
Replies: 166
Views: 161560

Re: Using VLC to stream from the camera - Help needed

Hi, it seems that you don't have enough power for your Raspberry Pi. The USB hub provides 500mA max. If you have a USB charger for some other device (Kindle, Android phone/tablet etc.) - try with that. Regards! Sorry i forgot. The pi has got it's own power supply (i think its 1.2A) - And the USB Hu...
by wallarug
Wed May 22, 2013 9:00 am
Forum: Camera board
Topic: Using VLC to stream from the camera - Help needed
Replies: 166
Views: 161560

Re: Using VLC to stream from the camera - Help needed

vlc (running on PC) does not want to open the stream... :( :( :( :( Once VLC has run out of video to stream I suspect its closing the network connection. Does the raspicam preview window open up on the HDMI output to confirm that video is being captured? yes. I will look at tomorrow though. We can'...
by wallarug
Wed May 22, 2013 8:58 am
Forum: Camera board
Topic: Using VLC to stream from the camera - Help needed
Replies: 166
Views: 161560

Re: Using VLC to stream from the camera - Help needed

wallarug wrote:vlc (running on PC) does not want to open the stream... :( :( :( :(

looks like a job for tomorrow. I did get http stream working in th end but not rtsp.

I will try and see what I can do tomorrow.
by wallarug
Wed May 22, 2013 8:43 am
Forum: Camera board
Topic: Using VLC to stream from the camera - Help needed
Replies: 166
Views: 161560

Re: Using VLC to stream from the camera - Help needed

vlc (running on PC) does not want to open the stream... :( :( :( :(
by wallarug
Wed May 22, 2013 8:39 am
Forum: Camera board
Topic: Using VLC to stream from the camera - Help needed
Replies: 166
Views: 161560

Re: Using VLC to stream from the camera - Help needed

That wasn't to hard:

I fixed the raspivid so it now works for user 'pi'

Code: Select all

sudo chmod 777 /dev/vchiq
moving onto video stream now.
by wallarug
Wed May 22, 2013 8:21 am
Forum: Camera board
Topic: Using VLC to stream from the camera - Help needed
Replies: 166
Views: 161560

Re: Using VLC to stream from the camera - Help needed

You might have missed this one... or be reading it now :lol: EDIT2: I think I worked it out. I created a user called 'pi' on the pwnpi OS. I don't think this user has any privlages. That is why it can't access the camera and the 'root' user can. I was running vlc under the 'pi' user with no camera p...
by wallarug
Wed May 22, 2013 8:10 am
Forum: Camera board
Topic: Using VLC to stream from the camera - Help needed
Replies: 166
Views: 161560

Re: Using VLC to stream from the camera - Help needed

Same result: [0x1d63a08] main playlist debug: changing item without a request (current 0/1) [0x1d63a08] main playlist debug: nothing to play ...with both http and rtsp is there some other package that I should have installed? I am running this on pwnpi3 (which seems ok since it is just raspbain with...
by wallarug
Wed May 22, 2013 7:57 am
Forum: Camera board
Topic: Using VLC to stream from the camera - Help needed
Replies: 166
Views: 161560

Re: Using VLC to stream from the camera - Help needed

no luck there either.

here is what I put into the command line:

Code: Select all

raspivid -o - -t 99999999 |cvlc -vvv stream:///dev/stdin --sout '#rtp{sdp=rtsp://:8554/}' :demux=h264
I have the camera connected correctly (tested) and its connected to the network.
by wallarug
Wed May 22, 2013 7:55 am
Forum: Camera board
Topic: Using VLC to stream from the camera - Help needed
Replies: 166
Views: 161560

Re: Using VLC to stream from the camera - Help needed

no luck here :( Here is the ouput from the console. [email protected]:~$ [email protected]:~$ raspivid -o - -t 99999 |cvlc -vvv stream:///dev/stdin --sout will do. hang a minute while I try. This timeout equates to around 1.5 minutes [0x1d74980] main input debug: `stream:///dev/stdin' successfully opened [0x1d74980]...
by wallarug
Wed May 22, 2013 7:47 am
Forum: Camera board
Topic: Using VLC to stream from the camera - Help needed
Replies: 166
Views: 161560

Re: Using VLC to stream from the camera - Help needed

no luck here :( Here is the ouput from the console. [0x310ff0] main stream debug: no stream_filter module matching "any" could be loaded [0x310ff0] main stream debug: TIMER module_need() : 28.675 ms - Total 28.675 ms / 1 intvls (Avg 28.675 ms) [0x310ff0] main stream debug: looking for stream_filter ...
by wallarug
Mon May 20, 2013 11:35 pm
Forum: Camera board
Topic: Using VLC to stream from the camera - Help needed
Replies: 166
Views: 161560

Re: Using VLC to stream from the camera - Help needed

texy wrote:Yeah - that works !
Texy
Could you publish some clear instructions on what you did?

I am very interested in vlc streaming from Pi.
by wallarug
Mon May 20, 2013 12:11 pm
Forum: Camera board
Topic: STICKY: Foundation (old) Camera Board information
Replies: 443
Views: 279296

Re: Foundation Camera Board information

I found the following in mmal_param_convert.c, and I'm guessing those are our encoding options: static string_pair_t video_codec_enums[] = { { "h264", MMAL_ENCODING_H264 }, { "h263", MMAL_ENCODING_H263 }, { "mpeg4", MMAL_ENCODING_MP4V }, { "mpeg2", MMAL_ENCODING_MP2V }, { "vp8", MMAL_ENCODING_VP8 }...
by wallarug
Mon May 20, 2013 11:20 am
Forum: Camera board
Topic: My Camera arrived today... what now?
Replies: 108
Views: 28730

Re: My Camera arrived today... what now?

When I started a stream to Windows the lag was about a second in the beginning but was reduced later to almost zero. What can help is use the mouse wheel in MPlayer to change the lag, strange as this may seem. but which way? When I used the mouse wheel, it made it more laggy. So are you telling me ...
by wallarug
Sun May 19, 2013 12:59 pm
Forum: Camera board
Topic: My Camera arrived today... what now?
Replies: 108
Views: 28730

Re: My Camera arrived today... what now?

When I started a stream to Windows the lag was about a second in the beginning but was reduced later to almost zero. What can help is use the mouse wheel in MPlayer to change the lag, strange as this may seem. but which way? When I used the mouse wheel, it made it more laggy. So are you telling me ...
by wallarug
Sun May 19, 2013 12:10 pm
Forum: Camera board
Topic: My Camera arrived today... what now?
Replies: 108
Views: 28730

Re: My Camera arrived today... what now?

When stream from Pi to an Ubuntu box using ethernet, the latency is a couple of frames - you cannot really see the difference. I blame Windows...with a helping hand from wireless networking. I have Pi connect to ethernet... so wireless networking is not the problem here. Windows Might be the proble...
by wallarug
Sun May 19, 2013 11:36 am
Forum: Camera board
Topic: Default still image size is not using the whole sensor
Replies: 16
Views: 8358

Re: Default still image size is not using the whole sensor

psergiu wrote:You just found RPi's "uncrop" function. :lol:

http://www.youtube.com/watch?v=KUFkb0d1kbU

Great Find! :D
by wallarug
Sun May 19, 2013 10:43 am
Forum: Camera board
Topic: My Camera arrived today... what now?
Replies: 108
Views: 28730

Re: My Camera arrived today... what now?

I followed the instructions to get the video stream working between the raspicam and my Windows PC. It seemed to always be delayed... How can I make it LIVE / Real-time? This may be an Mplayer issue as I've beem able to vary the lag using the mouse wheel in Mplayer..... See my post #28 here: http:/...

Go to advanced search