Go to advanced search

by ksharindam
Sun Nov 18, 2018 5:34 pm
Forum: Raspbian
Topic: [Solved] Failed to clone a running raspbian stretch system
Replies: 7
Views: 1526

Re: Failed to clone a running raspbian stretch system

Finally I have found the problem.
running sudo fdisk -l shows message "Partition table entries are not in disk order".
There was some problem in partitioning. So i deleted all partitions and recreated them. then copied all files using the script.
Problem solved !
by ksharindam
Sun Nov 18, 2018 4:53 pm
Forum: Raspbian
Topic: [Solved] Failed to clone a running raspbian stretch system
Replies: 7
Views: 1526

Re: Failed to clone a running raspbian stretch system

I am not using dd command to clone the card, I am using cp command to copy all files of the partitions (see my script). So copying from larger to smaller sdcard should not create problem. And I am copying from 16GB card to 16GB card.
I did not get any error or warning in console.
by ksharindam
Sun Nov 18, 2018 3:20 pm
Forum: Raspbian
Topic: [Solved] Failed to clone a running raspbian stretch system
Replies: 7
Views: 1526

Re: Failed to clone a running raspbian stretch system

fruitoftheloom wrote:
Sun Nov 18, 2018 3:08 pm
Why not use Raspbian Stretch with Desktop built in SD Card Copier utility, it clones a running OS to an SD Card in a USB SDHC Card Reader.
I have to try that as last option.

But my question is why my method is not working now, though it worked for last 5 times?
by ksharindam
Sun Nov 18, 2018 2:41 pm
Forum: Raspbian
Topic: Bash Scripts and xterm error.
Replies: 5
Views: 3684

Re: Bash Scripts and xterm error.

Check if xterm package exists.
Run

Code: Select all

dpkg -l | grep xterm
and see if you get any output.

If xterm package does not exist , install it

Code: Select all

sudo apt install xterm
by ksharindam
Sun Nov 18, 2018 2:30 pm
Forum: Raspbian
Topic: [Solved] Failed to clone a running raspbian stretch system
Replies: 7
Views: 1526

[Solved] Failed to clone a running raspbian stretch system

I am trying to clone a running Rasbian stretch to another new sdcard. I am doing this by creating three partitions boot, root and home. I am copying root by running this picopy.sh script inside the root partition of new sdcard. #!/bin/bash # Open terminal # Change directory to the folder where root ...
by ksharindam
Fri Nov 09, 2018 9:58 am
Forum: Raspbian
Topic: Duplicate an image using Win32DiskImager doesn't work
Replies: 13
Views: 1766

Re: Duplicate an image using Win32DiskImager doesn't work

[*]I took the other, identical SD card and used again Win32DiskImager to write the image from the other SD card onto the new one. When the write action started, Win32DiskImager warned me that the image to be written on the new SD card was too big but that the part that couldn't be written was not c...
by ksharindam
Fri Nov 09, 2018 3:32 am
Forum: Raspbian
Topic: Sometimes wlan0 interface does not come up when I insert wifi adapter
Replies: 2
Views: 390

Re: Sometimes wlan0 interface does not come up when I insert wifi adapter

I have solved the problem by replacing the /lib/dhcpcd/dhcpcd-hooks/10-wpa_supplicant file with the older version from jessie.
It seems there is a problem in wpa_supplicant_start() function in stretch version of 10-wpa_supplicant file.
by ksharindam
Mon Nov 05, 2018 2:29 am
Forum: Raspbian
Topic: Sometimes wlan0 interface does not come up when I insert wifi adapter
Replies: 2
Views: 390

Sometimes wlan0 interface does not come up when I insert wifi adapter

Sometimes wlan0 interface does not come up when I insert wifi adapter in Raspberry Pi 2. Then I have to manually run sudo ifconfig wlan0 up to start wifi. It is somewhat random. I could not find a way to reproduce it. This problem was not in Jessie. When I replace the latest version of dhcpcd5 with ...
by ksharindam
Wed Oct 24, 2018 4:45 pm
Forum: Raspbian
Topic: A light web browser !!!
Replies: 8
Views: 7434

Re: A light web browser !!!

Very good information.
But you can also try this PyQt Webkit based browser...
https://github.com/ksharindam/quartz-browser-qt5
by ksharindam
Fri Oct 19, 2018 2:51 am
Forum: Beginners
Topic: will Raspberry Pi 3 fry if i use a 5V/850mA power supply?
Replies: 8
Views: 965

Re: will Raspberry Pi 3 fry if i use a 5V/850mA power supply?

Using underpowered Raspberry pi will not make any damage to the raspberry pi. It will fry the raspberry pi only if the output voltage is greater than 5.25 V. I used a 700mA power supply for my raspberry pi 2 for a long time. If you connect power hungry device (such as USB modem) through USB port of ...
by ksharindam
Sat Oct 13, 2018 7:53 am
Forum: Raspbian
Topic: [Unofficial announcement] Raspbian - October 2018 version
Replies: 17
Views: 2962

Re: [Unofficial announcement] Raspbian - October 2018 version

oguime wrote:
Sat Oct 13, 2018 1:27 am
Is ffmpeg with hw acceleration installed on Stretch lite?
ffmpeg is not installed by default in stretch lite. but if you install it using apt-get, you will get hw-accleration enabled ffmpeg.

BTW, hw-accleration support on ffmpeg was already added more than 8 months ago, not in this release.
by ksharindam
Tue Sep 18, 2018 4:42 pm
Forum: Raspbian
Topic: raspbian stretch and second enviroment e17
Replies: 6
Views: 805

Re: raspbian stretch and second enviroment e17

It seems installing e17 package only provides the window manager, and not the session or desktop. So you can not start enlightenment session.
by ksharindam
Tue Sep 18, 2018 1:48 pm
Forum: Raspbian
Topic: raspbian stretch and second enviroment e17
Replies: 6
Views: 805

Re: raspbian stretch and second enviroment e17

To boot to e17 directly you have to select e17 as default x-session-manager. To do this run this command

Code: Select all

sudo update-alternatives --config x-session-manager
and select e17.
Then reboot.
by ksharindam
Thu Sep 13, 2018 5:54 pm
Forum: Graphics programming
Topic: How to install qtwebengine5-dev?
Replies: 8
Views: 6902

Re: How to install qtwebengine5-dev?

You should post in raspbian forum.
by ksharindam
Tue Sep 11, 2018 3:46 pm
Forum: Graphics programming
Topic: Use opencv mat data to create dispmanx resource
Replies: 1
Views: 3444

Re: Use opencv mat data to create dispmanx resource

Finally found it by myself. Each rows of cv mat data is aligned to 4. But the pitch of image buffer for dispmanx is needed to be multiple of 16. Thats why we can not directly use mat.data for the resource buffer. We have to allocate a data of pitch*height. and copy each row of cv::mat to that alloca...
by ksharindam
Sun Sep 09, 2018 7:22 am
Forum: Graphics programming
Topic: Use opencv mat data to create dispmanx resource
Replies: 1
Views: 3444

Use opencv mat data to create dispmanx resource

I am a newbie in dispmanx. I want to load an image with opencv using cv::Mat img = cv::imread("test.jpg"); now i want to use write/use img.data to create dispmanx resource. how i can utilize img.data in this case. void *image; vc_dispmanx_resource_write_data(resource, type, pitch, image, &dst_rect )...
by ksharindam
Thu Sep 06, 2018 6:21 pm
Forum: Graphics programming
Topic: dispmanx show picture
Replies: 3
Views: 3666

Re: dispmanx show picture

ben.ezazi wrote:
Thu Aug 23, 2018 12:19 pm
this code mostly does the trick but in some cases it projects a distorted image.
e.g the following pc will be shown distorted.
Upload an image in which case it shows correct image
by ksharindam
Wed Sep 05, 2018 3:58 am
Forum: Gaming
Topic: Starcraft and Diablo II on Wine (3G/1G kernel) working on pi 3b/b+
Replies: 4
Views: 4559

Re: Starcraft and Diablo II on Wine (3G/1G kernel) working on pi 3b/b+

Where to get the source code and compile instructions?
I want to run starcraft.
by ksharindam
Mon Sep 03, 2018 6:24 pm
Forum: Raspbian
Topic: raspberrypi-kernel package is uninstalling chromium browser
Replies: 3
Views: 430

Re: raspberrypi-kernel package is uninstalling chromium browser

did you run?

Code: Select all

sudo apt update
.
If yes then, when?
by ksharindam
Thu Aug 30, 2018 5:14 pm
Forum: Raspbian
Topic: Raspbian Stretch 2017-11-29 performs always intensive disk check when booting w/o network.
Replies: 41
Views: 15252

Re: Raspbian Stretch 2017-11-29 performs always intensive disk check when booting w/o network.

Strange thing is that, when i enable fake-hwclock the last write time is Nov 3 2016.
But when i disable fake-hwclock the last write time it shows is Aug 30 2018.
by ksharindam
Thu Aug 30, 2018 1:27 pm
Forum: Raspbian
Topic: Raspbian Stretch 2017-11-29 performs always intensive disk check when booting w/o network.
Replies: 41
Views: 15252

Re: Raspbian Stretch 2017-11-29 performs always intensive disk check when booting w/o network.

Yes it works.
fake-hwclock service is now run before fsck, that's what i wanted. And this solution is better than the previous.
by ksharindam
Thu Aug 30, 2018 10:43 am
Forum: Raspbian
Topic: Raspbian Stretch 2017-11-29 performs always intensive disk check when booting w/o network.
Replies: 41
Views: 15252

Re: Raspbian Stretch 2017-11-29 performs always intensive disk check when booting w/o network.

Wow ! it worked .
I created the /etc/e2fsck.conf file as you have said. And booted my raspberry multiple times.
It did not check filesystem.

Please add this fix to the next release of Raspbian.
Thanks.
by ksharindam
Thu Aug 30, 2018 10:22 am
Forum: Raspbian
Topic: Raspbian Stretch 2017-11-29 performs always intensive disk check when booting w/o network.
Replies: 41
Views: 15252

Re: Raspbian Stretch 2017-11-29 performs always intensive disk check when booting w/o network.

ShiftPlusOne wrote:
Thu Aug 30, 2018 10:12 am
Another thing to try... create /etc/e2fsck.conf with the following:

Code: Select all

[options]
broken_system_clock=1
I will also try that.
before doing that i shall enable fake-hwclock.

Btw, here is the plot svg file...
https://drive.google.com/open?id=1mEIYu ... 7uRcq1mGZS
by ksharindam
Thu Aug 30, 2018 9:54 am
Forum: Raspbian
Topic: Raspbian Stretch 2017-11-29 performs always intensive disk check when booting w/o network.
Replies: 41
Views: 15252

Re: Raspbian Stretch 2017-11-29 performs always intensive disk check when booting w/o network.

If you see it happening, could you please run 'systemd-analyze plot > something.svg' and upload it somewhere? I disabled fake-hwclock and the problem still exists. Ok i shall run that command and upload the svg. here is the journalctl log. sudo journalctl | grep -E "fsck|clock" Nov 03 22:46:43 rasp...

Go to advanced search