Go to advanced search

by ksharindam
Wed Jul 31, 2019 5:06 pm
Forum: Raspberry Pi OS
Topic: Set bluealsa as default sound output device
Replies: 1
Views: 1534

Re: Set bluealsa as default sound output device

Finally found somewhere... I have to just create ~/asoundrc with this following text pcm.btreceiver { type plug slave.pcm { type bluealsa device "8B:13:69:8F:42:75" profile "a2dp" } hint { show on description "Bluetooth Receiver" } } pcm.!default { type plug slave.pcm "btreceiver" } The first sectio...
by ksharindam
Wed Jul 31, 2019 7:08 am
Forum: Raspberry Pi OS
Topic: Compress option in PCmanFM not working with xarchiver
Replies: 5
Views: 635

Re: Compress option in PCmanFM not working with xarchiver

sail1943 wrote:
Wed Jul 31, 2019 3:39 am
any workaround for this problem ?
have to edit the source code and change the command

Code: Select all

xarchiver --add-to %F
to

Code: Select all

xarchiver  --compress %F
But this should be done by the package maintainers.
I have switched to file-roller (though it has less features).
by ksharindam
Tue Jul 30, 2019 6:45 pm
Forum: Raspberry Pi OS
Topic: Set bluealsa as default sound output device
Replies: 1
Views: 1534

Set bluealsa as default sound output device

My setup is raspbian buster lite with xfce desktop. I have installed pibluetooth, blueman , bluealsa. added user pi to group bluetooth. Now I am trying to use my bluetooth headset to get all audio outputs. So I created ~/.asoundrc file with the following text defaults.bluealsa { interface "hci0" dev...
by ksharindam
Tue Jul 30, 2019 4:14 pm
Forum: Raspberry Pi OS
Topic: OpenGL ES not working on Raspberry Pi 4
Replies: 2
Views: 264

Re: OpenGL ES not working on Raspberry Pi 4

ShiftPlusOne wrote:
Tue Jul 30, 2019 4:11 pm
You have to use FKMS for any 3D support on the pi 4. Also, applications need to be built against mesa, not the legacy libs or headers.
That means RPi specific OpenGL ES code will not work on Raspberry Pi 4. Am I right?
Thanks.
by ksharindam
Tue Jul 30, 2019 3:39 pm
Forum: Raspberry Pi OS
Topic: OpenGL ES not working on Raspberry Pi 4
Replies: 2
Views: 264

OpenGL ES not working on Raspberry Pi 4

I have installed raspbian buster lite. and set up xfce4 desktop. I was using the sdcard on raspberry pi 2. Everything was fine. But now I have put the same sdcard into Raspberry Pi 4 , (and disaled fkms driver) but now opengles is not working. Any thing that uses opengles is not working (mpv player ...
by ksharindam
Thu Jul 18, 2019 5:10 pm
Forum: Raspberry Pi OS
Topic: gksudo deprecated
Replies: 10
Views: 3901

Re: gksudo deprecated

The only proper alternative for gksu I found is lxqt-sudo.

Code: Select all

sudo apt install lxqt-sudo
by ksharindam
Fri Jul 12, 2019 4:11 am
Forum: Raspberry Pi OS
Topic: Compress option in PCmanFM not working with xarchiver
Replies: 5
Views: 635

Compress option in PCmanFM not working with xarchiver

I am trying to Compress a file in pcmanfm by right clicking over a file. But clicking compress is not working. xarchiver is used as default archiver in pcmanfm. the output in terminal is xarchiver: Unknown option --add-to But the correct option should be --compress This bug should be fixed. Is xarch...
by ksharindam
Thu Jul 11, 2019 4:09 pm
Forum: Raspberry Pi OS
Topic: Buster bug report thread
Replies: 314
Views: 72543

Compress option in PCmanFM not working with xarchiver

I am trying to Compress a file in pcmanfm by right clicking over a file. But clicking compress is not working. xarchiver is used as default archiver in pcmanfm. the output in terminal is xarchiver: Unknown option --add-to But the correct option should be --compress This bug should be fixed. Is xarch...
by ksharindam
Sat Jun 15, 2019 5:26 pm
Forum: C/C++
Topic: using dynamically loaded libraries causes segmentation fault
Replies: 2
Views: 861

Re: using dynamically loaded libraries causes segmentation fault

uff...what a silly mistake!
Problem solved.
Thanks.
by ksharindam
Sat Jun 15, 2019 4:15 pm
Forum: C/C++
Topic: using dynamically loaded libraries causes segmentation fault
Replies: 2
Views: 861

using dynamically loaded libraries causes segmentation fault

I am trying to use dynamically loaded libraries to get mp3 file duration. But when I am trying to clean allocated memory. It causes segfault. #include <stdlib.h> #include <stdio.h> #include <dlfcn.h> typedef void TagLib_File; typedef void TagLib_AudioProperties; TagLib_File* (*taglib_file_new)(char*...
by ksharindam
Tue Apr 02, 2019 12:40 pm
Forum: Raspberry Pi OS
Topic: Taking long time to boot up
Replies: 3
Views: 853

Re: Taking long time to boot up

after a google search of random: crng init done I found that It is a kernel problem.
And I have fixed my problem by installing rng-tools5 package.
by ksharindam
Tue Apr 02, 2019 12:12 pm
Forum: Raspberry Pi OS
Topic: Taking long time to boot up
Replies: 3
Views: 853

Re: Taking long time to boot up

Output of sudo systemd-analyze blame 2.011s dev-mmcblk0p2.device 1.708s raspi-config.service 1.328s networking.service 940ms dhcpcd.service 840ms keyboard-setup.service 575ms systemd-logind.service 534ms lightdm.service 430ms systemd-timesyncd.service 413ms systemd-udevd.service 409ms systemd-udev-t...
by ksharindam
Tue Apr 02, 2019 2:37 am
Forum: Raspberry Pi OS
Topic: Taking long time to boot up
Replies: 3
Views: 853

Taking long time to boot up

I am using raspbian stretch lite with XFCE desktop. It took 25-30 secs to boot up. But now it takes more than 60 secs to boot up. The output of journalctl indicates that random : crng init done part is taking long time. The output is here Apr 01 02:00:26 raspberrypi polkitd[436]: started daemon vers...
by ksharindam
Tue Mar 26, 2019 3:01 pm
Forum: Raspberry Pi OS
Topic: Pi Without seeing
Replies: 2
Views: 336

Re: Pi Without seeing

To get hdmi output, at first detach your broken display from Pi.
Then remove the SD card from Pi and insert into your android phone.
Edit config.txt and add the line

Code: Select all

hdmi_force_hotplug=1
Then reinsert the SD card to Pi and boot up.
by ksharindam
Sat Jan 26, 2019 4:16 am
Forum: Graphics programming
Topic: transformation matrix of pdf not working for translation
Replies: 0
Views: 972

transformation matrix of pdf not working for translation

I am using pspdftool (https://sourceforge.net/projects/pspdftool/) program to transform pdf pages. It transforms pages by appending q a b c d e f cm command for [a b c d e f] matrix. However rotation and scaling working. But when i try to translate it fails. To translate i am trying to use matrix li...
by ksharindam
Wed Dec 12, 2018 4:12 pm
Forum: Graphics programming
Topic: Qt
Replies: 23
Views: 5513

Re: Qt

If you are choosing a Gui library, Qt will be great. For a beginner , gtk is easier to learn than qt. But after you learn how to implement signal and slots, and subclass a QObject, everything will be easier with qt. When i started to learn gtk, i tried to create a simple drawing app, and failed to d...
by ksharindam
Tue Dec 11, 2018 7:30 pm
Forum: Graphics programming
Topic: Qt
Replies: 23
Views: 5513

Re: Qt

And is it true that the Qt UI uses gtk ? No, Qt does not use gtk, it has its own gui libraries. But in some cases it uses native dialog, such as it can open gtk dialog on a raspbian system. Speaking about pro and cons... Gtk should be faster and the libs are installed by default. While Qt is easyer...
by ksharindam
Thu Dec 06, 2018 1:49 pm
Forum: Raspberry Pi OS
Topic: starting omxplayer in .profile
Replies: 6
Views: 1160

Re: starting omxplayer in .profile

Yes, xterm requires xserver.

If you are running it in cmdline , then it should not require any terminal for keyboard input.
I dont know why it is not taking keyboard input.
by ksharindam
Wed Dec 05, 2018 5:00 pm
Forum: Raspberry Pi OS
Topic: starting omxplayer in .profile
Replies: 6
Views: 1160

Re: starting omxplayer in .profile

to control omxplayer, such as quit by pressing Esc, you have to run omxplayer in terminal.
To run omxplayer in fullscreen in xterm, use this command...

Code: Select all

xterm -fullscreen -e omxplayer -b file.mp4
You have to put this command in .profile
by ksharindam
Sat Dec 01, 2018 3:21 pm
Forum: Raspberry Pi OS
Topic: How do I clone data disk on a live system?
Replies: 4
Views: 811

Re: How do I clone data disk on a live system?

Yes , You can use rsync.

you can also use cp command. cp command with -p flag will reserve all the permissions.

Code: Select all

cp -rp /media/pi/SOURCE-DRIVE/. /media/pi/DESTINATION-DRIVE
If you copy a file a file which is changing, it is most likely that the file will be corrupted.
by ksharindam
Mon Nov 26, 2018 2:48 am
Forum: OpenGLES
Topic: Sharing an OpenGLES 2.0 Christmas Scene ...
Replies: 12
Views: 5997

Re: Sharing an OpenGLES 2.0 Christmas Scene ...

Great job...
Give the github link of the source
by ksharindam
Sat Nov 24, 2018 5:33 am
Forum: Graphics programming
Topic: How to use mmal to decode jpeg image
Replies: 7
Views: 4627

How to use mmal to decode jpeg image

Is it possible to decode a jpeg image using mmal?
If yes , then tell me how. It wiil be helpful if you give code example.

I know it is possible using openmax but i want to use simpler mmal api.
by ksharindam
Thu Nov 22, 2018 1:43 pm
Forum: Raspberry Pi OS
Topic: VLC 3.0 with hardware acceleration
Replies: 97
Views: 36831

Re: VLC 3.0 with hardware acceleration

I still wish that fullscreen mode with mouse triggered popup transport bar was possible. You can do that by selecting X11 video output (XCB) . Performance will be similar to that of x11 splitter for RPi in windowed mode I suspect that depends on the resolution of the clip. The video will have to be...
by ksharindam
Thu Nov 22, 2018 1:29 pm
Forum: Raspberry Pi OS
Topic: Outdated youtube-dl package
Replies: 4
Views: 2251

Re: Outdated youtube-dl package

I think you have tried the second command to install (install in local). For this ~/.local/bin must be in PATH. For this i add this line in ~/.profile if [ -d "$HOME/.local/bin" ] ; then PATH="$HOME/.local/bin:$PATH" fi and also create a text file /etc/X11/Xsession.d/99user with the contents... # Cr...

Go to advanced search