Go to advanced search

by ksharindam
Thu Aug 30, 2018 6:21 am
Forum: Raspbian
Topic: Raspbian Stretch 2017-11-29 performs always intensive disk check when booting w/o network.
Replies: 41
Views: 15277

Re: Raspbian Stretch 2017-11-29 performs always intensive disk check when booting w/o network.

Is it possible to set the time before fsck.?
I mean, using something like service file or shell script.
by ksharindam
Thu Aug 30, 2018 6:17 am
Forum: Raspbian
Topic: rebuild.sh in hello_pi failed to build hello_mmal_encode
Replies: 4
Views: 495

Re: rebuild.sh in hello_pi failed to build hello_mmal_encode

warmbiscuit wrote:
Tue Aug 28, 2018 11:39 pm
I'm having the exact same issue. I can get the Hello_World example to run in the console, but if I try to run anything else, the console essentially freezes.
I can successfully run all of the example binaries. The console does not freeze.
by ksharindam
Tue Aug 28, 2018 2:02 pm
Forum: Gaming
Topic: cant build quake 3 please help
Replies: 5
Views: 1409

Re: cant build quake 3 please help

To build follow these steps ...

Open terminal and run

Code: Select all

git clone https://github.com/RetroPie/quake3.git
cd quake3
Edit the file build_rpi_raspbian.sh and go to line no 35. And remove -lvmcs_rpc_client from that line.
Now run

Code: Select all

./build_rpi_raspbian.sh
by ksharindam
Tue Aug 28, 2018 1:40 pm
Forum: Gaming
Topic: cant build quake 3 please help
Replies: 5
Views: 1409

Re: cant build quake 3 please help

Dont use the source from Raspberry pi git. instead build from the source from the link https://github.com/RetroPie/quake3 .
Because build scripts from the raspberry pi git is not ok, and does not compile successfully.
by ksharindam
Tue Aug 28, 2018 9:08 am
Forum: Gaming
Topic: cant build quake 3 please help
Replies: 5
Views: 1409

Re: cant build quake 3 please help

Which github source are you using?
by ksharindam
Wed Aug 22, 2018 11:21 am
Forum: Raspbian
Topic: rebuild.sh in hello_pi failed to build hello_mmal_encode
Replies: 4
Views: 495

rebuild.sh in hello_pi failed to build hello_mmal_encode

I was running rebuild.sh in hello_pi to compile the example sources. but it failed to build hello_mmal_encode. cc -o hello_mmal_encode.bin -Wl,--whole-archive mmal_encode.o -lmmal -lmmal_core -lmmal_components -lmmal_util -lmmal_vc_client --no-as-needed -L/opt/vc/lib/ -lbrcmGLESv2 -lbrcmEGL -lopenma...
by ksharindam
Thu Feb 15, 2018 1:08 pm
Forum: Raspbian
Topic: GPU Acceleration in chromium with xfce
Replies: 8
Views: 2595

Re: GPU Acceleration in chromium with xfce

Chromium should play videos smoothly. I also use xfce in raspbian stretch lite image. I never encountered a single problem in chromium about video accleration.
by ksharindam
Sun Feb 11, 2018 4:29 am
Forum: Raspbian
Topic: SOLVED CUPS incomplete page printing problem
Replies: 3
Views: 717

Re: CUPS printing problem

Give more detail about it. I mean what is the output of your program. Show us the error messages.
by ksharindam
Sat Feb 10, 2018 8:19 am
Forum: C/C++
Topic: GUI C++ programing for a Rpi 3, and a CM3L
Replies: 6
Views: 7819

Re: GUI C++ programing for a Rpi 3, and a CM3L

I think Qt will be best.
And please dont use GTK, it is very complicated.

Qt is not only a modern Gui library and also a large development framework. It has smart signal-slot system for function callback. It makes many things easier, such as multithreading, creating plugins ... etc.
by ksharindam
Sat Feb 10, 2018 7:52 am
Forum: Raspbian
Topic: Tutorial: Compile VLC with HW acceleration - Stretch, RPi 2/3
Replies: 184
Views: 91243

Re: Tutorial: Compile VLC with HW acceleration - Stretch, RPi 2/3

To add the patch , at first they added ffmpeg in RPi Foundation repo. Then added the patch.
by ksharindam
Sat Feb 10, 2018 7:05 am
Forum: Raspbian
Topic: Tutorial: Compile VLC with HW acceleration - Stretch, RPi 2/3
Replies: 184
Views: 91243

Re: Tutorial: Compile VLC with HW acceleration - Stretch, RPi 2/3

gkreidl wrote:
Sat Feb 10, 2018 6:45 am
What makes you think so?
Because, previously I have sent a patch to enable HW accl in ffmpeg. You can see that they have added my patch.

Now I have sent a patch to enable HW accl in VLC. It may take time to get my message, but then I hope they will add my patch.
by ksharindam
Sat Feb 10, 2018 2:27 am
Forum: Raspbian
Topic: Tutorial: Compile VLC with HW acceleration - Stretch, RPi 2/3
Replies: 184
Views: 91243

Re: Tutorial: Compile VLC with HW acceleration - Stretch, RPi 2/3

McLion wrote:
Fri Feb 09, 2018 8:35 am
Do we still have to compile it by ourselves to get HW acceleration or will the version from the Raspbian repo include GPU acceleration?
I hope VLC in raspbian repo will be HW Accl supported within one month.
by ksharindam
Mon Feb 05, 2018 12:33 pm
Forum: Raspbian
Topic: Hw accl supported ffmpeg in Raspbian repo
Replies: 10
Views: 1884

Re: Hw accl supported ffmpeg in Raspbian repo

cjan wrote:
Mon Feb 05, 2018 3:05 am
sorry, found libass enabled.
but can not use 'ffmpeg -vf subtitles=' option.
I have tried that video filter, It is working without any problem.
by ksharindam
Thu Jan 04, 2018 2:28 pm
Forum: Raspbian
Topic: How to create personal custom image?!
Replies: 2
Views: 16238

Re: How to create personal custom image?!

You can install Raspian image in a sdcard. Then modify the installed os by removing unnecessary softwares,
and installing required softwares, customize the configurations. Then create a disk image of the sdcard in which the os is installed.
Finally u can release the image.
by ksharindam
Wed Jan 03, 2018 5:42 pm
Forum: Raspbian
Topic: Hw accl supported ffmpeg in Raspbian repo
Replies: 10
Views: 1884

Hw accl supported ffmpeg in Raspbian repo

Hello, I have created a patch for ffmpeg package to enable HW accl video decoding and encoding on Raspberry Pi. which is here ... https://gist.github.com/ksharindam/a17a52907dac0d0014b1d36c36e4e465 I want to add this patch in the repo. How can I send this patch to Raspbian maintainers (especially Sh...
by ksharindam
Wed Dec 13, 2017 11:27 am
Forum: Raspbian
Topic: playing HD videos
Replies: 16
Views: 15927

Re: playing HD videos

The video encoding is AVC1 , I think this is not supported by OMXPLAYER.
Though you have given all infos, it will be helpful if you give output of the command...

Code: Select all

omxplayer -i video_name.mov
by ksharindam
Sun Dec 10, 2017 10:20 am
Forum: Raspbian
Topic: youtube-dl
Replies: 16
Views: 11247

Re: youtube-dl

I would recommend pytube instead of youtube-dl.
It can download all videos that youtube-dl can. And also it is easy to use.
You can install it from git source, or you can install using pip.
sudo pip install pytube
by ksharindam
Fri Dec 08, 2017 1:16 pm
Forum: Raspbian
Topic: VLC version on Repository
Replies: 6
Views: 999

Re: VLC version on Repository

Thanks.
by ksharindam
Fri Dec 08, 2017 1:12 pm
Forum: Raspbian
Topic: VLC version on Repository
Replies: 6
Views: 999

Re: VLC version on Repository

Glad to hear it . I will try to make a patch.
And one more question, if I send you a patch of ffmpeg with hwaccl support will you include the patch?
by ksharindam
Fri Dec 08, 2017 10:24 am
Forum: Raspbian
Topic: VLC version on Repository
Replies: 6
Views: 999

Re: VLC version on Repository

They will never include OMX IL output supported version in the repo. Because omxil output does not work when gl driver is enabled.
They will not incllude any app in the repo that does not work properly when gl driver is enabled.
even they haved removed penguinspuzzle from the repo.
by ksharindam
Mon Nov 27, 2017 3:10 pm
Forum: Graphics programming
Topic: I want to download opencv
Replies: 2
Views: 1354

Re: I want to download opencv

To install opencv run this command ...

Code: Select all

sudo apt install libopencv-core-dev libopencv-highgui-dev libopencv-imgproc-dev libopencv-flann-dev libopencv-photo-dev libopencv-video-dev libopencv-features2d-dev libopencv-objdetect-dev libopencv-calib3d-dev libopencv-ml-dev libopencv-contrib-dev
by ksharindam
Mon Nov 27, 2017 3:05 pm
Forum: Raspbian
Topic: wlan0 disappears after Stretch 2017-09-07
Replies: 29
Views: 3441

Re: wlan0 disappears after Stretch 2017-09-07

few days ago i updated dhcpcd5 package, after that my wifi dongle does not works at first attempt. I have to plug and unplug two or more times to make it work. There may be a bug in latest dhcpcd5 package.
by ksharindam
Sun Nov 26, 2017 5:10 pm
Forum: Raspbian
Topic: wlan0 disappears after Stretch 2017-09-07
Replies: 29
Views: 3441

Re: wlan0 disappears after Stretch 2017-09-07

I also have no clue what happened.
by ksharindam
Sun Nov 26, 2017 1:18 pm
Forum: Raspbian
Topic: wlan0 disappears after Stretch 2017-09-07
Replies: 29
Views: 3441

Re: wlan0 disappears after Stretch 2017-09-07

The firmware for internal wifi is firmware-brcm80211 which is also installed.
Its very weird that wifi is not working. I want do a final try... paste the contents of /boot/config.txt

If there is no problem in config.txt then you have to reinstall the image. wifi works in a fresh installation.
by ksharindam
Sun Nov 26, 2017 9:11 am
Forum: Raspbian
Topic: wlan0 disappears after Stretch 2017-09-07
Replies: 29
Views: 3441

Re: wlan0 disappears after Stretch 2017-09-07

I use TP-Link 725N and it works fine. required firmware is firmware-realtek which is already installed in your system. your wpa-suppliccant.conf file is also error free. So wifi should work in your Pi. But the wifi dongle is not shown in the output of lsusb command. Have you inserted the wifi dongle...

Go to advanced search