Go to advanced search

by ZPMMaker
Sat Nov 03, 2018 10:50 am
Forum: General discussion
Topic: SSH tunnel to Pi via my own server
Replies: 5
Views: 2545

Re: SSH tunnel to Pi via my own server

Never mind; got it working by following the steps at https://www.howtoforge.com/reverse-ssh-tunneling Let's assume that Destination's IP is 192.168.20.55 (Linux box that you want to access). You want to access from Linux client with IP 138.47.99.99. Destination (192.168.20.55) <- |NAT| <- Source (13...
by ZPMMaker
Sat Nov 03, 2018 5:14 am
Forum: General discussion
Topic: SSH tunnel to Pi via my own server
Replies: 5
Views: 2545

Re: SSH tunnel to Pi via my own server

However, when I ran the first command (on the Pi), all it did was open a new SSH connection from the Pi to the EC2 instance (i.e. I could control the EC2 instance through the SSH connection I had made to control the Pi). This is correct, you will have the tunnel created anyway. There is an option f...
by ZPMMaker
Fri Nov 02, 2018 9:44 am
Forum: General discussion
Topic: SSH tunnel to Pi via my own server
Replies: 5
Views: 2545

SSH tunnel to Pi via my own server

So I've tried about half a dozen different commercial SSH tunnelling services (e.g. Weaved/Remote-IoT/AWS Systems Manager, OpenPort, and so on) over the last year for remote controlling my RPis. They all have issues that make them unreliable. So I want to replace/augment them with my own SSH tunnels...
by ZPMMaker
Thu Aug 09, 2018 12:05 am
Forum: General discussion
Topic: Powering a USB hub from third-party 5V 2A solder pads
Replies: 10
Views: 943

Re: Powering a USB hub from third-party 5V 2A solder pads

The page you originally linked to is referring to the original Pi model B(1). That had fuses on each of the two USB ports to limit the current to under 140mA. You'd be better off looking at the "Power Requirements" section of the FAQ , which gives a list of each of the major models, the r...
by ZPMMaker
Wed Aug 08, 2018 5:08 am
Forum: General discussion
Topic: Powering a USB hub from third-party 5V 2A solder pads
Replies: 10
Views: 943

Re: Powering a USB hub from third-party 5V 2A solder pads

The Pi cannot provide more than 1.2A to the USB ports, combined, that is true. If, however, you are using only one port, it has all of that 1.2A to itself. Sadly, I need to use three of the USB ports, so not all of the 1.2A can go to the camera itself. I’m curious to know, though, where you found t...
by ZPMMaker
Wed Aug 08, 2018 4:38 am
Forum: General discussion
Topic: Powering a USB hub from third-party 5V 2A solder pads
Replies: 10
Views: 943

Re: Powering a USB hub from third-party 5V 2A solder pads

Paul Hutch wrote:
Tue Aug 07, 2018 6:07 pm
So cutting the cord and hooking it up to a different 5V @ 2A power source should be fine.
Excellent; thanks for your advice. I’ll give it a go.
by ZPMMaker
Wed Aug 08, 2018 4:37 am
Forum: General discussion
Topic: Powering a USB hub from third-party 5V 2A solder pads
Replies: 10
Views: 943

Re: Powering a USB hub from third-party 5V 2A solder pads

The problem is the RPi USB hub doesn't provide enough current to charge the camera's internal battery. I don't understand. An RPi3B is able to provide up to 1.2 amps from a single one of its 4 USB ports. That's far in excess of the USB2.0 spec. So what spec of USB port is the camera supposed to wor...
by ZPMMaker
Tue Aug 07, 2018 2:01 pm
Forum: General discussion
Topic: Powering a USB hub from third-party 5V 2A solder pads
Replies: 10
Views: 943

Powering a USB hub from third-party 5V 2A solder pads

Hi folks, I realise this isn't directly a Raspberry Pi question, but I'm hoping someone here knows the answer to my problem. I have a Raspberry Pi 3 and a USB camera (the Raspberry Pi camera module isn't suitable for my project). I am planning to use the new LiFePo4wered/Pi+ module (which I will con...
by ZPMMaker
Fri Jul 13, 2018 12:52 am
Forum: Troubleshooting
Topic: RPi3 freezes when uploading to AWS S3 via 4G
Replies: 2
Views: 687

Re: RPi3 freezes when uploading to AWS S3 via 4G

Fixed it.
Turns out there was an error in my version of the AWS CLI tools.

A simple application of

Code: Select all

sudo pip install --upgrade awscli
updated AWS CLI and fixed the issue. :roll:
by ZPMMaker
Thu Jul 12, 2018 11:44 pm
Forum: Troubleshooting
Topic: RPi3 freezes when uploading to AWS S3 via 4G
Replies: 2
Views: 687

Re: RPi3 freezes when uploading to AWS S3 via 4G

Ok, bit of an update on this one... A friend directed me to /var/log/ (which I had no idea existed, silly me). I scoured through every log file in that folder. I only found something unusual in /var/log/syslog https://s3-ap-southeast-2.amazonaws.com/ionthesky/PiLogs/log4GS3logout.jpg At roughly 22:0...
by ZPMMaker
Thu Jul 12, 2018 6:23 am
Forum: Troubleshooting
Topic: RPi3 freezes when uploading to AWS S3 via 4G
Replies: 2
Views: 687

RPi3 freezes when uploading to AWS S3 via 4G

Hi all. Got myself a puzzling problem... I have a Raspberry Pi Model 3B, a Sense HAT plugged into it via the GPIO pins, and a 4G/LTE modem and a camera plugged in via USB. My goal is to make a 4G-connected camera that automatically takes a photo every 5 mins and uploads it to AWS S3, and collects se...
by ZPMMaker
Tue Jun 05, 2018 11:51 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: [Announcement] New USB chip-solution
Replies: 12
Views: 3322

Re: [Announcement] New USB chip-solution

B.Goode wrote:
Tue Jun 05, 2018 11:31 am
They have a Contact Us facility on their company website: http://www.flyfish-tech.com/ContactUs.php
DougieLawson wrote:Ivan disappeared from this forum in 2014.
Thanks for that. I'll send him a message there.
by ZPMMaker
Tue Jun 05, 2018 11:04 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: [Announcement] New USB chip-solution
Replies: 12
Views: 3322

Re: [Announcement] New USB chip-solution

Hi Ivan,

I have just bought one of your FF32 chips and am trying to use it with an RPi3. I would appreciate any input you could provide, please: viewtopic.php?f=44&t=215240.

Thanks. :)
David
by ZPMMaker
Tue Jun 05, 2018 11:03 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Using many sensors on RPi3 via a Flyfish FF32
Replies: 0
Views: 361

Using many sensors on RPi3 via a Flyfish FF32

Howdy, I've got a Raspberry Pi 3 Model B, a Flyfish FF32 (introduced to the forum here: https://www.raspberrypi.org/forums/viewtopic.php?t=72023 ), and an Adafruit digital light/lux sensor ( https://learn.adafruit.com/tsl2561/wiring-the-tsl2561-sensor ) (and about two dozen other digital and analog ...
by ZPMMaker
Mon Mar 26, 2018 2:33 am
Forum: General discussion
Topic: USB OTG WiFi Adapter exists?
Replies: 5
Views: 3667

Re: USB OTG WiFi Adapter exists?

Add something like http://www.ebay.co.uk/itm/2X-OTG-Adapter-Micro-USB-Male-to-USB-Female-For-Samsung-Android-Phone-Tablet-PC-/262458084444 Amusingly, that link is to a fidget spinner. Given the URL has adapter in it, I doubt that was your intent. Something screwy must be going on with eBay links......
by ZPMMaker
Tue Dec 19, 2017 1:34 pm
Forum: Automation, sensing and robotics
Topic: Pressing a button to turn on a camera using RPi3 and motors
Replies: 4
Views: 1355

Re: Pressing a button to turn on a camera using RPi3 and motors

no problem, hope it works for you. a couple points i didnt make, the code was written in python 2.7.13, if you set the pycharm interpreter to 3.5 it will highlight errors.. it may be worth sticking with the same version if you are using the code i posted. also its set up for bcm gpio, not board.. s...
by ZPMMaker
Mon Dec 18, 2017 9:09 am
Forum: Automation, sensing and robotics
Topic: Pressing a button to turn on a camera using RPi3 and motors
Replies: 4
Views: 1355

Re: Pressing a button to turn on a camera using RPi3 and motors

im surprised you cant turn the camera on through software, but a quick google didnt come back with anything.. maybe you could use a car door lock actuator to press the button? they are 12v but possibly better than rigging up a motor? https://www.ebay.co.uk/itm/Universal-Heavy-Duty-Power-Door-Lock-A...
by ZPMMaker
Fri Dec 15, 2017 5:59 am
Forum: Automation, sensing and robotics
Topic: Pressing a button to turn on a camera using RPi3 and motors
Replies: 4
Views: 1355

Pressing a button to turn on a camera using RPi3 and motors

Hello, I'm building a remote camera network and need a way to turn the camera on robotically, i.e. I need something that will - when my software detects that the camera is turned off - push the power button on the camera, and then retract. I am completely new to robotics, and certainly don't know my...
by ZPMMaker
Tue Nov 28, 2017 4:47 am
Forum: Advanced users
Topic: Powering USB on and off
Replies: 17
Views: 8328

Re: Powering USB on and off

I realise this conversation is a few years old, but I found it via Google when I was facing the same problem, so figured I'd share the below solution in case someone else needs it in future... This solution works as-is on an RPi 3 model B running Raspbian Stretch. http://embeddedapocalypse.blogspot....
by ZPMMaker
Sun Oct 15, 2017 12:31 pm
Forum: General discussion
Topic: Weaved Service Alternative
Replies: 6
Views: 3903

Re: Weaved Service Alternative

DougieLawson wrote:
Sun Oct 15, 2017 7:18 am
How about running OpenVPN on your AWS service and getting each of the twenty remote Raspberries to connect to that. OpenVPN gives you a two-way tunnel.

Or there's the commercial RealVNC service https://manage.realvnc.com/en/pricing
Thanks Dougie, I'll give OpenVPN a go. :)
by ZPMMaker
Sun Oct 15, 2017 3:39 am
Forum: General discussion
Topic: Weaved Service Alternative
Replies: 6
Views: 3903

Re: Weaved Service Alternative

Get yourself a virtual server on Google Cloud, AWS, or whatever. Have your Pi ssh into that virtual server and create SSH tunnels. Login to the cloud server from wherever you are in the world. Login into your Pi from the cloud server through the SSH tunnels. Sorry to necro an old thread, but... I'v...
by ZPMMaker
Sat Sep 30, 2017 10:44 am
Forum: Advanced users
Topic: Script runs normally except when called via cron
Replies: 12
Views: 2341

Re: Script runs normally except when called via cron

Just to close up this topic, I figured out the issue. I had forgotten to end a For-loop on my main camera script, and also had a typo in my auto-updater script. The error in the auto-updater script meant the error in the main camera script hadn't been installed onto the working systems. When I went ...
by ZPMMaker
Mon Sep 18, 2017 12:52 pm
Forum: Advanced users
Topic: Script runs normally except when called via cron
Replies: 12
Views: 2341

Re: Script runs normally except when called via cron

Well that's one thing you can tick of the list of causes, now you need to do as dougie suggested and add some print statements to your program so you know what's happening. Put one at the beginning reporting the program starting , in each defined function to say its started and stopped, if you have...
by ZPMMaker
Mon Sep 18, 2017 12:50 pm
Forum: Advanced users
Topic: Script runs normally except when called via cron
Replies: 12
Views: 2341

Re: Script runs normally except when called via cron

If you install a mail transfer agent (MTA) like postfix then any output from a cronjob will be emailed to your id. Fill up your script with lots of print (...stuff..here...) commands so you can see the flow and the failure. Thanks Dougie... actually, I already have almost every part of my script lo...
by ZPMMaker
Mon Sep 18, 2017 11:41 am
Forum: Advanced users
Topic: Script runs normally except when called via cron
Replies: 12
Views: 2341

Re: Script runs normally except when called via cron

if you want to check cron is actually working as expected you could try adding an extra cron line like this */5 * * * * date >> /home/pi/log.txt it will just write the date & time to the log.txt file then at least you will know cron is executing the timed instructions Thanks - cron seems to be ...

Go to advanced search