Go to advanced search

by lpsw
Fri Aug 02, 2019 5:56 pm
Forum: Troubleshooting
Topic: 4k 60 hz is not listed, only 30hz
Replies: 35
Views: 5304

Re: 4k 60 hz is not listed, only 30hz

Update: did same with Pi4 and now it's running at 4kp60.
Seems to be monitor wonkiness and not the Pi4, at least in regard to my particular monitor.
YMMV.
by lpsw
Thu Aug 01, 2019 9:40 pm
Forum: Troubleshooting
Topic: 4k 60 hz is not listed, only 30hz
Replies: 35
Views: 5304

Re: 4k 60 hz is not listed, only 30hz

I've been dealing with a similar (if not identical) issue with 4kp60. My monitor is a Samsung U28E590. Samsung says HDMI2 can push 4kp60. I could not get 4kp60 from either my Pi42M (config.txt was correct) or my Windows 10 desktop, regardless of HDMI port. I switched my Win10 box to 2560x1440 @ 60Hz...
by lpsw
Thu Aug 01, 2019 6:02 am
Forum: Python
Topic: TypeError: lcd_string() missing 1 required positional argument: 'style'
Replies: 2
Views: 270

Re: TypeError: lcd_string() missing 1 required positional argument: 'style'

Try:

Code: Select all

lcd_byte(1, LCD_CMD)
lcd_string(rbuff, LCD_LINE_1)
Assuming, of course, that LCD_CMD and LCD_LINE_1 are correct.
by lpsw
Mon Jul 22, 2019 4:35 am
Forum: General discussion
Topic: Power Supply - Type C of Pi 4 model B
Replies: 32
Views: 2186

Re: Power Supply - Type C of Pi 4 model B

Designing a safe, reliable, and on-spec power supply is not trivial, especially for a beginner. IMHO, beyond the scope of this forum.
by lpsw
Wed Jul 17, 2019 4:29 pm
Forum: Raspbian
Topic: Does anybody else have problems with USB 3 storage on RPi4?
Replies: 25
Views: 3854

Re: Does anybody else have problems with USB 3 storage on RPi4?

This may help: https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=245323 Yes, this helped. I can now boot with the USB SSD connected, however read/write performance seems poor, it is only slightly better than a sata 4500rpm hdd plugged into the usb 3 What SSD and SATA controller chip are you u...
by lpsw
Mon Jul 15, 2019 5:31 pm
Forum: Camera board
Topic: HDMI output with RPi-Cam-Web-Interface and Pikrellcam
Replies: 6
Views: 532

Re: HDMI output with RPi-Cam-Web-Interface and Pikrellcam

I use solar backed batteries. The Pi0s connect to a long range outdoor Wifi AP. I disable on board wifi and bluetooth, and use external USB wifi adapters with high gain antennae. To get notifications, this is my approach. I'm sure it could be improved on :) 1) Install some stuff (if not already inst...
by lpsw
Mon Jul 15, 2019 2:37 pm
Forum: Camera board
Topic: HDMI output with RPi-Cam-Web-Interface and Pikrellcam
Replies: 6
Views: 532

Re: HDMI output with RPi-Cam-Web-Interface and Pikrellcam

I have eight (8) Pi0Ws running Pikrellcam, deployed as wildlife cameras, with motion detection and email notification. They run just fine. All are headless, though. After all, they are in the wild :D
by lpsw
Sun Jul 14, 2019 4:25 pm
Forum: Troubleshooting
Topic: AData SD600 ssd not working on USB 3 ports
Replies: 8
Views: 1154

Re: AData SD600 ssd not working on USB 3 ports

I had to do the same to get my SSD to run from a USB3 port. It ran fine on a USB2 port.

SATA controller:
ID 152d:1561 JMicron Technology Corp. JMS561U

SSD:
KINGSTON SA400S37240G; firmware revision SBFKB1D1
by lpsw
Fri Jun 07, 2019 2:44 pm
Forum: Beginners
Topic: Get new web browser
Replies: 15
Views: 1223

Re: Get new web browser

This problem happens every time I try to install something.
Can you please post any error messages from a failed install attempt?
by lpsw
Wed May 22, 2019 4:45 pm
Forum: Off topic discussion
Topic: ARM, Broadcom pull the plug on Huawei
Replies: 14
Views: 1754

Re: ARM, Broadcom pull the plug on Huawei

Code: Select all

Just an excuse for the unintelligent occupant of the White House to bring in more protectionism, despite that being a terrible medium/long term strategy, as the incumbant would know if he actually knew anything
He won't be around much longer. Hopefully the damage can be corrected in time.
by lpsw
Sat May 18, 2019 5:38 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1477
Views: 338933

Re: PiKrellCam: motion vector detect + OSD web interface

Kajan001, Is it a relatively new Pi? I have 6 Pi0Ws streaming from Pikrellcam. The last (newest) one I added started freezing after 1-2 hours. The rest run rock solid 24x7. I stumbled on this thread: https://www.raspberrypi.org/forums/viewtopic.php?f=43&t=230771 And now the new Pi is streaming fine....
by lpsw
Thu May 16, 2019 7:01 pm
Forum: Camera board
Topic: PI Zero W Crash with V2 Kamera Modul with Motion/BCM2835
Replies: 2
Views: 897

Re: PI Zero W Crash with V2 Kamera Modul with Motion/BCM2835

After looking at https://www.raspberrypi.org/forums/viewtopic.php?f=43&t=212777 I tried over_voltage=8 (1.4V), and new zero is streaming fine now for >24 hours. Max before was less than 2 hours. May be too early to tell, but looks like it is having a positive effect. Pi is still running +9C above by...
by lpsw
Mon May 13, 2019 7:13 am
Forum: Camera board
Topic: PI Zero W Crash with V2 Kamera Modul with Motion/BCM2835
Replies: 2
Views: 897

Re: PI Zero W Crash with V2 Kamera Modul with Motion/BCM2835

I'm just now seeing something similar. Some config info, from crash time: Raspberry Pi Zero W Rev 1.1 temp=59.5'C volt=1.3500V throttled=0x0 Linux pi-10 4.14.98+ #1200 Tue Feb 12 20:11:02 GMT 2019 armv6l GNU/Linux uptime: 01:30:01 up 3:12, 1 user, load average: 0.21, 0.29, 0.28 I currently run 5 Pi0...
by lpsw
Fri May 10, 2019 8:01 pm
Forum: General discussion
Topic: vcgencmd get_throttled returns 0xd0000 and 0x50000
Replies: 13
Views: 701

Re: vcgencmd get_throttled returns 0xd0000 and 0x50000

Andyroo,
I believe I was in preview mode.
by lpsw
Fri May 10, 2019 7:53 pm
Forum: General discussion
Topic: vcgencmd get_throttled returns 0xd0000 and 0x50000
Replies: 13
Views: 701

Re: vcgencmd get_throttled returns 0xd0000 and 0x50000

Tried code tagsfirst, no help. Spaces were still removed.
I expected code tags to honor (honour :D ) indentation.

Edit: Thanks B.Goode. I copied and pasted from a document to between the code tags...hmm
by lpsw
Fri May 10, 2019 7:39 pm
Forum: General discussion
Topic: vcgencmd get_throttled returns 0xd0000 and 0x50000
Replies: 13
Views: 701

Re: vcgencmd get_throttled returns 0xd0000 and 0x50000

This may help clarify: Hex 5 0 0 0 0 Binary 0101 0000 0000 0000 0000 Bit#---- 1111 1111 1100 0000 0000 ----------- 9876 5432 1098 7654 3210 -------------------^--- Bit 16 is on - Been under voltage (at least once) ---------------^------- Bit 18 is on - Been throttled (at least once) (Note: since bit...
by lpsw
Sat May 04, 2019 6:23 pm
Forum: Troubleshooting
Topic: Pi 3 B+ doesn't work on 1Gbps switch
Replies: 7
Views: 443

Re: Pi 3 B+ doesn't work on 1Gbps switch

If the cable checks out, and the switch supports it (I don't have one and no time to google :)) disable auto-negotiate on the switch port and fix it at 100MB.
by lpsw
Tue Apr 30, 2019 6:27 pm
Forum: Beginners
Topic: MOTION NOT WORKING
Replies: 15
Views: 789

Re: MOTION NOT WORKING

The router displays the pi as connected on it's page
Have you verified that the router displays the expected IP address?
by lpsw
Wed Apr 24, 2019 6:02 am
Forum: General discussion
Topic: looking for system logs related to Picamera run
Replies: 1
Views: 112

Re: looking for system logs related to Picamera run

No, since Picamera is not part of Raspian.
You can add your own logging in your Python code.
by lpsw
Sat Apr 20, 2019 7:33 pm
Forum: Debian
Topic: Headless install
Replies: 5
Views: 3966

Re: Headless install

Why do you think Raspian is at fault?
That would be a bug.

Much more likely causes for data corruption:
1) Power. Poor power supply (don't use a charger), or loss of power at an unfortunate time.
2) SD card. Lots of fake/poor quality cards out there.
by lpsw
Mon Apr 15, 2019 7:38 pm
Forum: Troubleshooting
Topic: Does cloning an SD clone the Pi's MAC address?
Replies: 20
Views: 1091

Re: Does cloning an SD clone the Pi's MAC address?

epoch1970,
This is off topic, just want to express our sorrow and heavy hearts for Paris and all of France for today's historic disaster.
Vive La France.

EDIT: fixed my bad spelling.
by lpsw
Thu Apr 11, 2019 3:29 am
Forum: General discussion
Topic: Quectel EC 25 / 21 drivers ?
Replies: 8
Views: 1188

Re: Quectel EC 25 / 21 drivers ?

https://www.quectel.com/UploadImage/Dow ... e_V1.8.pdf

This is what I used in my decision on what I wanted to use in my application.
Sorry I don't have time to google to see if there is more recent info. Maybe you can do that.

PS See 3.3.4 and 3.3.5
by lpsw
Fri Apr 05, 2019 4:02 am
Forum: General discussion
Topic: Quectel EC 25 / 21 drivers ?
Replies: 8
Views: 1188

Re: Quectel EC 25 / 21 drivers ?

This might shed some light:
https://github.com/raspberrypi/linux/issues/1880

I looked at this modem a while back, but went with another (U620L from Verizon (US)) due to support concerns.
by lpsw
Fri Apr 05, 2019 3:23 am
Forum: General discussion
Topic: Quectel EC 25 / 21 drivers ?
Replies: 8
Views: 1188

Re: Quectel EC 25 / 21 drivers ?

Took a quick read of the EC21 install doc; it clearly indicates that the driver must be compiled by the end user, in order to install the driver(s).

BTW, the Pi does not have a mPCIe port.

EDIT: driver (not kernel) requires recompilation.

Go to advanced search