Go to advanced search

by Canedje
Wed May 31, 2017 4:21 pm
Forum: Troubleshooting
Topic: SD error not enough sectors to replace image
Replies: 15
Views: 3148

SD error not enough sectors to replace image

I had a problem that my SD 16Gb card was broken. I bought a new 16GB SD card and tried to replace the image by Win32Diskimager. This is generating an error saying not enough sectors to install image (there is a small difference between image and SD). How can I still get the image on the SD??? Please...
by Canedje
Wed Mar 08, 2017 5:39 pm
Forum: Troubleshooting
Topic: How to protect the RPI against Hackers?
Replies: 10
Views: 4101

Re: How to protect the RPI against Hackers?

Thanks for the advice.
I just changed the ssh port away from the standard.
Is there somewhere a tutorial how to install the the fail2ban program you mentioned?
I do run a mix on Apache2 the most is written in PHP and Java
by Canedje
Wed Mar 08, 2017 5:23 pm
Forum: Troubleshooting
Topic: How to protect the RPI against Hackers?
Replies: 10
Views: 4101

Re: How to protect the RPI against Hackers?

runboy93 wrote:Offline :)

Or "harden" security of the RPi with tweaks.
Yes but how to harden security??
by Canedje
Wed Mar 08, 2017 4:24 pm
Forum: Troubleshooting
Topic: How to protect the RPI against Hackers?
Replies: 10
Views: 4101

How to protect the RPI against Hackers?

A couple of days ago My provider blocked my IPadres because of sending SPAM mails. At that time there was no laptop or pc connected to the network. Only 2 NASses, 2 ip cams and 2 RPI's. I checked the NASses on virus and mallware. Nothing found. I checked the RPI's. One had a strange line in the cron...
by Canedje
Mon Feb 20, 2017 12:01 pm
Forum: Troubleshooting
Topic: I don't understand dmesg message
Replies: 3
Views: 837

Re: I don't understand dmesg message

Thanks.
Strange because I'm not using W1 at this moment
by Canedje
Sun Feb 19, 2017 4:48 pm
Forum: Troubleshooting
Topic: I don't understand dmesg message
Replies: 3
Views: 837

I don't understand dmesg message

After running dmesg command I do recieve a lot lines all telling the same.
I don't understand the message. Can somebody help?

Code: Select all

[155442.835970] w1_master_driver w1_bus_master1: Family 0 for 00.113000000000.ee is not registered.
by Canedje
Sat Feb 18, 2017 9:45 pm
Forum: Troubleshooting
Topic: USB port not always recognized
Replies: 5
Views: 1035

Re: USB port not always recognized

Thanks MaxK1. I don't know the command dmesg. I executed it and a long list of lines appears. Until now it says several times: [45967.273740] [UFW BLOCK] IN=eth0 OUT= MAC=01:00:5e:00:00:01:14:dd:a9:d1:f8:10:08:00:46:c0:00:20:00:00:40:00:01:02:04:17 SRC=0.0.0.0 DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0xC0...
by Canedje
Sat Feb 18, 2017 9:17 pm
Forum: Troubleshooting
Topic: Cron not working?
Replies: 19
Views: 3958

Re: Cron not working?

You need to have the full pathname to python3
so the command have to be:

Code: Select all

@reboot /usr/bin/python3 /home/pi/git/SunriseSimulator/app.py
by Canedje
Sat Feb 18, 2017 9:11 pm
Forum: Troubleshooting
Topic: USB port not always recognized
Replies: 5
Views: 1035

Re: USB port not always recognized

Thanks topguy.
No only 1 mtr.
What is strange that it only happens to one of the two USB connectors
by Canedje
Sat Feb 18, 2017 9:31 am
Forum: Troubleshooting
Topic: USB port not always recognized
Replies: 5
Views: 1035

USB port not always recognized

I'm using my RPI as a datalogger for Energy measuring. I'm using two devices both connected by USB to the RPI. I predefined the names for the USB's. This is working fine. My problem is that sometimes one of the USB is not recognized by the RPI anymore (Always the same one connected by P1 at smart en...
by Canedje
Thu Dec 01, 2016 7:39 pm
Forum: Python
Topic: How to start a async tornado @gen.coroutine
Replies: 0
Views: 817

How to start a async tornado @gen.coroutine

I do run a webserver by tornado. It works fine. I do try to start a async routine that don't start. I don't know why? I am able to run a time controlled routine by: @classmethod def write_to_clients(cls): # print ("Writing to clients: ", cls.clients) for client in cls.clients: client.write_message("...
by Canedje
Wed Nov 30, 2016 12:22 pm
Forum: C/C++
Topic: compare unity8_t to a string not working
Replies: 6
Views: 1115

Re: compare unity8_t to a string not working

Thanks again.
This was what I needed.
by Canedje
Tue Nov 29, 2016 9:08 pm
Forum: C/C++
Topic: compare unity8_t to a string not working
Replies: 6
Views: 1115

Re: compare unity8_t to a string not working

Thanks. I know that a pointer is an adress to the value and not the value itself. I still having trouble comparing a uint8_t with a string. I do try to compare the uint8_t var named "payload" with a string named "test" If both the value is : "Ben je er al?" the if statement is true. I don't know how...
by Canedje
Tue Nov 29, 2016 8:04 pm
Forum: C/C++
Topic: compare unity8_t to a string not working
Replies: 6
Views: 1115

Re: compare unity8_t to a string not working

yes I do.
In the past I did programming. That is a while ago.
by Canedje
Tue Nov 29, 2016 7:20 pm
Forum: C/C++
Topic: compare unity8_t to a string not working
Replies: 6
Views: 1115

compare unity8_t to a string not working

I do try to test an unity8_t var (payload) with a string (p). I do convert a string to an unity8_t var called p, by: String test = "message received : Ben je er al?"; const uint8_t* p = reinterpret_cast<const uint8_t*>(test.c_str()); Then I do compare "p" with a websocket called "payload" by: if ( p...
by Canedje
Sat Nov 26, 2016 2:09 pm
Forum: Nederlands
Topic: static IP-adress [opgelost]
Replies: 3
Views: 1129

Re: static IP-adress

Ik heb er ook mee lopen zweten.
Ik kreeg of aleen op eth0 of op wlan0 een vast ip adres, niet bij beiden.
Ik heb de methode van Jessie en die van Wheezy allebei samen gebruikt. Nu werkt het wel.
(Het zal vast niet volgens de boekjes zijn, maar ik heb fixed ip adressen :D :roll: )
by Canedje
Sat Nov 26, 2016 9:29 am
Forum: Nederlands
Topic: static IP-adress [opgelost]
Replies: 3
Views: 1129

Re: static IP-adress

In deze link wordt precies beschreven hoe je statische adressen bij Jessie moet regelen:
https://www.modmypi.com/blog/how-to-giv ... ess-update
by Canedje
Thu Nov 24, 2016 6:19 pm
Forum: Troubleshooting
Topic: NXDOMAIN error by Gmail
Replies: 4
Views: 2695

Re: NXDOMAIN error by Gmail

Set up postfix and dnsmasq (or bind9) so that a lookup for the MX record gets a good result. Also look at whether your ISP has a valid MX record for your domain. Postfix has some sensible default configurations (that you get to choose when you install it) that mostly match what most folks want to d...
by Canedje
Thu Nov 24, 2016 4:34 pm
Forum: Troubleshooting
Topic: NFS server only starts on second attempt
Replies: 2
Views: 504

Re: NFS server only starts on second attempt

I did have almost the same problem.
Maybe this item will help you:

viewtopic.php?f=28&t=166479
by Canedje
Thu Nov 24, 2016 4:32 pm
Forum: Troubleshooting
Topic: Fresh RPI not Booting
Replies: 2
Views: 523

Re: Fresh RPI not Booting

I almost don't dare to tell. :oops: :oops: :oops:

The monitor was not connected to the HDMI input.
The RPI was waiting for input. But I didn't see it.
Everything worked fine after selecting the HDMI port of the monitor

Sorry about confusing everybody
by Canedje
Thu Nov 24, 2016 4:30 pm
Forum: Troubleshooting
Topic: NXDOMAIN error by Gmail
Replies: 4
Views: 2695

Re: NXDOMAIN error by Gmail

Nobody a tip?
by Canedje
Thu Nov 24, 2016 4:28 pm
Forum: Troubleshooting
Topic: nfs-kernel-server not always start at startup
Replies: 4
Views: 1984

Re: nfs-kernel-server not always start at startup

It looks like working.
Thanks again!
by Canedje
Thu Nov 24, 2016 11:04 am
Forum: Troubleshooting
Topic: Fresh RPI not Booting
Replies: 2
Views: 523

Fresh RPI not Booting

I bought a new RPI 3b. (My 3th) The two before installed fine It will not initiate and boot. I formatted the SD card with SDFormatter and copied NOOBS v2.0.0 on it The size is about 14.8 Gb left (Its a 16Gb sd card) If I put the sd in the RPI and put power on. The red LED is burning. The green LED i...
by Canedje
Thu Nov 24, 2016 8:04 am
Forum: Troubleshooting
Topic: nfs-kernel-server not always start at startup
Replies: 4
Views: 1984

Re: nfs-kernel-server not always start at startup

Thanks.
I didn't read that warning :oops:
I will try that tonight after work!
by Canedje
Thu Nov 24, 2016 7:14 am
Forum: Troubleshooting
Topic: nfs-kernel-server not always start at startup
Replies: 4
Views: 1984

Re: nfs-kernel-server not always start at startup

No one a hint?

Go to advanced search