Go to advanced search

by micksulley
Wed Feb 01, 2017 3:48 pm
Forum: General discussion
Topic: STICKY: USB boot now working on Pi3
Replies: 545
Views: 295370

Re: USB boot now working on Pi3

I just followed the instructions here - https://www.raspberrypi.org/blog/pi-3-booting-part-i-usb-mass-storage-boot/#comment-1269851 and got it working with a 1Tb Seagate FreeAgent drive (with it's own power supply) using the latest Jessie lite. The only problem I have is that it won't reboot. If I p...
by micksulley
Tue Jan 31, 2017 7:26 am
Forum: General discussion
Topic: Boot from Hard Disk?
Replies: 4
Views: 1240

Re: Boot from Hard Disk?

Many thanks for the links guys. I had missed it because I searched the forum for 'boot from hard disk' and because the search ignores 'boot' and 'from' it didn't seem to find these links.
by micksulley
Mon Jan 30, 2017 10:51 pm
Forum: General discussion
Topic: Boot from Hard Disk?
Replies: 4
Views: 1240

Boot from Hard Disk?

I read somewhere that Pi3 has the capability of booting from a hard disk rather than SD. As I have had many SD card failures I would really like to try this. Can anyone point me to instructions please?
Thanks
Mick
by micksulley
Sun Jan 08, 2017 11:46 am
Forum: Troubleshooting
Topic: SD Card Troubleshooting
Replies: 0
Views: 312

SD Card Troubleshooting

Can anyone point me to a good troubleshooting guide for SD cards please? I have had many occasions when a Pi just stops working because an SD card has failed in some way. Sometimes I can plug the SD in to my desktop (Linux Mint) and investigate, other times I can not see the card. It has just happen...
by micksulley
Fri Jan 06, 2017 6:23 pm
Forum: Troubleshooting
Topic: systemctl problem (I think!)
Replies: 5
Views: 958

Re: systemctl problem (I think!)

Thank you so much, it works!! :D

Do you know of any good documentation covering this? I found enough to make guesses at the setup, I had created one which worked for gwsetup and couldn't understand why gwd didn't.

Thanks for your help.
Mick
by micksulley
Tue Jan 03, 2017 6:13 pm
Forum: Troubleshooting
Topic: systemctl problem (I think!)
Replies: 5
Views: 958

Re: systemctl problem (I think!)

I have just tried running it as sudo and it still works OK. I also tried changing the service definition to pi, copy, enable, reboot and it is still not working. Service status still looks OK.

Any other ideas?
by micksulley
Tue Jan 03, 2017 12:11 pm
Forum: Troubleshooting
Topic: systemctl problem (I think!)
Replies: 5
Views: 958

systemctl problem (I think!)

I have installed a beta version geneweb, a family tree package which provides a web server on port 2317 to access the information. I can run it as /home/pi/geneweb/distribution/gwd and I can then access the web server on my desktop as pi-dev:2317 I wanted to create a service using systemcrl so it wo...
by micksulley
Mon Jan 02, 2017 2:32 pm
Forum: General discussion
Topic: Enable SSH when creating SD card
Replies: 17
Views: 72617

Re: Enable SSH when creating SD card

Great!! That will save me having to bring the TV downstairs every time I create a new SD!

Thanks guys
Mick
by micksulley
Mon Jan 02, 2017 1:39 pm
Forum: General discussion
Topic: Enable SSH when creating SD card
Replies: 17
Views: 72617

Enable SSH when creating SD card

Is there any way to enable SSH on a newly created SD card while it is still in my PC? All of my Pi's run headless and when I create a new SD card I have to go fetch a TV and USB keyboard just so I can enable SSH, everything else I can then do from my PC via SSH. It would be much more convenient if I...
by micksulley
Tue Oct 25, 2016 2:26 pm
Forum: Raspbian
Topic: Dirty Cow bug fix in place?
Replies: 17
Views: 7953

Re: Dirty Cow bug fix in place?

I'm not sure how this has happened, I looked at the others as well and they are Jessie. How can I upgrade this one to Jessie? I tried
sudo apt-get dist-upgrade
but it says nothing to upgrade.
by micksulley
Tue Oct 25, 2016 1:49 pm
Forum: Raspbian
Topic: Dirty Cow bug fix in place?
Replies: 17
Views: 7953

Re: Dirty Cow bug fix in place?

[email protected] ~ $ apt-cache policy Package files: 100 /var/lib/dpkg/status release a=now 500 http://archive.raspberrypi.org/debian/ wheezy/main armhf Packages release o=Raspberry Pi Foundation,a=oldstable,n=wheezy,l=Raspberry Pi Foundation,c=main origin archive.raspberrypi.org 500 http://raspberr...
by micksulley
Tue Oct 25, 2016 1:13 pm
Forum: Raspbian
Topic: Dirty Cow bug fix in place?
Replies: 17
Views: 7953

Re: Dirty Cow bug fix in place?

I have several pi's and have just tried to update them all sudo apt-get update sudo apt-get upgrade sudo apt-get dist-upgrade sudo apt-get install raspberrypi-kernel All but one are fine, but on that one I get E: Unable to locate package raspberrypi-kernel On that one I also ran sudo rpi-update but ...
by micksulley
Sun Oct 23, 2016 10:09 am
Forum: Troubleshooting
Topic: mysql exception
Replies: 3
Views: 722

Re: mysql exception

Thanks for the reply Dougie. mysql was running, but it gave me another thought, was it running at the time the script ran? I added a 5 second delay in the startup and now it works. Question - time delays never seem like the right way to do things, how can I check that mysql is running before I call ...
by micksulley
Sun Oct 23, 2016 9:41 am
Forum: Troubleshooting
Topic: mysql exception
Replies: 3
Views: 722

mysql exception

I have a Python script that runs on a Pi. All was well until I had an SD card corruption and I had to rebuild it all. As usual my records and backups were a little less than perfect, but I recreated it all and moved to the latest versions of everything. If I run my script from my user, with sudo for...
by micksulley
Sun Aug 21, 2016 12:38 pm
Forum: Troubleshooting
Topic: How to install specific version of Unison
Replies: 4
Views: 3137

Re: How to install specific version of Unison

Thanks for the replies. I did a bit more research and came up with this which allows using testing for specific packages - Edit (or create) your /etc/apt/preferences to contain: -------------------------------------------------------------------------- Package: * Pin: release o=Raspbian,a=stable Pin...
by micksulley
Sun Aug 21, 2016 10:43 am
Forum: Troubleshooting
Topic: How to install specific version of Unison
Replies: 4
Views: 3137

How to install specific version of Unison

I use unison to sync files between various machines including a few Pi's. Having upgraded my other machines they are now running unison Version: 2.48.3 and will not sync with the Pi's which are running unison Version: 2.40.65-2 I have run dist-upgrade on the Pi's, so this is the latest version avail...
by micksulley
Fri Jul 01, 2016 6:19 pm
Forum: Troubleshooting
Topic: Zero wifi/wireless keyboard problem
Replies: 3
Views: 1161

Re: Zero wifi/wireless keyboard problem

I really don't understand what is happening here! I have just started to gather the info you asked for and it is working fine for all configurations. I will continue to play around with it to see if I can recreate the issue, I will post the results if I manage to break it again. In the mean time tha...
by micksulley
Fri Jul 01, 2016 3:31 pm
Forum: Troubleshooting
Topic: Zero wifi/wireless keyboard problem
Replies: 3
Views: 1161

Zero wifi/wireless keyboard problem

I'm trying to use an Edimax wifi dongle with my Pi Zero and I have found a curious problem. I have a powered hub with the zero, wireless keyboard dongle and wifi dongle plugged in. The zero is plugged in with a micro/USB A cable into the USB port, so it serves as both USB and power. The wireless key...
by micksulley
Thu May 19, 2016 9:28 am
Forum: Beginners
Topic: Backup to encrypted usb hard drive
Replies: 0
Views: 483

Backup to encrypted usb hard drive

I have a Pi (current raspbian) that runs constantly controlling a heating system. I would like to also use it as backup storage for my server. I have installed a 3Tb usb hard drive, auto mounts and I have set up Unison to sync the data. This Pi is in a less secure location (remote from the house but...
by micksulley
Thu Mar 10, 2016 3:57 pm
Forum: Troubleshooting
Topic: Pi3 wifi dies - Solved
Replies: 15
Views: 7097

Re: Pi3 wifi dies - Solved

I just tried that, rebooted and iwconfig says Power Management:on

Is there anything else I need to do?
by micksulley
Thu Mar 10, 2016 1:47 pm
Forum: Troubleshooting
Topic: Pi3 wifi dies - Solved
Replies: 15
Views: 7097

Re: Pi3 wifi dies - Solved

Thanks that seems to have fixed it. In order to get it to happen at startup I modified /etc/network/interfaces. It took a few goes to get it right, it seems you need to add a line in the right place. This is what I have now # interfaces(5) file used by ifup(8) and ifdown(8) # Please note that this f...
by micksulley
Wed Mar 09, 2016 2:29 pm
Forum: Troubleshooting
Topic: Pi3 wifi dies - Solved
Replies: 15
Views: 7097

Pi3 wifi dies - Solved

I have a problem with my new Pi3, at boot the wifi is on and all is fine, however after a time (don't know how long) the wifi dies. I can restart it with
sudo ifdown wlan0 && sudo ifup wlan0

What can cause this and how do I fix it? It is running the latest Raspian.

Thanks
Mick
by micksulley
Sat Mar 05, 2016 3:14 pm
Forum: Other programming languages
Topic: Ocaml 4.02 on Raspbian
Replies: 1
Views: 1006

Ocaml 4.02 on Raspbian

I need to install Ocaml 4.02 or later on the latest Raspbian, standard repo has 4.01. Is there a PPA I can use for this?
by micksulley
Fri Feb 05, 2016 10:48 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1485
Views: 360715

Re: PiKrellCam: motion vector detect + OSD web interface

I have done tests on a PIR, just detecting, not triggering video, and it seemed to work fairly well, details here http://www.raspberrypi-spy.co.uk/2013/01/cheap-pir-sensors-and-the-raspberry-pi-part-1/ Yes my camera is inside looking through a window, I put a hole through the wall and mounted the PI...
by micksulley
Fri Feb 05, 2016 2:41 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1485
Views: 360715

Re: PiKrellCam: motion vector detect + OSD web interface

Is it possible to trigger via a PIR? PiKrellCam works fine for me most of the time but I am on a busy road, so set detection zone to just trigger on my driveway, but when it is wet I see the reflection of the traffic on the wet paving bricks and that triggers the motion detection. I feel that a PIR ...

Go to advanced search