Go to advanced search

by pumpkinpi
Tue Apr 04, 2017 2:31 am
Forum: Troubleshooting
Topic: eth0 not working anymore
Replies: 40
Views: 9282

Re: eth0 not working anymore

This is what dmesg shows us (not sure if this is helpful): $ dmesg [ 0.000000] Booting Linux on physical CPU 0x0 [ 0.000000] Linux version 4.9.19-v7+ ([email protected]) (gcc version 4.9.3 (crosstool-NG crosstool-ng-1.22.0-88-g8460611) ) #983 SMP Thu Mar 30 14:46:28 BST 2017 [ 0.000000] CPU: ARMv7 ...
by pumpkinpi
Tue Apr 04, 2017 2:26 am
Forum: Troubleshooting
Topic: eth0 not working anymore
Replies: 40
Views: 9282

Re: eth0 not working anymore

Ok, so this is what I see from the Pi when I ping my router and Wifi turned off on the Pi: $ ping 192.168.2.1 connect: Network is unreachable This is my /etc/network/interfaces file: interfaces(5) file used by ifup(8) and ifdown(8) # Please note that this file is written to be used with dhcpcd # For...
by pumpkinpi
Tue Apr 04, 2017 2:18 am
Forum: Troubleshooting
Topic: eth0 not working anymore
Replies: 40
Views: 9282

Re: eth0 not working anymore

Thanks for all the replies folks. I don't think the opposite port is borked {word of the day!} since I tried several ways to connect it to my router (through different switches). Three ways so far (with 3 different cables) and I get no response from my router or internet access from the pi. From my ...
by pumpkinpi
Mon Apr 03, 2017 2:26 am
Forum: Troubleshooting
Topic: eth0 not working anymore
Replies: 40
Views: 9282

eth0 not working anymore

Hi Friends, I have had a Pi 3 running as a security camera for a while with no issues. It was running Jessie. This week, I lost connection to it. I tried rebooting but still could not connect. So, I took the Pi down and built a new card with Jessie to see if it was something to do with the software ...
by pumpkinpi
Sun Mar 26, 2017 11:39 pm
Forum: General discussion
Topic: apt-get upgrade error [solved]
Replies: 12
Views: 3978

Re: apt-get upgrade error

Same here. Fixed with:

Code: Select all

cd /var/lib
sudo rm -R chksshpwd
PPi
by pumpkinpi
Sun Dec 18, 2016 11:10 pm
Forum: Raspbian
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1545
Views: 675100

Re: Kweb Suite (Minimal Kiosk Browser)

I found a way to do it with iframes.

PPi
by pumpkinpi
Sat Dec 17, 2016 6:06 pm
Forum: Raspbian
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1545
Views: 675100

Re: Kweb Suite (Minimal Kiosk Browser)

Is there a way I can edit the Right Click Pop-Up menu so that there is always a book mark there to a fixed web page? I am using this in kiosk mode without keyboard, iframes or program header so I have no way to navigate back to my home page. Right click works however and I would love to just pop a b...
by pumpkinpi
Mon Dec 12, 2016 5:20 am
Forum: General discussion
Topic: Raspbian with Read-only Root
Replies: 191
Views: 89543

Re: Raspbian with Read-only Root

Just tried this on a car based media server I built for the kids. Works! I didn't want to have any risk of corruptions on this thing. Nice little tutorial.

Thanks!

PPi
by pumpkinpi
Fri Nov 25, 2016 1:44 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5071
Views: 1347126

Re: RPi Cam Web Interface

Hi Folks,

I have a few cameras and have been having issues with massive video files being written (>1GB) to the drives for reasons I can't figure out. They have the extension .h264. I am using an echo command to enable and disable motion detection with md 0 and md 1.

Any ideas?

Thanks,
PPi
by pumpkinpi
Sun Nov 06, 2016 4:16 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5071
Views: 1347126

Re: RPi Cam Web Interface

Yes, I want it to be in the Simple view by default. I tried messing around with this block in index.php, but couldn't make it default to Simple. $toggleButton = "Simple"; $displayStyle = 'style="display:block;"'; if(isset($_COOKIE["display_mode"])) { if($_COOKIE["display_mode"] == "Simple") { $toggl...
by pumpkinpi
Fri Nov 04, 2016 8:16 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5071
Views: 1347126

Re: RPi Cam Web Interface

Is there a way that the initial screen can default to the "Simple" view rather than the "Full" view.

I don't see an option for that

Thanks,
PPi
by pumpkinpi
Thu Nov 03, 2016 4:17 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5071
Views: 1347126

Re: RPi Cam Web Interface

Wow. Thanks for the descriptions of what internal and external mean. Now I get it. I thought internal was "inside" and external was "outside". I randomly tried making this setting adjustment at my workplace yesterday (going to internal) and it worked perfectly. No issues with excessive files. Thanks...
by pumpkinpi
Tue Nov 01, 2016 11:16 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5071
Views: 1347126

Re: RPi Cam Web Interface

Hi, Trying to figure out how to reduce the number of false positives during motion detection. I had one camera on for 9 hours today and it recorded 500+ 2 second videos where absolutely nothing happened. The other camera I have recorded 100+. There were no sun spots, nothing that moves at all (resid...
by pumpkinpi
Tue Oct 25, 2016 11:51 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5071
Views: 1347126

Re: RPi Cam Web Interface

Thanks for the advice folks. I have been playing with it. I have not quite got it working the way I want it. It might be a permissions thing on my external drive. It does not seem to want to create the subfolders. I will report back on what works.

PPi.
by pumpkinpi
Mon Oct 24, 2016 12:35 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5071
Views: 1347126

Re: RPi Cam Web Interface

Hi Folks, I just recently discovered this package and have been playing around with it. Fantastic work! I was configuring motion manually before on my Pi, but this is waaaay better. I am having a small issue that I am hoping somebody can help with. I am attempting to save motion detection videos to ...
by pumpkinpi
Sat Sep 10, 2016 5:55 pm
Forum: Raspbian
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1545
Views: 675100

Re: Kweb Suite (Minimal Kiosk Browser)

PM sent with more details. Thanks!
by pumpkinpi
Sat Sep 10, 2016 1:45 pm
Forum: Raspbian
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1545
Views: 675100

Re: Kweb Suite (Minimal Kiosk Browser)

Hmm... good idea. I did not. Ok, so Ephiphany, Midori, Netsurf get the same results as kweb. I just don't get why it works fine in kweb on an RPi2 with Wheezy and not on an RPi3 with Jessie with all the same settings. I really would like to use kweb due to the speed and kiosk mode. Any other ideas? ...
by pumpkinpi
Sat Sep 10, 2016 1:47 am
Forum: Raspbian
Topic: Kweb Suite (Minimal Kiosk Browser, omxplayerGUI)
Replies: 1545
Views: 675100

Re: Kweb Suite (Minimal Kiosk Browser)

Almost a year ago, I tried using Kweb on Jessie with my in house kiosk application. See post string here: https://www.raspberrypi.org/forums/viewtopic.php?p=846075#p846075 Well, I ended up trying to get my buttons to work on Jessie and reverted to Wheezy and have been using it since. Now, I am back ...
by pumpkinpi
Fri Aug 26, 2016 6:18 pm
Forum: Official Foundation Display
Topic: RPi Touchscreen - How to turn it off?
Replies: 42
Views: 69654

Re: RPi Touchscreen - How to turn it off?

What happens when you do

Code: Select all

sudo nano bl_power
and try to save the file after changing the 0 to a 1?

PPi
by pumpkinpi
Mon May 23, 2016 1:22 am
Forum: Troubleshooting
Topic: Basic GPS USB setup
Replies: 11
Views: 17375

Re: Basic GPS USB setup

I have been tied up lately and haven't had much time to work on this. Last night found a solution to the time sync and GPS setup that seems to work really well. Time sync details here: http://engineering-diy.blogspot.ca/2013/10/keep-your-linux-clock-synchronized-with.html Basically, I am using Navit...
by pumpkinpi
Wed May 04, 2016 11:54 pm
Forum: Troubleshooting
Topic: Basic GPS USB setup
Replies: 11
Views: 17375

Re: Basic GPS USB setup

One of the things that drives me crazy about computers is that something can work fine one day and then not the next. Now, everything was working fine last night, but this afternoon when I booted my system, I got a GPS fix, but the time does not sync. I have stopped and started ntp, but it still doe...
by pumpkinpi
Tue May 03, 2016 11:37 pm
Forum: Troubleshooting
Topic: Basic GPS USB setup
Replies: 11
Views: 17375

Re: Basic GPS USB setup

Ok, so this command: minicom -b 9600 -o -D /dev/ttyUSB0 is giving me lots of data that cannot be read. It just looks like funny characters. Just like the command: sudo cat /dev/ttyUSB0 I tried putting this in my rc.local before the exit 0: stty -F /dev/ttyUSB0 115200 service gpsd restart gpspipe -r ...
by pumpkinpi
Tue May 03, 2016 5:35 pm
Forum: Troubleshooting
Topic: Basic GPS USB setup
Replies: 11
Views: 17375

Re: Basic GPS USB setup

Ha ha! Looks like I have to be told twice to get it right. I will review it all again tonight in detail. Thanks for your patience.

PPi.
by pumpkinpi
Tue May 03, 2016 4:00 pm
Forum: Troubleshooting
Topic: Basic GPS USB setup
Replies: 11
Views: 17375

Re: Basic GPS USB setup

Oh, that is fascinating. In this thread, I was looking for help to set the time of my computer from the GPS and it was a lot more complicated than I expected. https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=146447&p=964968 If ntp works like you describe, then that sounds a lot easier. I will...
by pumpkinpi
Tue May 03, 2016 3:40 pm
Forum: Troubleshooting
Topic: Basic GPS USB setup
Replies: 11
Views: 17375

Re: Basic GPS USB setup

One question. What is this line?
gpspipe -r -n 1 &
PPi

Go to advanced search