Go to advanced search

by HelloPi
Wed Nov 13, 2019 3:51 pm
Forum: Troubleshooting
Topic: Monitor goes to sleep within minutes
Replies: 0
Views: 32

Monitor goes to sleep within minutes

... currently. My setup to disable sleep mode: sudo nano /etc/xdg/lxsession/LXDE-pi/autostart Added below part @xset s noblank @xset s off @xset -dpms I couldn’t find [SeatDefaults] ...
by StevenDJaques
Sun Nov 10, 2019 5:09 pm
Forum: Raspbian
Topic: SOLVED: How do I get multiple backgrounds back?
Replies: 6
Views: 402

Re: How do I get multiple backgrounds back?

... necessary. The problem was in ~/,config/lxsession. I replaced the LXDE and LXDE-pi directories with the ones from my Pi3. ORIGINAL, no working multiple backgrounds LXDE: autostart @lxpanel --profile LXDE @pcmanfm --desktop --profile LXDE @xscreensaver -no-splash ...
by Kendek
Mon Nov 04, 2019 12:54 pm
Forum: Advanced users
Topic: automatic startup Bash script
Replies: 6
Views: 184

Re: automatic startup Bash script

henribusio wrote:
Mon Nov 04, 2019 12:51 pm
bash: /home/pi/.config/lxsession/LXDE-pi/autostart: No such file or directory

Code: Select all

mkdir -p ~/.config/lxsession/LXDE-pi
touch ~/.config/lxsession/LXDE-pi/autostart
nano ~/.config/lxsession/LXDE-pi/autostart
by henribusio
Mon Nov 04, 2019 12:51 pm
Forum: Advanced users
Topic: automatic startup Bash script
Replies: 6
Views: 184

Re: automatic startup Bash script

well not for me because i get this error

bash: /home/pi/.config/lxsession/LXDE-pi/autostart: No such file or directory

however with this it did work

sudo nano /etc/xdg/lxsession/LXDE-pi/autostart
by Kendek
Mon Nov 04, 2019 12:47 pm
Forum: Advanced users
Topic: automatic startup Bash script
Replies: 6
Views: 184

Re: automatic startup Bash script

henribusio wrote:
Mon Nov 04, 2019 12:37 pm
i found a solution adding it to sudo nano /etc/xdg/lxsession/LXDE-pi/autostart
The correct file is

~/.config/lxsession/LXDE-pi/autostart

if you want to execute a script from your home directory.
by henribusio
Mon Nov 04, 2019 12:37 pm
Forum: Advanced users
Topic: automatic startup Bash script
Replies: 6
Views: 184

Re: automatic startup Bash script

i found a solution adding it to sudo nano /etc/xdg/lxsession/LXDE-pi/autostart
by PhatFil
Tue Oct 29, 2019 4:40 am
Forum: General discussion
Topic: viewing my windows desktop from raspberry pi on bootup?
Replies: 5
Views: 326

Re: viewing my windows desktop from raspberry pi on bootup?

... sudo nano /etc/xdg/lxsession/LXDE-pi/autostart This is the same file that is edited if you are disabling the screen saver, it causes ...
by david_1234
Mon Oct 28, 2019 3:29 pm
Forum: Beginners
Topic: PI4-buster Vs. PI3-stretch
Replies: 2
Views: 173

PI4-buster Vs. PI3-stretch

... in /usr/share/plymouth/themes/pix/ sudo nano /home/pi/.config/lxsession/LXDE-pi/autostart.txt @lxpanel --profile LXDE-pi @pcmanfm --desktop --profile LXDE-pi @xset s noblank ...
by klricks
Mon Oct 28, 2019 1:50 pm
Forum: General discussion
Topic: Global autostart file
Replies: 2
Views: 118

Re: Global autostart file

Code: Select all

/etc/xdg/lxsession/LXDE-pi/autostart
by pcmanbob
Mon Oct 28, 2019 1:50 pm
Forum: General discussion
Topic: Global autostart file
Replies: 2
Views: 118

Re: Global autostart file

The auto start file in buster is at " /etc/xdg/lxsession/LXDE-pi/autostart "
by jvteam
Mon Oct 28, 2019 1:40 pm
Forum: General discussion
Topic: Global autostart file
Replies: 2
Views: 118

Global autostart file

... The fix listed is this Issue: cant find /home/pi/.config/lxsession/LXDE-pi/autostart Solution: A) Copy the content from the global autostart into your /home/pi/.config/lxsession/LXDE-pi/autostart ...
by topguy
Mon Oct 28, 2019 12:50 pm
Forum: General discussion
Topic: Start Google Assistant on boot
Replies: 3
Views: 197

Re: Start Google Assistant on boot

... - Why do you want it running in a terminal window ? It sound like using LXDE autostart is what you are looking for, I think this is still a good guide... https://www.raspberrypi-spy.co.uk/2014/05/how-to-autostart-apps-in-rasbian-lxde-desktop/ ...
by Jackallitor
Fri Oct 25, 2019 9:58 am
Forum: Beginners
Topic: Open chromium on each monitor
Replies: 4
Views: 300

Open chromium on each monitor

... and using 2 virtual displays. However i have managed to edit the autostart file at "/etc/xdg/lxsession/LXDE-pi/autostart" and added the following code @xset s off @xset -dpms @xset s noblank @chromium ...
by klricks
Thu Oct 24, 2019 6:17 pm
Forum: Raspbian
Topic: Disable Screen Sleep?
Replies: 4
Views: 289

Re: Disable Screen Sleep?

Open autostart

Code: Select all

sudo nano /etc/xdg/lxsession/LXDE-pi/autostart
Add the following 2 commands to what is already there:

Code: Select all

@xset s off
@xset -dpms
by vallad
Thu Oct 24, 2019 10:51 am
Forum: Raspbian
Topic: [Guide] Kodi on Raspbian Buster
Replies: 162
Views: 20584

Re: [Guide] Kodi on Raspbian Buster

... "Group" fields above accordingly. Option 2 (with desktop): If you want autostart Kodi at boot but also keep the Desktop Environment on the background, just edit the file (with sudo) /etc/xdg/lxsession/LXDE-pi/autostart and add a line, preferably at the beginning of the file with: ...
by bluePiuser
Thu Oct 24, 2019 2:57 am
Forum: Camera board
Topic: Image capture program does not work at startup
Replies: 3
Views: 407

Re: Image capture program does not work at startup

I use an autostart similar to: @lxpanel --profile LXDE-pi @pcmanfm --desktop --profile LXDE-pi @xscreensaver -no-splash @point-rpi[/code/ @/home/pi/startpythonprogram.sh ...
by klricks
Wed Oct 23, 2019 11:18 pm
Forum: Camera board
Topic: Image capture program does not work at startup
Replies: 3
Views: 407

Re: Image capture program does not work at startup

... fine, but when I add it to the Linux startup, in "/etc/xdg/lxsession/LXDE-pi/autostart", so that it runs at boot does not work. The program is running, I can see it running ...
by RunRoad
Wed Oct 23, 2019 1:37 pm
Forum: Camera board
Topic: Image capture program does not work at startup
Replies: 3
Views: 407

Image capture program does not work at startup

... fine, but when I add it to the Linux startup, in "/etc/xdg/lxsession/LXDE-pi/autostart", so that it runs at boot does not work. The program is running, I can see it running ...
by mcole79
Mon Oct 21, 2019 2:50 pm
Forum: Beginners
Topic: Auto start Chromium Browser not working
Replies: 6
Views: 244

Auto start Chromium Browser not working

... auto logs in, the pi boots to desktop, however I cannot seem to get the autostart function to work. I dont appear to have the LXDE folders everyone seems to reference. (I've tried showing hidden and system folders, no ...
by Paeryn
Mon Oct 21, 2019 2:06 pm
Forum: Beginners
Topic: autoboot script does not function
Replies: 5
Views: 351

Re: autoboot script does not function

Also what is the difference in paths, I've seen online that some autostart files are in /.config/lxsession/LXDE-pi directory instead. Is there a difference between this? Also the autostart file in the ...
by pcmanbob
Mon Oct 21, 2019 12:07 pm
Forum: Beginners
Topic: autoboot script does not function
Replies: 5
Views: 351

Re: autoboot script does not function

... output then try calling you program like this in the /etc/xdg/lxsession/LXDE-pi/autostart file @lxterminal -e python /home/pi/program.py assuming your program.py in located ...
by stanwin00
Mon Oct 21, 2019 6:42 am
Forum: Beginners
Topic: autoboot script does not function
Replies: 5
Views: 351

autoboot script does not function

... script #!/bin/sh cd / cd directory sudo python program.py in the autostart file under /etc/xdg/lxsession/LXDE-pi i have the following lines @lxpanel -- profile LXDE-pi @pcmanfm --desktop --profile ...
by klricks
Sun Oct 20, 2019 4:07 pm
Forum: General discussion
Topic: "Click here..." is annoying
Replies: 8
Views: 998

Re: "Click here..." is annoying

Open autostart and remove or comment out point-rpi. sudo nano /etc/xdg/lxsession/LXDE-pi/autostart #point-rpi Tried the above edit and rebooted pi , still get the "Click here to open applications ...
by Paeryn
Sun Oct 20, 2019 1:15 pm
Forum: General discussion
Topic: "Click here..." is annoying
Replies: 8
Views: 998

Re: "Click here..." is annoying

Open autostart and remove or comment out point-rpi. sudo nano /etc/xdg/lxsession/LXDE-pi/autostart #point-rpi Tried the above edit and rebooted pi , still get the "Click here to open applications ...
by pcmanbob
Sun Oct 20, 2019 12:59 pm
Forum: General discussion
Topic: "Click here..." is annoying
Replies: 8
Views: 998

Re: "Click here..." is annoying

klricks wrote:
Thu Jun 27, 2019 7:39 pm

Open autostart and remove or comment out point-rpi.

Code: Select all

sudo nano /etc/xdg/lxsession/LXDE-pi/autostart

Code: Select all

#point-rpi
Tried the above edit and rebooted pi , still get the "Click here to open applications menu" on my pi4 running buster.

Go to advanced search