Go to advanced search

by vaidasm
Sat Dec 17, 2016 1:09 pm
Forum: Raspberry Pi OS
Topic: I can't use apt-get cause I've have held broken package
Replies: 28
Views: 7182

Re: I can't use apt-get cause I've have held broken package

Thank You, now it works without changing any file.
by vaidasm
Mon Dec 12, 2016 6:52 pm
Forum: Raspberry Pi OS
Topic: I can't use apt-get cause I've have held broken package
Replies: 28
Views: 7182

Re: I can't use apt-get cause I've have held broken package

I have removed those dependencies, but I don't think it is the right way of solving this problem... I don't know if in the future there will be more problems because of removing these packages...
by vaidasm
Mon Dec 12, 2016 6:13 pm
Forum: Raspberry Pi OS
Topic: I can't use apt-get cause I've have held broken package
Replies: 28
Views: 7182

Re: I can't use apt-get cause I've have held broken package

ShiftPlusOne wrote:Thanks, I will take a look at it tomorrow. Looks like there may be a missing -dev package.
ShiftPlusOne,

maybe You looked at it? :)
by vaidasm
Mon Dec 12, 2016 7:00 am
Forum: Raspberry Pi OS
Topic: I can't use apt-get cause I've have held broken package
Replies: 28
Views: 7182

Re: I can't use apt-get cause I've have held broken package

The only quick workaround (not solution) is to remove libgtk${GTK_VERSION}-dev, libegl1-mesa-dev, libgles1-mesa-dev and libgles2-mesa-dev from the install_dependencies.sh script, as sudgested sy1vain in OpenFrameworks forum. Yesterday I did it and OpenFrameworks compiled, but I do not know what will...
by vaidasm
Sun Dec 11, 2016 6:30 am
Forum: Raspberry Pi OS
Topic: I can't use apt-get cause I've have held broken package
Replies: 28
Views: 7182

Re: I can't use apt-get cause I've have held broken package

After dist-upgrade the same situation: The following packages have unmet dependencies: libegl1-mesa-dev: Depends: libwayland-dev (>=1.2.0) but it is not going to be installed libgtk-3-dev: Depends: libwayland-dev (>=1.4.0) but it is not going to be installed E:Unable to correct problems, you have he...
by vaidasm
Sun Dec 11, 2016 5:54 am
Forum: Raspberry Pi OS
Topic: I can't use apt-get cause I've have held broken package
Replies: 28
Views: 7182

Re: I can't use apt-get cause I've have held broken package

Hello, thank you for the answer. I'm using simple upgrade. I am not expert in this kind of stuff, but somewhere around 3 years ago I was playing with RPI B+ and openFrameworks, it worked like a charm. Now I got new rpi3 for playing and decided to try the same old program which I wrote 3 years ago (r...
by vaidasm
Sat Dec 10, 2016 3:48 pm
Forum: Raspberry Pi OS
Topic: I can't use apt-get cause I've have held broken package
Replies: 28
Views: 7182

Re: I can't use apt-get cause I've have held broken package

Hello, i have very similar problem, but I did not delete any file and my raspi.list and sources.list files looks like normal - the same as in upper comments. When I am installing openframeworks (tried few releases: v0.8.4, v0.9.3, v0.9.7) with few raspbian versions (2016-09-23-raspbian-jessie, 2016-...

Go to advanced search